IRC channel logs

2023-08-28.log

back to list of logs

<damo22><(23:20:46) luckyluke: damo22: you can just add it to the gnumach command line> nope that does not work
<damo22>i got a general protection fault on iret
<damo22>right before it spawned a shell
<youpi>$ ./main
<youpi>Hello, world!
<youpi>\o/
<youpi>(rust-compiled)
<youpi>$ ./rustc --print target-list | grep hurd
<youpi>i686-unknown-hurd-gnu
<youpi>$ ~/stage2/bin/rustc src/main.rs
<youpi>Segmentation fault
<youpi>ok, not so complete :)
<damo22>interesting
<Gooberpatrol66>nice
<youpi>$ ./main
<youpi>Hello, world!
<youpi>\o/
<youpi>this time with the hurd rustc running on hurd :)
<youpi>it took me some time to reverse-engineer what actually needs to be copied, rust's x.py build script doesn't do everything...
<kilobug>youpi: congrats :)
<youpi>congrats to vedant ;)
<youpi>he did the painful work :)
<youpi>now, it will take some time to end up in the debian packaging, since that is relatively out-of-date
<youpi>and I think we don't want to spend time on backporting the port work :)
<kilobug>next step is to write bindings so we can write translators in rust ? ;)
<youpi>next step is porting cargo
<youpi>there are probably various syscalls that it makes
<youpi>also, getting the thing actually merged-in
<youpi>well, also, build rust with rust on hurd
<youpi>so we can actually run testsuites etc.
<youpi>for now it was just a "pray & launch"
<kilobug>I see, still lots of work, but nice to see things going forward :)
<youpi>at least it's incremental work
<youpi>once we get the rust port merged in
<nikolar>Kek don't tell me there are plans to use rust in the Hurd
<azert>did I hear it right? rewriting the hurd in rust?
<youpi>there aren't plans
<youpi>just people having ideas
<youpi>just like there was about using perl, scheme, etc.
<youpi>please don't distort/amplify rumors
<youpi>(personnally, I really don't see the rust ecosystem as reasonable, rustc and cargo are not even using the same version of rustix...)
<nikolar>I was joking but I do agree with you youpi
<azert>same
<nikolar>It's a shame it was let into linux
<youpi>from a programming langage point of view it makes a lot of sense
<youpi>but I'm really afraid of the maintenance cost
<youpi>problem being that people pushing for it apparently have a lot of time to spend
<youpi>so that might not show up yet
<azert>it should have been written as a C extension
<nikolar>Also I really hate their need to reimplement everything in rust
<youpi>that also does make some sense
<youpi>I'd way much more trust a rusty libxml than the C libxml
<azert>last time i checked, rust didn't have a stable abi
<nikolar>I really wouldn't trust xml :)
<youpi>3Building bootstrap
<youpi>this is looking good
<youpi>only way slower than on the lab 52-core machine :)
<youpi>bootstrap completed :D
<nikolar>Nice
<youpi>now onto stage 1
<youpi>fortunately I managed to convince it *not* to rebuild a complete llvm and just use the one from debian