IRC channel logs

2023-07-22.log

back to list of logs

<damo22>janneke: i havent tried to build that package before
<damo22>janneke: which getauxval() is it trying to read?
<damo22>i assume it gets ENOENT
<damo22>if its AT_SECURE, there is a patch for that in debian's glibc
<damo22>region_block_ioport_op () seems to be correctly handling io region block r/w
<damo22>so it turns out you *can* expose the io ports as a file
<damo22>it uses in/out under the hood depending on the width of the access
<damo22>how do you implement sleeping locks instead of spinlocks?
<damo22>looks like the vm_page_queue_lock is the most contended
<janneke>damo22: that's a helpful question
<janneke>i believe it's a python program that fails like this, as the gobject-introspection sources do not contain getauxval, and it's written in python
<janneke>so, it's probably AT_MINSIGSTKSZ
<janneke> https://github.com/python/cpython/blob/3.10/Modules/faulthandler.c#L1398
<damo22>janneke: see debian/patches/git-updates.diff in glibc ?
<damo22>which version of glibc are you using for hurd?
<janneke>ACTION looks
<janneke>we're using 2.37 + patches
<janneke>=> https://git.savannah.gnu.org/cgit/guix.git/tree/gnu/packages/base.scm#n1443
<janneke>this one? https://salsa.debian.org/glibc-team/glibc/-/blob/sid/debian/patches/git-updates.diff
<damo22>i am struggling how to get the 2.37 source tarball in debian
<damo22>looks like dl_minsigstacksize is a constant on hurd ?
<damo22>not the function, i mean what it returns or something
<damo22>i cant find it overridden in any glibc file
<damo22>i think the problem is, AT_MINSIGSTKSZ is defined in /usr/include/i386-gnu/bits/auxv.h but it doesnt implement it?
<damo22>so cython testing for that define might be not the right test?
<damo22>or it should be implemented
<damo22>_dl_show_auxv (void)
<damo22>{
<damo22> /* There is nothing to print. Hurd has no auxiliary vector. */
<janneke>hmm?
<janneke>that's interesting
<damo22>maybe it should not install auxv.h
<damo22>idk
<janneke>yeah, thanks for getting me on this track
<damo22>i have no clue if we want an aux vector on hurd or not
<janneke>maybe it's easiest to just look at a python package build and inspect/instrument faulthandler.c
<janneke>hmm, when building on guix, AT_MINSTACK_SIZE is not defined
<janneke>so it seems that i've been looking wrong
<janneke>and it might as well be AT_SECURE, as you suggested