IRC channel logs

2023-06-15.log

back to list of logs

<gabber>... i'd rather not tell
<gabber>ok, since you seem so nice, i'll do it anyways. so basically i've tried (next to reading all i could on the topic of Hurd) just added the necessary host_platform case to configure.ac and tried the ./configure && make route and fixed the problems along the way. i've copied the source tree from i386 directories
<gabber>sorry for my mediocre phrasing -- i'm a bit tired
<luckyluke>you should probably also check host_cpu
<gabber>will do! i suppose you've been working on the master-x86_64 branch?
<luckyluke>no, that is quite old IIRC... you can find the last version on the master branch
<gabber>so the _Static_assert calls from MIG are architecture independent? most structs are defined with old-style integer types (long, short, etc) and not uint16, etc -- the long, short etc terminology refers to other sizes in RISC-V than in x86
<gabber>nvm, thanks for the pointers! i gotta leave soon
<gabber>btw is this the best channel to reach out to other Hurd devs or would a mailing list be preferrable?
<luckyluke>Which data model is used on riscv64?
<luckyluke>Mailing list is also good, especially for more detailed discussions
<gabber>WDYM data model?
<_Random>hey guys, is hurd only 32 bit or is 64 bit an option ?
<zamfofex>_Random: As far as I know, there is support for running the kernel in 64 bits, but userland programs will still be in 32 bits.
<youpi1>zamfofex: actually the full 64bit work is also almost ready
<VedantT>When building the rust compiler, it is better to build have a full build or a stage build since we are only concerned with a specific library?
<youpi1>a stage build will be enough first
<youpi1>we'll try the full build later
<youpi1>for now we only need what's enough to build rustc itself
<VedantT>I almost accidentally built the three libraries so I freaked out
<youpi1>most of the libraries will probably just compile alright because they just depend on the cpu architecture
<youpi1>it's really "only" the system-related parts that will need to be fixed
<youpi1>and debugged :)
<VedantT>It says I will have a ability to customize the config.toml by referring to config.example.toml and src/bootstrap/defaults, I am assuming I could go with the default config for now to run the build
<VedantT>I see, thanks for the clarification
<VedantT>so essentially this command ./x.py build --stage 2 compiler/rustc would build stage0,1,2 compilers (a full build), compared to ./x.py build which simply builds the stage0 compiler, since we are working on a library a night build as you mentioned would be enough youpi1
<youpi1>possibly, that depends if the result is enough to build a cargo that can run on the hurd
<VedantT>I have the stage 0 and stage 1 build now which is enough to create the rustup toolchain but a full build is needed at some point
<VedantT>In this case would my target be x86_32? ./x.py build --target x86_64-unknown-linux-gnu --target wasm32-wasi