IRC channel logs

2023-06-12.log

back to list of logs

<damo22>Pellescours: what is the problem with DMA on ide?
<damo22>janneke: /gnu/store/h8b66idp06w2n0w8n3gm2fj94dqy1j29-hurd-v0.9.git20230216/hurd/pfinet: file_name_lookup eth0: No such file or directory
<damo22>/gnu/store/h8b66idp06w2n0w8n3gm2fj94dqy1j29-hurd-v0.9.git20230216/hurd/pfinet: device_open(eth0): (os/device) no such device
<damo22>youpi: how does netdde expose a mach device interface for a network card? i guess there are low level ioctls that control the card(s) but how does that map onto a mach device?
<janneke>damo22: i've used
<janneke>settrans --active --create --keep-active /servers/socket/2 /hurd/pfinet \
<janneke> --ipv6=/servers/socket/26 --interface=/dev/eth0 --address=192.168.178.21 \
<janneke> --netmask=255.255.255.0 --gateway=192.168.178.1
<youpi>yes it does
<damo22>im trying to figure out how rumpnet could fit in
<damo22>to replace the driver part
<youpi>we could have /dev/net that either points to /dev/netdde or /dev/rumpnet
<damo22>i think rumpnet supports more network cards than netdde
<damo22>but it may not be a drop in replacement
<damo22>i need to work out what the interface is
<damo22>i think i need to tease it out of ddekit
<llp>Sorry if I am outdated. I was reading some stuff on GNU Hurd page about 64-bit migration, and one of the problems was on MIG. Is that a current problem or that information is outdated?
<youpi>damo22: not really ddekit, but libmachdevdde
<youpi>notably its net.c
<youpi>llp: depends which details you are talking about
<youpi>the gnu.org website pages are indeed outdated, see the topic for the latest wiki pages urls
<llp>I was reading that URL that is on the topic of this group: https://darnassus.sceen.net/~hurd-web/open_issues/64-bit_port/
<youpi>then the details there are up to date
<damo22>thanks youpi
<damo22>am i understanding right that network only has device_write, so is it unidirectional?
<youpi>?? there's device_read as well
<llp>I looked for information about that "mig migration" after 2013 and I found nothing on IRC logs, so there was no solution for that. Thanks, @youpi . I wanna study more about that.
<youpi>damo22: ah, no, it's deliver_msg that sends mig messages by hand
<youpi>llp: the wiki pages don't necessarily contain all relevant irc logs
<llp>I download almost all of them and tryied "grep" it.
<youpi>damo22: I don't know why it's a NET_RCV_MSG_ID rather a device_read
<youpi>apparently that's how gnumach works
<youpi>llp: remember that there's also a mailing list...
<damo22>ok so gnumach handles the network receive packets as mach messages
<damo22> -r total_ram
<damo22> Sets the limit of kernel memory allocatable by the server to total_ram as opposed to the
<damo22> default which allows the server to allocate as much memory as the host will give it. This
<damo22> parameter is especially useful for VFS servers, since by default the virtual file system
<damo22> will attempt to consume as much memory as it can, and accessing large files can cause an
<damo22> excessive amount of memory to be used as file system cache.
<damo22>that probably explains why rumpdisk uses a lot of ram
<damo22> case 'r':
<damo22> setenv("RUMP_MEMLIMIT", optarg, 1);
<Pellescours>damo22: it's working but wotj the currznt gnumach it's disabled (except with a patch) because it try to alloc_allign with an alignment greater than gnumach page size
<damo22>it doesnt seem to be disabled, it tries to use it
<damo22>at least in janneke's guix image
<damo22>how do you disable DMA in ide at runtime?
<Pellescours>it tries but fails to allign alloc and so, not use it (at least in vm)
<damo22>hmm
<damo22>it hangs on my T500
<damo22>but says DMA is available on ide
<Pellescours> http://git.zammit.org/gnumach-sv.git/tree/vm/vm_user.c?h=master#n595
<Pellescours>try to allow here ^ `if ( pallign % PAGE_SIZE == 0)`
<damo22>why cant we merge a patch to fix it
<Pellescours>i don't have my computer with me this week
<janneke>damo22: to state the possibly obvious, you need to use "noide" to disable gnumach's ide driver in my current image
<damo22>janneke: sorry, i am talking about rumpdisk's ide driver, it is currently broken with a gnumach bug
<damo22>piixide to be more precise
<damo22>so the noide flag causes it to hang on T500 for example
<janneke>right, that makes (more) sense ;)
<damo22>Tool /usr/bin/mig :
<damo22>gcc: error: missing filename after '-o'
<damo22>ERROR: failed to build wrapper for MIG
<damo22>cant build rumpkernel on hurd itself
<janneke>ACTION has been working towards a native build for guix hurd but hasn't gotten as far as rumpkernel yet
<janneke>66% of packages for debian is pretty impressive!
<damo22>im talking about the debian package, it seems broken on debian
<janneke>yeah, i got that
<zamfofex>janneke: I just wanted to say thank you for your work, by the way! (And to everyone else too, of course!)
<janneke>zamfofex: yeah, now we need to finish, clean-up and release
<damo22>i think the last few commits broke native build
<damo22>i am trying to build latest actual uploaded package now
<janneke>ah "great", so it worked before
<janneke>that might have been my bad ...
<damo22>no probs its not released yet
<damo22>but i got confused because it didnt build
<damo22>we actually build all the phy drivers as a library but it doesnt get installed
<damo22>:|
<damo22>librumpdev_miiphy.a
<janneke>the build system is quite a challenge
<janneke>the install phase is also interesting/non-existent, it will overwrite previously copied libraries iirc
<janneke>but hey, it works, which is already pretty nice
<damo22>yeah
<damo22>i spent quite some time fiddling with rump builds too
<damo22>we need to start actually using these drivers
<damo22>i found a dhcp client written for rump
<damo22>so i should be able to write a net driver translator at some point
<luckyluke>anyone seeing a cpu reset (caused by triple fault) on full x86_64? I have some draft patches to fix the fsbase and segment issues, but I'm not sure if I introduced something worse...
<luckyluke>I only see the reset after installing several packages with debootstrap --second-stage
<youpi>luckyluke: I'm not getting any with commenting the ds/es writes in locore.S