IRC channel logs

2023-03-21.log

back to list of logs

<damo22>youpi: did you change all of simple locks to be sleeping spin locks?
<damo22>braunr said he implemented "queued spin locks" in x15 and might be interesting for gnumach. There may currently be no cooperation between gnumach and the host scheduler choosing to run the vm or not
<youpi>damo22: simple locks can be spin locks or queued spin locks, that won't change their behavior concerning scheduling
<youpi>yes, there is no cooperation between a guest kernel and a host kernel
<youpi>that's why you shouldn't virtualize more cpus than what the host can provide
<youpi>that's true for all guest systems :)
<damo22>ok
<youpi>queued spin locks can be interesting, yes, but that's *not* what will solve the current terrible slowdown
<youpi>queued spin locks are interesting only for large smp machines
<damo22>i am working on making lock monitoring print the lock names
<damo22>it doesnt work
<damo22>the symbol lookup returns the address as a string
<damo22>db_printsym((db_addr_t) li->lock, DB_STGY_ANY);