IRC channel logs

2023-03-09.log

back to list of logs

<damo22>this smp work needs some youpi magic to make it progress
<damo22>i dont know what to do now
<damo22>how do we review all the locking
<damo22>from my measurements with lock monitoring, the absolute number of locks doesnt change much with -smp {1, 2, 4, 6, 8}
<damo22>but the boot speed slows down as you increase cores
<damo22>with the biggest jump between 1 and 2 i think
<damo22>1 being usable and 2 being so slow it is unusable
<damo22>smp 1 has no failed locks, but each additional core accumulates hundreds of failed locks
<damo22>maybe some of those failed locks are critical and cause significant delays?
<AwesomeAdam54321>damo22: Possibly, is it difficult to debug it with gdb?
<damo22>debug what exactly?
<damo22>i think we need statistics on how long each lock is held for?
<AwesomeAdam54321>debug why the locks fail
<damo22>i dont know what a failed lock means, but its most likely that the lock was unable to be taken straight away
<damo22>and caused a delay until it was able to be locked
<damo22>its not something that breaks the kernel, it actually boots, just slow
<damo22>what would be interesting is to set that special flag in grub that enters kdb when its about to resume the first task and then make kdb print the lock statistics at exactly the same step in the boot process for different numbers of cpus
<damo22>i kind of did that, but manually
<damo22>but we also really need timing stats
<damo22>the lip() function only prints total stats for all locks, i dont know if it tallies by lock type, would be interesting if it showed a breakdown of locks
<youpi>damo22: I don't think the hundreds of fail locks can explain the slowdown. I don't think we should assume that it's locks that take time. One way to debug this from outside with gdb, is to interrupt at random the OS, and see what it is doing. Doing that several times, you will have an idea where it spends time
<luckyluke>Could it be useful to trace the context switches?
<tifpifs>Hello, gnu world :)
<tifpifs>Just a new user of IRC; testing my install.
<tifpifs>Installed HexChat client and want to see if everything working on my machine; giving some channels a test and look around.
<tifpifs>Just curiosity, is this a real one irc channel for GNU/hurd developers?
<ThinkT510>this is the main channel yes
<ThinkT510>most hurd dev tends to happen on debian
<tifpifs>I am also, comparatively speaking, really new to GNU/Linux as well. In a matter of few months just started first time ever in my life studying/giving effort of transitioning into Linux.
<ThinkT510>nice
<tifpifs>But I already know about FSF, its visions (which I agree to), Linux kernel, Hurd kernel stories.
<tifpifs>Somewhat recently graduated from university (studied computer science + robotics in short). Was starting even before university become aware of commercial/proprietary software inherent evils (so to speak). And after uni finally started personally moving on to Linux.
<tifpifs>I found this whole thing, both the Linux and GNU efforts incredible.
<tifpifs>Now I am just experimenting and getting used to what is where, as well getting used to irc channel's ecosystem (lets put it that way for now).
<ThinkT510>open source is great. plenty to explore
<ThinkT510>you can register an account on libera if you want to get a cloak to cover your ip address
<tifpifs>So far I am happy to study even Linux; getting used to terminal, packages, other basics.
<tifpifs>Yes, this whole privacy thing is important to me also. Slowly try to study and explore of how to make myself anonymous and simply not so cheaply sucked out for data unit of society.
<tifpifs>Happened to get my copy of Edward Snowden's "Permanent record". It makes think carefully.
<lissobone>ThinkT510: https://www.gnu.org/philosophy/words-to-avoid.en.html#Open
<lissobone>tifpifs: Linux is a systems kernel and nothing more. Many mistakingly call it so. It's GNU/Linux or simply GNU.
<tifpifs>Data extraction is ridiculous; all those coockies. Funny how data-extracting companies quickly found ways how to fool most of the folks with "Legitimate interest" sub-option in cookies.
<lissobone>I don't really use websites often, anyways.
<lissobone>Or I use them under the shield of LibreJS.
<lissobone>I see you're new to free software. Please, make an effort to avoid certain misnomers.
<lissobone>Alright?
<tifpifs>Totally new, you may say.
<lissobone>There is a lot for new users to learn, especially on www.gnu.org. You might consider reading "Free Software, Free Society" (third edition) by Richard Stallman or even 'Free as in Freedom' by Sam Williams and rms.
<tifpifs>Nevertheless, I got that there is Linux kernel, Linux-libre kernel and Hurd kernel to be distinguished now.
<tifpifs>So far I read Stallmans published essays on FSF website. Incredible stories and reflections.
<tifpifs>Good at revealing infinite-competition-based society's illness.
<tifpifs>I am far from being on skills level relevant to Hurd efforts as of now but in parallel to my explorations of GNU/Linux I somehow developed my sympathies towards everything Hurd stands so its a curiosity topic for me.
<tifpifs>Doesn't hurt that during university I wasn't either scared or chased away from C++ and even C (we had to program robots / microcontrollers); I liked those languages and continue to study them for personal needs and challenge and discipline.
<ThinkT510>if you are interested in microkernels in general there are several projects you may like
<tifpifs>How, folks, you would measure the requisite complexity of skillsets & understanding to even remotely one being able to approach Hurd kernel development's insights let alone understand something of its challenges?
<ThinkT510>minix (the inspiration of linux), helios (new, written in hare), redox (inspired by minix, written in rust), managarm (interesting async approach, written in C++)
<tifpifs>So, anyone interested in Hurd dev should be familiar in detail of at least one of those (as well as microkernel theory and concepts), i understood correctly?
<ThinkT510>I was just providing examples of other microkernel projects in case you wanted to check them out
<tifpifs>Got it.
<ThinkT510>os-dev in general can be quite tricky
<AwesomeAdam54321>tifpifs: How, folks, you would measure the requisite complexity <- Even simple things can go a long way in helping the HURD, for example contributions through packaging: https://wiki.debian.org/DakHowTo
<tifpifs>Is there any place of artificial intelligence methods and approaches in Hurd development conceptually and technically?
<ThinkT510>be vary wary of "AI" usage in helping generate code
<ThinkT510>tifpifs: here is an example of how off-mark it can be: https://rustmagazine.org/issue-2/demystifying-rust-lifetime-with-chatgpt/
<ThinkT510>it really is a language model rather than true AI
<tifpifs>chatGPT is just
<tifpifs>ou, I was jsut about to say about language model, but
<tifpifs>by artificial intelligence i mean science of artificial intelligence with its methods, approaches, including old-school AI (symbolic) - and not just what is fancy now;
<tifpifs>During my university studies I discovered that most likely i am most interested (as my potential career and interest path) in artificial intelligence (as science; but I know in capitalism I will not be allowed purely to exercise such my interest without aspects of enslavement and coercions of various kinds); I particularly got interested personally in evolutionary algorithms and so called genetics-based machine learning, which slowly i continue to study on
<tifpifs>my own pace now after university.
<tifpifs>Since i know almost nothing of compilers / kernel development I was just left with wondering so far - whether there actually is some place of search & optimization procedures in kernel design/architecture?
<tifpifs>If there would be such recognized potential and indications of some researches, well, that maybe could transform into good news for me. Since i plan to "walk my path" into artificial intelligence/machine learning study quest anyways, I thought that maybe after few years I might some day reach a point of relevant expertise to be able, hopefully, help in something like Hurd.
<ThinkT510>with the lack of manpower in hurd dev the bar for helping out would be quite low. you certainly don't need expertise in AI do help with optimizations but I can see we that can be an area of interest
<ThinkT510>*see why
<ThinkT510>you might be surprised at howyou can help even now
<ThinkT510>damo22 has been quite active lately so they would be able to advise the best area to focus on
<ThinkT510>and youpi is very knowledgable
<ThinkT510>I'm just a simple enthusiast rather than an OS dev
<tifpifs>From little that i understood from brief read into some posts/info about Hurd's microkernel (of which I learnt merely week ago first time in my life) there is struggles in syncing those supposed-hypothetical micro-servers; there is this whole thing of translators; very complex dynamics of what will go where, meaning in other words - exponential combinatorics.
<tifpifs>Machine learning can have its place and use in tasks of search & optimization when something behaves in complex, tricky combinators and relevant patterns must be discovered, found and recognized and acted upon.
<tifpifs>(when i wrote "combinators", i meant "combinatorics")