IRC channel logs

2023-03-05.log

back to list of logs

<damo22>ok i figured it out, PIT timer is redirected to IOAPIC pin 2
<damo22>so we can use the method youpi1 suggested
<damo22>it works
<Pellescours>yay
<damo22>sent in a patch for this already
<damo22>but smp is still slow with cpus > 1
<damo22>at least the time is correct
<damo22>it must be related to the fine locking
<damo22>something must be locked for too long and causes things to stall?
<damo22>cpus spinning unnecessarily in loops
<damo22>i wonder if there is a way to count the number of spins in each lock and print some stats
<damo22>maybe one lock is dominating the rest
<damo22>or the number of times the lock is taken
<damo22>db{0}> show all slocks
<damo22>SUCCESS FAIL MASKED STACK TIME LOCK/CALLER
<damo22>10790 total locks, 0 empty buckets
<damo22>1251873 50/0 290938/23 248429/0 0/0 0xc10a4100(c10a4100)
<DiffieHellman>SMP is nearly working? Nice.
<damo22>DiffieHellman: it works but its currently so slow that the system is unusable
<damo22>there is definitely something wrong with it
<damo22>i think i fixed MACH_LOCK_MON lock monitoring
<DiffieHellman>Nice.
<damo22>but i dont quite understand what the output means
<damo22>youpi1: do you know what the lock_info_print lip() function is supposed to show? i hooked it up
<damo22>FAIL is very low
<damo22>looks like there are just too many successful locks
<damo22>with -smp 1 it boots fast to this position:
<damo22>db{0}> show all slocks
<damo22>SUCCESS FAIL MASKED STACK TIME LOCK/CALLER
<damo22>15126 total locks, 0 empty buckets
<damo22>2287490 0/0 441021/19 3898186/1 0/0 0xc10a4100(c10a4100)
<damo22>with -smp 2 it boots slow to the same position:
<damo22>db{0}> show all slocks
<damo22>SUCCESS FAIL MASKED STACK TIME LOCK/CALLER
<damo22>15384 total locks, 0 empty buckets
<damo22>2376675 480/0 471399/19 3981849/1 0/0 0xc10a4100(c10a4100)
<damo22>it looks like roughly the same number of locks are being taken, but smp 2 has 480 failed locks and smp 1 has zero
<damo22>-smp 4:
<damo22>db{0}> show all slocks
<damo22>SUCCESS FAIL MASKED STACK TIME LOCK/CALLER
<damo22>15555 total locks, 0 empty buckets
<damo22>2390319 941/0 480270/20 7974790/3 0/0 0xc10a4100(c10a4100)
<damo22>-smp 8:
<damo22>db{0}> show all slocks
<damo22>SUCCESS FAIL MASKED STACK TIME LOCK/CALLER
<damo22>18391 total locks, 0 empty buckets
<damo22>2401894 1296/0 484905/20 4344562/1 0/0 0xc10a4100(c10a4100)
<DiffieHellman>That's a lot of locks
<youpi1>damo22: I don't know anything about the lock mon, but the numbers you show look alright
<youpi1>DiffieHellman: that's not really surprising