IRC channel logs

2022-12-07.log

back to list of logs

<luckyluke>gnu_srs: How are you building the image?
<gnu_srs>luckyluke: It is a script containing the following steps: create_image;mount_image; copy_files; install_grub;umount_image.
<gnu_srs>It worked perfectly in 2019-2020, with grub 2.04, still using --i386-pc. Now I use grub2.06. If you like I can paste it to debian.net.
<p4r4>hello
<p4r4>I have some issue with openssh-server, the tutorial on the wiki suggests that I install random-egd but the package requires `libdigest-sha1-perl` which is not installable.
<youpi1>that's an oldie
<youpi1>it's not needed any more
<p4r4>alright, I'm using qemu, but I seem to not be able to log from my localhost to the hurd
<luckyluke>gnu_srs: that would be great
<luckyluke>When I had similar issues it was because something went bad and the ext2fs task was terminated before it could install an exception port
<gnu_srs>luckyluke: https://paste.debian.net/1263172/
<gnu_srs>How to enable debug mode in gnumach to obtain the prompts when booting?
<gnu_srs>C-A-d does not work with serial output :(
<luckyluke>You should compile witk --enable-kdb
<luckyluke>Also, you can try to apply this and see if you have more useful messages https://gitlab.com/luckyd/gnumach/-/commit/764e2eb62b561e7bf0900cf76be574fed2baf5de
<gnu_srs>luckyluke: gnumach is already compiled with --enable-kdb
<luckyluke>Then probably some task terminates before reaching the prompt
<gnu_srs>Thanks for the patch. I'll apply it and rebuild gnumach and the image.
<gnu_srs>Q: Is the file servers.boot used somewhere?
<gnu_srs>And how?
<luckyluke>I don't know
<gnu_srs>luckyluke: Thanks for your patch: Here is the error log, what can be done to fix this problem? start ext2fs: Unhandled exception caught by task ext2fs(f59c2e40), terminating
<gnu_srs>Dump of i386_saved_state f59bf718: EAX 081e001f EBX 081d78ac ECX 00000000 EDX 0000001f; ESI 00000000 EDI 00000000 EBP 00000000 ESP bffffcf0
<gnu_srs>CS 0017 SS 001f DS 001f ES 001f FS 001f GS 001f; v86: DS 0000 ES 0000 FS 0000 GS 0000;EIP 080ef98f EFLAGS 00010246;trapno 14: Page fault, error 00000004
<luckyluke>I'd run it with gdb, or invoke kdb there
<luckyluke>Afaik the issue is that there is no exception port set to handle page faults, iirs thos could happen at early stages of startup
<luckyluke>You could try to get a stacktrace from the userspace thread
<luckyluke>Maybe there is already a helper to invoke kdb, I don't remember right now
<youpi>seen just a few lines below, you have the
<youpi>debug_all_traps_with_kdb
<youpi>variable
<youpi>which you can just set to 1
<gnu_srs>Thanks, I've got this far: start ext2fs: kernel: Page fault (14), code=4; What next?
<gnu_srs>Stopped at 0x80ef98f: orb 0(%edx),%cl; >>>>> user space <<<<<; 0x80ef98f(); db>