IRC channel logs

2022-11-13.log

back to list of logs

<youpi>luckyluke: we do use -ffreestanding
<youpi>and define uint8_t etc.
<luckyluke>but why define standard types when stdint.h is one of the few headers available with ffreestanding?
<luckyluke>I see also -nostdinc is used...
<luckyluke>could it be that some parts don't work with C99/C11?
<luckyluke>and in this case, would it be ok to fix the code to target a recent C standard?
<gnu_srs>Hi, as I understand we don't have a cross-compiler from Linux to Hurd available?
<Zopolis4>we sort of do
<Zopolis4>but its outdated
<Zopolis4>look up crosshurd on the hurd site
<Zopolis4>theres an old script
<Zopolis4>theres also a more recent blog post
<gnu_srs>crosshurd is not the right tool: Install a Debian system
<luckyluke>the bootstrap.sh part of crosshurd could be enough for a cross-compiler
<Zopolis4>no crosshurd the debian package isint the right one
<luckyluke>I meant this one, which is different from the debian package: https://github.com/flavioc/cross-hurd.git
<youpi>luckyluke: std headers could bring unsupported bits
<youpi>in terms of system support, not language support
<youpi>e.g. things like tls
<luckyluke>The ones from ffreestanding seem generic enough, they don't inlcude any system support
<luckyluke>From the gcc docs: "a conforming freestanding implementation is only required to provide certain library facilities: those in <float.h>, <limits.h>, <stdarg.h>, and <stddef.h>; since AMD1, also those in <iso646.h>; since C99, also those in <stdbool.h> and <stdint.h>; and since C11, also those in <stdalign.h> and <stdnoreturn.h>. In addition, complex types, added in C99, are not required for freestanding implementations. "
<luckyluke>From here https://gcc.gnu.org/onlinedocs/gcc-12.2.0/gcc/Standards.html#Standards
<youpi>I can only say what I vaguely remember, simplest to make sure don't unexpectedly break is to host oneself
<youpi>things+
<luckyluke>I see, but it seems to require also additonal maintenace, potentially... not that I found anything missing, I just saw this when looking for other stuff