IRC channel logs

2022-11-06.log

back to list of logs

<gfleury>youpi: i'm trying hard to use THREAD_SELF and THREAD_GETMEM in pthread like in nptl before i move it in libc. follow nptl way doesn't work because struct like TCB end pthread differ
<gfleury>any tips
<gfleury>bc I don't have any experience with TLS
<youpi>I'd say leave that aside for now
<youpi>it's very complex
<youpi>notably, the tcbhead_t doesn't actually have a poniter to the thread structure that htl uses
<youpi>so in the end what you'd need is not even there yet
<gfleury>I was trying that bc florian's said that it will interfere with dlmopen and that is problematic
<gfleury>the use of thread variable
<youpi>yes but that's independent from your concern of moving symbols
<gfleury> https://sourceware.org/pipermail/libc-alpha/2022-October/143082.html
<youpi>you're just moving it, you're not inventing it
<gfleury>ok, thanks.