IRC channel logs

2022-10-31.log

back to list of logs

<damo22>im having trouble switching back the kernel_page_dir to bsp's
<damo22>i think i need a temporary kernel_pmap as well
<damo22>(04:10:15) iska: would doing it on Xen be easier? not if the goal is to make it work on hardware
<damo22>youpi: as i understand, CR3 holds the page directory base address. i am trying to allocate one per cpu temporarily for a mapping that will allow segmentation/paging to work. but when i switch back to the real page directory, do i need to flush tlb?
<damo22>youpi: https://paste.debian.net/plain/1259003
<damo22>it looks like it switched to a thread with zero stack pointer, and crashed while printing to console on bsp
<damo22>is there a good place i should breakpoint such that getting to this point would mean its mostly working ? im trying to run the kernel with no boot parameters with qemu -kernel
<youpi>damo22: setting CR3 is the way to flush the tlb
<youpi>damo22: it's bootstrap_create that is basically the end of kernel initialization
<damo22>#16 0xc1012531 in kmem_submap (map=0xc11e0340 <device_io_map_store>, parent=0xc11dee60 <kernel_map_store>, min=0xf61aff78, max=0xf61aff7c, size=16777216) at ../vm/vm_kern.c:871
<damo22>#17 0xc1023f72 in mach_device_init () at ../device/ds_routines.c:1606
<damo22>it tries to vmap_enter
<damo22>vm_map_enter
<damo22>#13 0xf61afe0c in ?? ()
<damo22>then page faults
<damo22>...
<damo22>#19 0xc100c0d6 in start_kernel_threads () at ../kern/startup.c:251
<damo22>#20 0xc100ae0e in thread_continue (old_thread=0x0) at ../kern/sched_prim.c:828
<damo22>#21 0xc10301e5 in Thread_continue () at ../i386/i386/cswitch.S:95
<damo22>(gdb)
<damo22>it must be doing a context switch
<damo22>and then breaks
<damo22>ESP 00000000 CS 0008 SS ee60
***CaCode_ is now known as CaCode
***LordBin is now known as TylerB
<TylerB>Hi all
<TylerB>Im just wondering what the most stable Hurd system is at the moment, is it still debian?
<ThinkT510>TylerB: very likely yes. guix is the only other active one I'm aware of. archhurd isn't really active any more but would welcome activity
<iska>TylerB stability isn't the problem, debian is just the most complete, afaik guix is a bit too far behing
<TylerB>isaka: I have tried Guix Hurd before and even their qemu package was a rubbish (for now). Im just trying the Debian again now and the newer versions are miles better than the older ones
<iska>TylerB how much before?
<TylerB>I tried the Debian 2015 version after hearing 0.8 Hurd was released
<iska>ahh, it got much better even in 1 year for me
<iska>but I meant when you tried Guix Hurd
<TylerB>yea, I tried it this morning
<iska>ohh
<TylerB>It didnt run well
<iska>well, it's still in experimental stage AFAIK, only really runs as a VM (no system reconfigure iirc)
<TylerB>I probably wasn't using it correctly
***nckhexen is now known as jeffbezos
***civodul` is now known as civodul
***Noisytoot is now known as [