IRC channel logs

2022-10-28.log

back to list of logs

<damo22>youpi: "Rather use another kernel_page_dir, otherwise this is messing with the original kernel_page_dir of the BSP." i dont understand this part of the code, i just copied it because i thought it was needed. do we need it at all for APs?
<damo22>if there is a mapping in the page directory, why cant it be seen by the AP?
<youpi>the mapping is only temporary
<youpi>I don't know if you need it in the case of bsp, i'd have to thinki about it
<damo22>i think its only there for linux drivers to work
<damo22>because they access low memory
<youpi>no
<youpi>they use kvtolin etc. for that
<youpi> /*
<youpi> * We'll have to temporarily install a direct mapping
<youpi> * between physical memory and low linear memory,
<youpi> * until we start using our new kernel segment descriptors.
<youpi> */
<youpi>see that comment
<youpi>it's there only until segmentation works
<damo22>ohh
<damo22>we should get rid of it altogther and just make sure segmentation works when its needed?
<youpi>except you can't
<youpi>since you can set up at the same time paging and segmentation
<youpi>s/can/can't
<damo22>oh
<damo22>once the gdt is loaded, you dont need the mapping?
<youpi>yes
<youpi>because segmentation makes kvtolin then work
<youpi>(err, lintokv)
<damo22>oh i thought it was a local variable, but its extern
<damo22>the kernel_page_dir
<damo22>thats why i was confused