IRC channel logs

2022-10-23.log

back to list of logs

<damo22>ive got SMP with and without (LAPIC timer and IOAPIC) reaching almost the same point as (PIT timer/PIC), but neither of them quite boot
<Zopolis4>given that the drivers are seperate userspace servers (I presume), what does hurd do about drivers for hardware not present on the machine?
<damo22>there arent many drivers for hardware that arent present on the machines that hurd supports
<Zopolis4>how does hurd manage that though? like is there a check for excess drivers on installation or something
<damo22>but it usually probes the hardware to know what is present on the machine
<damo22>we are in the opposite situation though, we have hardware that hurd does not know how to drive
<damo22>argh i just cleaned up my branch and now non-smp is broken
<damo22>probably a timer issues
<damo22>-s
<Zopolis4>btw the crosshurd debian package only works if you manually download and install the gpg keys from ports.debian.org
<Zopolis4>i.e. https://www.ports.debian.org/archive_2022.key
<Zopolis4>and apt-key complained each time i did it about apt-key being deprecated
<damo22>Pellescours: i just pushed my branch, it compiles with non-smp, and smp with or without apic
<damo22>but something is broken even on non-smp which is interesting
<damo22>i might try to fix that first
<damo22>start acpi: acpi pci rumpdisk Kernel is already driving a SATA device, skipping
<damo22>probing disks
<damo22>Kernel Page fault trap, eip 0xc1008197
<damo22>kernel: Page fault (14), code=0
<damo22>Stopped at switch_context+0x37: movl 0x8(%edi),%eax
<damo22>switch_context(f4e27000,0,c11ccca8,c11ccaa0,c11ccde0)+0x37
<damo22>thread_invoke(f4e27000,0,c11ccca8,c102c0bd)+0xc0
<damo22>...
<Zopolis4>damo22: is this the hurd module you were talking about a while ago? https://git.savannah.gnu.org/cgit/grub.git/commit/?id=72b40c2ccb1f54deb4d448c6ff8016469f3920d1
<damo22>Zopolis4: not quite, thats for ACPI, but i wrote a module for grub that loads all the hurd multiboot modules in one command
<damo22>i need to refactor it and polish it off
<damo22>Zopolis4: https://lists.gnu.org/archive/html/bug-hurd/2022-09/msg00134.html
<Zopolis4>oh i was looking in the wrong mailing lists
<damo22>well i should have posted to grub
<Zopolis4>ah
<Pellescours>damo22: oh interesting, I won't be able to test until the end of the week.
<damo22>im guessing i changed something i shouldnt have in one of my commits
<damo22>its difficult to pinpoint because there were many changes
<damo22>i probably need to look at the total diff to master and pick off things that can be merged
<youpi>Zopolis4: fix contribution welcome ;)
<damo22>im pretty confident now that smp i386 with no ioapic can work
<damo22>since it has almost exactly the same behaviour when you compile with and without it
<gnu_srs1>youpi: Apparently the buildds are idle, at least mahler is. And the build queue has 107 packages to build.
<Zopolis4>youpi: idk where the source is debian doesn't tell you
<youpi>gnu_srs1: yes, I have restarted it already, the build server seems to have hiccups and that breaks the b uild daemon
<youpi>Zopolis4: it does
<Zopolis4>mind telling me where it tells you then?
<youpi>use debcheckout crosshurd
<youpi>or see apt-cache showsrc crosshurd
<Zopolis4>i dont have any deb-src sources
<gnu_srs1>youpi: Additionally several packages that fail to build are not seen in https://people.debian.org/~sthibault/graph-total-top.txt
<gnu_srs1>How come?
<youpi>Zopolis4: then add one, see https://www.debian.org/ports/hurd/hurd-install
<youpi>gnu_srs1: please provide examples, otherwise I can't say
<gnu_srs1>One example is: dhcpcd5
<youpi>see the bottom of the file
<gnu_srs1>You mean: less than 9 children: not represented here?
<youpi>yes
<jsi>Hello! Was wondering, could anyone please eli5 the benefits of the hurd contra linux kernel? Does hurd has any potential advantages to linux in terms of system performance and software minimalism?
<AwesomeAdam54321>jsi: Sure
<AwesomeAdam54321>The main advantage of the HURD is flexibility in modifying the system, as all the drivers and translators can be debugged like regular programs
<youpi> https://darnassus.sceen.net/~hurd-web/faq/still_useful/
<youpi> jsi: please read the faq ;)
<jsi>I see
<jsi>So no potential performance advantages, the main sellingpoint would be the flexibility and useability if I understand it right?
<AwesomeAdam54321>jsi: Yes, the performance is the same, except maybe fork&exec syscalls being converted to posix_spawn syscalls in glibc could be an advantage
<jsi>Thanks for the answers! :)
<Damy>Hi, how can to compile it hurd ?
<gnu_srs1>youpi: Why: rules.defs: add hurd to go_no_systems. It builds fine with the latest patches by Matthias (w/o tests)
<youpi>gnu_srs1: I hadn't actually tried, just wanted to get the -static-pie thing working so gnupg2 stops getting in the way of installing systems
<AwesomeAdam54321>Damy: You can check out the "Instant Development Environment" section from https://www.gnu.org/software/hurd/contributing.html , or you can use the Guix package manager to build it with `guix build hurd`
<Damy>ok, thanks, i see it
<Damy>AwesomeAdam54321
<AwesomeAdam54321>You're welcome, let me know if you have any other questions
<Damy>AwesomeAdam54321: thanks. And then the compile of the sources will do completely in the vm ?
<AwesomeAdam54321>yes
<Damy>AwesomeAdam54321: ok, perfect
<Damy>In qemu appear mouse:queue full. What is it ?
<youpi>your console is stuck reading mouse events
<youpi>is it also stuck on reading keyboard?
<Damy>yes...
<youpi>so your console is stuck
<Damy>youpi: Ok, thanks. I shutdown the system