IRC channel logs

2022-10-13.log

back to list of logs

<damo22>Pellescours: which commit?
<Pellescours>damo22: your latest
<damo22>Pellescours: yes there is something fishy about the PROCESSOR_IDLE and PROCESSOR_RUNNING default states
<damo22>it seems like BSP wants to fake being running immediatel
<damo22>but if you set RUNNING to APs immediately, they assume theyre running and never choose a thread
<damo22>or something like that
<damo22>i played around with the default settings in cpu_up
<damo22>see second last commit
<damo22>maybe the BSP faking being running is a bad idea in smp
<damo22>there is a comment in the code about that somewhere
<damo22>i think kern/sched_prim.c
<Pellescours>i didn't inspect that much actually, I started to read the linux book. But seeing how far the boot process was, I don't think it was issue with PROCESS_RUNNING that is cassOCOCOCOCing the trap
***Server sets mode: +nt
<Pellescours>damo22: with smp and 6 cpu it page fault (14), code=3 "Stopped at device_pager_setup+0xad: movl $0 0(%eax)"
<Pellescours>and the fault is at address 0xc1006a4b
<Pellescours>and with 1 cpu it fails at starting sshd server step, page fault (14), code=3 "Stopped at ipc_port_alloc_special+0x21: movl $0, 0(%eax)"
<Pellescours>and the fault is at address 0xc1004a3d
<Pellescours>what is TH_KERNEL_STACK and TH_SWAP_FUNC? I did a grep but I only see usages and no definition
<Pellescours>damo22: note that with your latest version of feat-smp, you can’t build without --enable-kdb. Otherwise db_on is undefined
<Pellescours>probably a missing #ifdef
<Pellescours>Without kdb enabled, there is another trap just after started the 1st task
<Pellescours>it’s a debug trap when kbd is not enabled