IRC channel logs

2022-09-30.log

back to list of logs

<damo22>youpi: what is the standard called that supports booting hurd from grub?
<damo22>is it multiboot?
<damo22>i am concerned that one needs to pass so many flags to bootstrap translators to make hurd boot up. What if you lose your grub config, how will you boot? it should be as easy as specifying a list of bootstrap translators and they chain together automatically
<damo22>maybe i can write a new bootstrap translator called "boot" whose only job is to take a list of bootstrap translators and compute the multiboot command line to boot hurd
<damo22>or a grub module called hurdboot
<damo22>hurdkernel /boot/gnumach.gz root=device:wd0
<damo22>hurdmodules /hurd/acpi.static /hurd/pci-arbiter.static /hurd/rumpdisk.static /hurd/ext2fs.static /hurd/exec.static
<damo22>boot
<Pellescours>damo22: could an initramfs do that job ?
<damo22>i think grub should have a module that expands a simple list of bootstrap translators into the "module" goop that multiboot needs
<damo22>its basically a special case of multiboot
<damo22>a hurd loader
<damo22>(make_mbi)
<damo22>can a grub command call another command?
<Zopolis4>ok got the hard drive linked up to a linux machine with admin and block drive access (old chromebook)
<Zopolis4>which one is the windows recovery partition? https://www.irccloud.com/pastebin/pmHSCYvV/
<Zopolis4>nvm found it
<Zopolis4>its sdb4
<Zopolis4>so how do i see whats in the rest of the partitions and how do i extend the hurd partition
<Zopolis4>oh and delete sdb4
<damo22>Zopolis4: that does not look right
<damo22>you have 100M 16M 297GB and 509M partitions
<damo22>what are they??
<damo22>they would not have been created by dd'ing the hurd image to the disk
<damo22>you did something wrong
<Zopolis4>the 509m is windows
<damo22>if you dd'd the hurd image to that disk, it would not have any recognisable partitions
<damo22>they would all be hurd
<damo22>and swap
<Zopolis4>i mean
<Zopolis4>i can try to dd again on a linux system
<damo22>where did that other dd go??
<Zopolis4>windows
<damo22>did you destroy another block device?
<Zopolis4>wdym
<damo22>your dd did not go where you expected it to
<Zopolis4>oh
<damo22>it probably overwrote something else
<Zopolis4>no so i was running dd on windows
<Zopolis4>only ever touched one drive
<damo22>can you run fdisk -l /dev/sdb
<damo22>and pastebin it
<Zopolis4>lemme reinstall fdisk
<Zopolis4> https://www.irccloud.com/pastebin/Rlh44CVH/
<damo22>Zopolis4: as i suspected, there is no hurd there
<damo22>so where did your dump go?
<damo22>/dev/important0
<ThinkT510>if they did the dd within wsl wouldn't it be using the VM's drive?
<Zopolis4>i did it using regular dd4windows
<Zopolis4>not mingwdd not wsl
<Zopolis4>wsl dosent have block drive acess anyways
<ThinkT510>what target did you give dd?
<Zopolis4>on windows, of=D
<ThinkT510>is D a partition or a separate drive?
<Zopolis4>a seperate drive
<Zopolis4>is there any particular block size i shouldnt go over for writing the image?
<ThinkT510>you know how big the drive is?
<Zopolis4>320gb
<Zopolis4>hurd dosent take over 180gb or smth tho
<damo22>128
<ThinkT510>have you checked to see what is on D now?
<Zopolis4>D is the device in discussion
<Zopolis4>partition list is above
<damo22>no, you plugged it into a different machine now?
<damo22>i do believe your dd went wrong
<ThinkT510>if D is /dev/sdb then you didn't dd your image there according to your pastes
<damo22>but i suggest firing up your first machine and check that everything still works, and you havent clobbered anything
<damo22>eg, if it boots hurd..
<Zopolis4>so the machine that i took the hard drive out of and dd'd booted into the windows recovery partition
<Zopolis4>the windows machine i dd'd from works fine
<damo22>did you perhaps dd to a partition and left the table intact?
<Zopolis4>thats possible
<damo22>i dont know if windows allows you to dd over the first sector
<damo22>do you have the hurd image on the chromebook?
<youpi>on windows, D (aka D:) is not a drive, but a partition
<Zopolis4>yeah im dding now
<damo22>as a file?
<Zopolis4>a proper linux dd (sudo dd bs=2M if=debian-hurd-20220824.img of=/dev/sdb)
<damo22>ok that should work
<Zopolis4>oh and done
<damo22>fdisk -l /dev/sdb
<Zopolis4>here it is https://www.irccloud.com/pastebin/4wjzoKPc/
<damo22>so you could use gparted to resize the 4G one to about 80G if you want
<damo22>or make it 16G and then add a third one for /home or something
<youpi>it may be useful to have a separate partition for builds, yes
<damo22>yes that is what i do
<youpi>(I'd say not home, that you wouldn't want to see affected by crashes hitting the build partition)
<damo22>fair
<Zopolis4>wait a different partition?
<damo22>yeah i use /part3
<damo22>Zopolis4: extend the 4G one, since that is slightly too small for /
<Zopolis4>oh just have a spare partition that you mount as /home?
<damo22>then create a third one and mount it elsewhere
<damo22>not /home preferably
<Zopolis4>why not?
<damo22>because if you build stuff there and test it, it could crash and then bring down your home
<damo22>its slightly annoying
<Zopolis4>oh wait so the partition could just randomly crash?
<damo22>with testing disk drivers yes
<damo22>youre almost shielded from that because rumpdisk is almost finished
<Zopolis4>i mean im not gonna be testing any disk drivers anytime soon
<damo22>you might if you disable gnumach ide/ahci
<Zopolis4>ill take the risk :p
<Zopolis4>given that i dont have a gui, how should i do the partition stuff?
<damo22>man fdisk
<damo22>-rw-rw-r--. 1 damien damien 3144 Sep 30 17:30 hurdhelper.mod
<damo22>grub> insmod hurdhelper
<damo22>HAHA i figured out why my hurd terminal wont work, i had a symlink from ~/.bash_history -> /run/xconsole
<Zopolis4>how did you manage that
<Zopolis4>also i cant figure out how to resize a partition in fdisk
<Zopolis4>ive made a 100gb build dir
<Zopolis4>no luck with expanding the 4gb / dir tho
<damo22>Zopolis4: you need contiguous space to expand a partition
<damo22>so you cant create the 100G one first
<damo22>im compiling grub2 with my new helper module
<damo22>in theory you can just do this:
<damo22>grub> multiboot /boot/gnumach.gz root=part:2:device:sd0
<damo22>grub> hurdmodules /hurd/acpi.static /hurd/pci-arbiter.static ....
<damo22>grub> boot
<gnu_srs1>(20:44:03) gnu_srs: Hi, what's the status of emacs-28. Can it be safely installed now?
<Zopolis4>what should i do then?
<gnu_srs1>youpi: Have your patches for gcc-12 been accepted upstream yet? I would like to see if gccgo-12 can be built.
<gnu_srs1>And what is the status of llvm-13/14 wrt the latest glibc changes?
<Zopolis4>gcc patches arent upstream yet
<youpi1>gnu_srs1: I'm not aware of anybody having worked or currently working on llvm vs pthread_cancel
<youpi1>s/cancel/once/ sorry
<youpi1>Zopolis4: llvm is completely independent from gcc :)
***youpi1 is now known as youpi
<damo22>youpi: i wrote a hurdhelper module for grub but ext2fs.static keeps crashing at boot: task loaded: ext2fs --multiboot-command-line=root=part:2:device:sd0 -T typed part:2:device:sd0 --next-task=1
<Zopolis4>youpi: you missed an earlier message "Have your patches for gcc-12 been accepted upstream yet? I would like to see if gccgo-12 can be built."
<damo22>youpi: https://paste.debian.net/plain/1255538
<damo22>woot my module works!!
<youpi>Zopolis4: ok :)
<youpi>it was posted on the list
<youpi>damo22: next-task looks odd
<damo22>youpi: my module works!
<damo22>i tried different combinations of chainloading
<damo22>all that is required is the list of tasks
<damo22>(in the order you wish to load them)
<iska>64bit kernel is there, is it possible to build and run 64-bit programs yet?
<youpi>after patching binutils, gcc, glibc, hurd, yes
<youpi>patch welcome
<iska>what patches are needed?
<youpi>to tell them that 64bit hurd exists, and how to implement it
<iska>ooh
<iska>so there hasn't been work yet?
<youpi>not that I'm aware of
<Pellescours>gnumach 64 bit works?
<iska>Pellescours has been for a while and bootable from grub recently
<iska>AFAIK
<Pellescours>OHH, I saw some patches being merged but I was not sure, all was done
<youpi>not all, some rpc and syscall conversions are pending