IRC channel logs

2022-09-23.log

back to list of logs

<damo22>Pellescours: i saw you sent in a patch to netbsd, but did you really need to send them the configure script? its 3000 lines of change
<Pellescours>I followed the comments in the configure.ac
<Pellescours>this is weird to me to, I tink they should remove the configure and let users do the autoreconf command thereself (or integrate the step in build.sh)
<Pellescours>I made progress wit ata compilation stuff
<Pellescours>I’m able to compile hurd with both ide and sata
<Pellescours>my problem is that now it panic at devw_attach
<damo22>hmm
<damo22>do you have a specific error message?
<Pellescours>the devw_attach("wd"...) failed
<Pellescours>I think it’s my ioconf generation which is incomplete for the wd part
<damo22>i think you can refer to a wd* in the ioconf even though its implemented in a different library
<damo22>since it will be present at runtime when linked
<Pellescours>Yes I can, this is what I did
<Pellescours>but it’s the ioconf.c that miss some config part for wd*
<damo22>libwd should have it
<damo22>what libs do you have now
<damo22>libpcidev_wd or something
<Pellescours>I compile hurd with librumpdev_ahcisata librumpdev_piixide librumpdev_ata
<Pellescours>the last one being the one I added to have the rumpns_atabus_cd and rumpns_wd_cd struct being in
<damo22>so librumpdev_ata has the wd elements and cd?
<Pellescours>yes it has
<damo22>you probably need to remove wd*.c and cd*.c from the ahcisata and piixide libraries and move them to ata
<damo22>if you havent already
<damo22>it should be makefile foo
<Pellescours>I already did
<damo22>ok
<Pellescours>it’s an ioconf problem
<damo22>maybe you can add them in as extern to the ioconf
<damo22>instead of having them missing
<damo22>im guessing here as i cant see what you did
<Pellescours>I will try to keep my changes and compile hurd with only one lib, just to see
<Pellescours>What I did, was to compile ata*.c files in libata + move the common part of *.ioconf in libata
<damo22>its a heirarchy as i understand: ahci/ide controller -> ata -> wd/cd
<Pellescours>right
<damo22>we need everything unrelated to the controller put in libata
<Pellescours>That’s what I did, and it worked, it’s just that at runtime, it’s not able to find th wd
<damo22>ok
<damo22>yeah it sounds like the ioconf
<damo22>but isnt the cd attached via a different lib? ahci/ide -> atapi -> cd
<damo22>so you need libs for wd and cd
<damo22>otherwise wd will clash twice when you compile in cd support?
<damo22>scsipi*
<Pellescours>wdc is in libata, so it won’t conflict, for scsipi, it’s just that libscspi will need a patch to use libata. But for now cd is not enabled in code, so I don’t care
<damo22>yes it is
<damo22>libscsipi is compiled in and cd works on rumpdisk currently
<Pellescours>But it’s not used If I try to boot with on wd0
<damo22>if you add a -cdrom iso in qemu it works
<Pellescours>yeah I see. I’ll check that after
<Pellescours>for now cd is not a problem to me, my problem is wd
<damo22>sure
<damo22>the autoconf was mismatched version, thats why you got a huge diff
<damo22>RE: netbsd patch
<Pellescours>yes, I know that my autoconf version missmatched, but I used the version installed on my linux (archlinux). Old version is 2.69, and mine is 2.71
<Zopolis4>arch should actually be easy for that
<Zopolis4>just use autoconf2.69
<Pellescours>I’ll re-submit the patch then
<Pellescours>damo22: I’m able to boot with ahci by compiling with libata (but without piixide)
<Pellescours>but with libata, you can’t build rump with only piixide (without ahcisata) because there is a missing symbol comming from sata_subr.c
<Pellescours>The panic happen when I compile with piixide and ahcisata but not ahcisata alone (I did not tried piixide alone due to missing symbol). I think panic is due to 2 modules trying to probe wd at the same time
<Pellescours>shouldn’t ata and sata being separated (sata = wd and ata = sd)?
<Pellescours>time to bed
<damo22>both wds cant be connected to the same controller so that should not be the problem
<damo22>unless its a naming problem
<damo22>ide should be wd, sata should be sd
<damo22>most likely
<Pellescours>so should I try to do the changes ?
<Pellescours>or is it probably something else ?
<damo22>perhaps sleep on it
<damo22>i have non-coding tasks to do now
<Zopolis4>oh wow a lot of packages with large reverse dependencies are just behind bad ifdefs
<Zopolis4>ok wait no theres only 6
<Zopolis4>and ive dealt with 3
<Zopolis4>even still
<youpi>Zopolis4: you can see that easily in graph-top.txt indeed
<Pellescours>damo22: by looking to the code, the call fails because the 2 modules asks for the same device, I will change the call to make them try attach fallback on lookup
<Pellescours>I DID IT
<Pellescours>the solution was simple, move the content of ahcisata_component to libata and make ahcisata_component and piixide_component being simple_component
<Pellescours>YAAAAYYYY, I’m able to boot the same disk in ide or sata
<Pellescours>now I have to create patches
<Pellescours>dumb question, how do I generate patch for quilt? I have commit of changes and I want to export the patches to put there content in debian/patches