IRC channel logs

2022-09-15.log

back to list of logs

<Zopolis4>nope i still have the issues using 4gb of memory
<damo22>zamfofex: it needs testing, as he said
<Pellescours>Note: compiling gnumach with "--disable-linux-group" and booting with rumpdisk triggers a kernel pannic at boot (kernel_trap: trap, trapno14: Page fault, error: 00000002)
<Pellescours>I will try to investigate
<Zopolis4>hurd fails to install cmake: https://usercontent.irccloud-cdn.com/file/Y4TDYnam/image.png
<Zopolis4>same type of issue with fish
<Pellescours>it’s super strange, when I compile with "configure --disable-linux-group" I trigger a trap, and when i do the same but by enabling the kdbg, no trap at all
<Pellescours>also I’m able to attach a gdb to debug the kernel but I’m not able to use breakpoints, when I put a breakpoint to a function and then continue, it does not stop at the breakpoint
<youpi>perhaps take care that linear address != virtual address
<youpi>due to segmentation
<Pellescours>How do I do that? To put a breakpoint I do "break theFunction"
<Pellescours>When I do gdb, and In gdb I do "add-symbol-file gnumach", I can add the breakpoint attach remote :1234 and continue
<Pellescours>but when I do "gdb gnumach", add the breakpoint, attach remote :1234, doing continue fails with "Warning Cannot Instert breakpoint 1 Cannot access memory at adress 0xc1013f10"
<Pellescours>I probably say something to gdb for the addressing but I have absolutely no idea, and there is not so much documentation on internet for debugging a kernel with gdb
<youpi>you substract the segmentation shift, to get the linear address instead of the virtual address
<youpi>the shift is probably just the C at the beginning of the address
<youpi>thus just drop the c
<Pellescours>ok thanks
<Pellescours>damo22: atabus_cd is defined by default in ioconf.h and is extern (extern struct cfdriver atabus_cd;), but in the objfile it’s defined for some reason that I don’t understand (000000c0 g O .data.rel.local 00000020 rumpns_atabus_cd)
<zamfofex>youpi: How would you recommend that I test the patch you shared? I tried it with Guix’s ‘--with-patch’, but then ran into Guix‐specific issues.
<zamfofex>For now, I suppose I can disable coreutils’ tests using ‘--without-tests’ and proceed trying to build Hello, but I feel like it’d be nice to send a patch eventually.
<zamfofex>Now I’m getting test failures when building grep. Strangely, when it’s built by Guix, it fails one single test, and when I try to build it myself, it fails one single *other* test!When building it myself, it fails the ‘file’ test, when trying to run ‘cp’ on ‘/dev/null’ (cp: skipping file '/dev/null', as it was replaced while being copied). And the Guix failure is with ‘test-perror2’ while comparing the messages of
<zamfofex>‘perror’ and ‘strerror’.
<zamfofex>I feel like I wish I could be more helpful.