IRC channel logs

2022-09-09.log

back to list of logs

***Server sets mode: +nt
***Shentino_ is now known as Shentino
<civodul>hello!
<civodul>any idea why pipe2 is not (not really) implemented in libc?
<civodul>currently hurd/pipe2.c reads:
<civodul> if (flags & ~(O_CLOEXEC | O_NONBLOCK))
<civodul> return __hurd_fail (EINVAL);
<damo22>civodul: in words of our maintainer: Contributions welcome!
<civodul>:-)
<civodul>i'm just wondering if there's a reason that made it hard to implement
<damo22>sorry im not sure
<civodul>maybe we first need socketpair to honor SOCK_CLOEXEC and SOCK_NONBLOCK?
<civodul>actually it does already
*civodul thinks out loud
<damo22>wouldnt that be flags & (O_CLOEXEC | O_NONBLOCK) ?
<damo22>if it were to fail due to one of those flags?
<damo22>so its all the other flags?
<damo22>is the ~() a bug perhaps?
<civodul>damo22: oh you're right, i'm misreading it
<civodul>no we're fine, pfew :-)
<damo22>i had a bit of practice with bitwise ops :)
<civodul>heh, thanks :-)
<damo22>what are you trying to do with pipe2?
<damo22>i dont really know what pipe2 is for
<civodul>it lets you pass additional flags, O_CLOEXEC and O_NONBLOCK
<civodul>so you can atomically create file descriptors with the right flags
<civodul>i'm using it in shepherd and wanted to make sure it's implemented on GNU/Hurd
<damo22>civodul: looks like it is implemented, but O_DIRECT is not supported
<civodul>yes
<damo22>youpi: inet_ntoa is thread safe apparently
<iska>what's the status on SMP?
<Pellescours>iska: still wip
<iska>Pellescours: that's the status of the entire hurd basically x3
<Pellescours>iska: you’ll be able to see progress here (https://github.com/AlmuHS/GNUMach_SMP/tree/smp_stage2), I don’t know more