IRC channel logs

2022-08-24.log

back to list of logs

***ThinkT510 is now known as Guest5832
<biblio>hi, I could not find route tool as mentioned in https://www.gnu.org/software/hurd/users-guide/using_gnuhurd.html#Networking Is there any alternative tool like inetutils-ifconfig
<biblio>I was able to run Hurd on OpenStack with user with hard-coded password. But the cloud way of pushing your selected ssh keys for a user doesnot work as it need to add static route for fetching metadata. We need some tool for adding static routes. Meanwhile, I wrote a small patch for cloud-init to use inetutils-ifconfig instead of ifconfig.
<damo22>biblio, does inetutils-route exist?
<biblio>damo22: no, it has only inetutils-traceroute
<damo22>see if you can find the source for route
<biblio>damo22: i will check https://www.gnu.org/software/inetutils/
<biblio>damo22: i checked - could not find any tool for route yet.
<mhatta>Hi!
<mhatta>I installed Debian GNU/Hurd on KVM(and QEMU)-based cloud
<mhatta>But had a problem on configuraing network
<damo22>mhatta: biblio is working on it
<damo22>missing route command
<mhatta>damo22, thanks
<mhatta>Do I need to use Sid-based snapshot d-installer?
<damo22>probably use the stable one
<biblio>mhatta: you need to specify network card type
<mhatta>biblio, how?
<mhatta>I read documents I could get, but most of them are quite vague
<biblio>mhatta: in openstack I added --property hw_vif_model=e1000
<biblio>mhatta: if you use plain KVM then check how to set ethernet type e1000
<biblio>mhatta: did you install from CD.iso or download HURD img ?
<mhatta>Ah, I'm using cloud service (it's Japanese one, but something like Digital Ocean)
<mhatta>So I don't think I could specify openstack options directly
<biblio>mhatta: https://paste.debian.net/1251563/ check
<biblio>mhatta: --property hw_disk_bus=ide also needed
<mhatta>lspci gives Intel Corporation 82540EM Gigabit Ethernet Controller (rev 03)
<biblio>mhatta: how you uploaded your hurd image to your cloud provider ?
<mhatta>I uploaded Debian GNU/Hurd debian-installer CD image
<mhatta>and installed it
<biblio>mhatta: stable or latest release ?
<biblio>mhatta: please check how can you set network card type e1000 while you are creating VM before installing.
<mhatta>biblio, I guess it's stable one https://cdimage.debian.org/cdimage/ports/hurd-i386/current/iso-cd/debian-hurd-2021-i386-NETINST-1.iso
<biblio>mhatta: I used same version. it should work with e1000
<biblio>mhatta: is it plain kvm VM or OpenStack ?
<mhatta>biblio, I think it's (customized?) openstack or such
<biblio>mhatta: ok. Network failed during installation or after installation ?
<mhatta>How can I specify e1000 during installing?
<mhatta>after installation
<mhatta>The installed HURD can be accezsed via console, but it can't e.g. ping to outside IPs
<biblio>mhatta: i wrote a patch for that I will share in git soon.
<biblio>mhatta: standard openstack approach is that you install first in your local VM change console to com0, then install cloud-init. then upload in your cloud provider using this command https://paste.debian.net/1251563/
<biblio>mhatta: I will let you know after I put my code in git.
<biblio>mhatta: I specified e1000 while uploading my hurd.qcow2 image to openstack.
<mhatta>I think my cloud provider only supports ISO image
<mhatta>Is there any other known cloud provider? I can try Digital Ocean etc.
<biblio>mhatta: please confirm if they are using openstack. if yes, then they might only allow these operations via openstack cli (without web interface)
<biblio>mhatta: ok sure. I will let you know after I push my code.
<mhatta>Their Web UI strongly suggests they are using openstack
<biblio>mhatta: check their guide for openstack cli access
<mhatta>but I'm not sure how to use openstack cli
<biblio>mhatta: https://docs.openstack.org/ocata/user-guide/cli-cheat-sheet.html
<mhatta>Seems they don't provide openstack cli access
<mhatta>Which cloud provider do you recommend for HURD?
<biblio>mhatta: my current status with HURD on openstack. You can deploy HURD but it wont be able to get your selected ssh key from cloud provider due to routing issue.
<biblio>mhatta: but you can use a hardcoded account with password to access it via ssh
<biblio>mhatta: I have my own openstack cloud for doing experiments. I can suggest sometime after I test a cloud provider.
<biblio>mhatta: if you have any spare machine with 12+GB ram you can try my script to setup openstack https://dynamicmalloc.com/cgit/debian_openstack_installer.git/
<mhatta>biblio, I'll try, but my 12+GB machines are all local laptops, so running web server (that's what I intend with HURD) is difficult
<biblio>mhatta: you can setup a kvm host and give it 10-12 GB ram and try to setup inside it. Later, you can upload your hurd image inside it for testing.
<biblio>mhatta: openstack will be inside that vm. and HURD will on openstack. vm inside vm. slow but it works for testing.
<gnu_srs>mhatta: kvm options I use: -net nic,model=e1000 -net user,hostfwd=tcp::5556-:22
<biblio>mhatta: damo22: draft documentation https://dynamicmalloc.com/cgit/hurd_openstack.git/