IRC channel logs

2022-03-12.log

back to list of logs

<AlmuHS>finally, i've found the problem which cause the kernel panic in my smp kernel. At least, in part. Simply, the cpus are not being enabled
<AlmuHS>i've changed the "started cpu X" prints to the functions which are executed from assembly initial routine. And now these prints isn't showed
<AlmuHS>added to this, i've added this line in the loop which starts the IPI sending for each cpu
<AlmuHS>while(machine_slot[cpu].running != TRUE);
<AlmuHS>And the while never finish
<AlmuHS>by any reason, the assembly initial routine isn't been executed
<AlmuHS>here is my code
<AlmuHS> https://github.com/AlmuHS/GNUMach_SMP/blob/smp_stage2/i386/i386/mp_desc.c
<AlmuHS> https://github.com/AlmuHS/GNUMach_SMP/blob/smp_stage2/i386/i386/cpuboot.S
<AlmuHS>i don't know if the problem is that the IPI doesn't reach the destination cpu, or the vector (the routine address) is bad specified
<AlmuHS>IPI sending is here: https://github.com/AlmuHS/GNUMach_SMP/blob/smp_stage2/i386/i386/smp.c
***alMalsamo is now known as lumberjack123
***galex-713_ is now known as galex-713