IRC channel logs

2022-01-31.log

back to list of logs

<curiosa>-Wall gets you a warning
<curiosa>of this kind: warning: 'buf' is used uninitialized in this function [-Wuninitialized]
<curiosa>the /* XXX */ was added by Bushnell in 1994
<curiosa> https://gitlab.com/hurd/hurd/-/commit/7e02fcd788862688a3952d6e75266423d77bdb7b
<curiosa>ok, I'm diving inside the mig generated code
<curiosa>it does this mig_strncpy(path, OutP->path, 1024);
<curiosa>meaning that it could have just returned OutP->path, and in theory it could have been as long as it wanted
<curiosa>but, still, no way to achieve that without changing the RPC
<curiosa>well.. no.. it's far more complex than that
<curiosa>there should have been a size parameter
<youpi>yes, a size parameter is mandator
<youpi>the stub can't return path since it's a local variable
<youpi>the 1024 implicit size is "fine enough" for now
***roptat is now known as Guest1387
<curiosa>gdb feels broken
<curiosa>I guess gdb developers won't fix it
<curiosa>A problem internal to GDB has been detected,
<curiosa>further debugging may prove unreliable.
<curiosa>and in fact, it is
<curiosa>inferior.c:293 Assertion `pid != 0' failed.
***Guest1387 is now known as roptat
<m4t3>Feeling Hurdish.
<gfleury>curiosa: that bug was fixed upstream http://sourceware.org/git/?p=binutils-gdb.git;a=commitdiff;h=038d8b4635eda079a63df176cfa48c47f8c32617
<curiosa>gfleury : this is great