IRC channel logs

2022-01-26.log

back to list of logs

<Pellescours>luckyluke: did you do any progress with your 64bit portage of gnumach?
<slex>youpi: heheh, while(1){ code to receive and handle a message } is blocking the server, obviously, and if i start my name server near the hurd it blocks the entire hurd boot. I had the great suspect that this approch was bad, but i had to try, going to prepeare a new mail asking for this and showing the stuff of the prev mail are workin, today or tomorro
<luckyluke>Pellescours: yes I'm at the point where I can start user space tasks, but syscalls need some testing
<luckyluke>and cleanup the patches
<Pellescours>niice
<youpi>slex: your first task should task_resume() the other task once it's ready to answer requests
<youpi>that's how ext2fs does it with exec
<youpi>luckyluke: perhaps you can already contribute some of it
<luckyluke>youpi: sure, I'm cleaning up the patches before going on. I'll send them to bug-hurd in the next days hopefully
<slex>youpi: ok, in the while or before?
<slex>ty
<slex>inside it would resume the task all the time a message is received and handled
<slex>...
<slex>tasks*
<youpi>slex: befire
<youpi>o
<Pellescours>It’s not possible to compile gnumach with --enable-apic, there is an issue with a linux file. I’m investigating
<youpi>I'd say don't bother
<youpi>we'll drop linux drivers before 64bit support
<youpi>that'll be simpler
<Pellescours>yes, I didn’t wanted to test x64 bit actually but I wanted to test the APIC
<Pellescours>actually just set --enable-ncpu=4 enable the apic discovery, that’s what I wanted
<Pellescours>I tried to enable-pae, the boot process seems to hang just after the DHCPDISCOVER.
<youpi>ah, it'd be good to fix pae first
<youpi>that's a first step before going 64bit
<youpi>and first test with not too much ram to avoid any physical address beyond 4GiB
<youpi>(which the linux drivers possibly won't grok)
<Pellescours>I assigned 4GiB of ram to my VM
<youpi>that's a bit too much because some of the addressing space is reserved
<youpi>you can see in the boot logs
<youpi>biosmem: 0000000000fffc0000:000000000100000000, reserved
<youpi>biosmem: 000000000100000000:000000000140000000, available
<youpi>that last line is beyond 4GiB, you'd want to avoid it
<kj7rrv>Is Hurd usable as a desktop OS?
<youpi>depends what you use on your desktop
<youpi>see the faq URL in the topic of the chan
<youpi>no USB or sound support yet
<kj7rrv>youpi: does that mean you need a ps/2 Keyboard and mouse?
<Pellescours>yes
<luckyluke>youpi: what's wrong with PAE?
<kj7rrv>Pellescours: okay.
<kj7rrv>So Hurd basically isn't usable on a newer computer without PS2 ports?
<Gooberpatrol_66>kj7rrv: i think laptop keyboards are commonly ps2, at least mine is
<biblio>luckyluke: I was wondering how can I write such function in assembly. I could not find any easy docs. Can I compile a function and see assembly code to understand how can I make a func call without parameter ?
<Gooberpatrol_66>most of the time hurd is run in a VM though with emulated ps2 devices
<youpi>luckyluke: I don't know, it's supposed to be workig
<youpi>biblio: gcc test.c -o test.s -S
<youpi>kj7rrv: bioses most often provide a ps2 emulation port
<biblio_>youpi: ok
***biblio_ is now known as biblio
<scm>Hi, all.
<kj7rrv>Gooberpatrol_66: oh okay
<kj7rrv>I would try it in its own partition on my laptop, but I already have a lot of GNU/Linux partitions
<kj7rrv>I might try it in a VM
<kj7rrv>Does Hurd have good support for Ethernet cards?
<youpi>kj7rrv: depends what you call "good"
<youpi>it has the linux 2.6.32.65 drivers
<youpi>but no firmware loading support
<kj7rrv>Oh okay
<kj7rrv>Could I run a LAN Website on it?
<kj7rrv>(if my Ethernet card was supported)