IRC channel logs

2022-01-05.log

back to list of logs

***biblio__ is now known as biblio
***iridium.libera.chat sets mode: +o ChanServ
<slex>hello, how mach start the first server when booting?
<youpi>slex: it's the boot script
<slex>ty
<youpi>it's the $(task-resume) part of the boot script that triggers the start of the corresponding task
<slex>ty, im just doing some experminets,learnign by doing, I want see if i can add a custom server at boot time, that just says hello
<youpi>you'd have to use $(task-resume) to let it go, yes
<youpi>note however that it won't be able to use anything else than the kernel
<youpi>in the normal script, it's ext2fs that resumes exec when it knows that things are initialized
<biblio>luckyluke: could you please share vm layout issue code for 64bit port when you have time.
<curiosa>biblio: there is also a SMP enabled repo of Gnumach, I think that before we see a 64bit Hurd we will have SMP Hurd
<damo22>its in master
<damo22>you just have to compile with a flag
<damo22>but to work correctly it needs ACPI to be completed
<curiosa>damo22: sorry I might be disinformed about that, what is this: https://github.com/AlmuHS/GNUMach_SMP
<damo22>that was the groundwork, Almu's work is already in upstream
<damo22>if i recall
<damo22>you also probably have to enable lapic
<curiosa>is it the ACPI driver in gnumach that needs to be completed?
<damo22>no its the userspace part
<damo22>so that pci devices can find their irqs
<damo22>device drivers*
<damo22>actually biblio's patch might be enough to make this work
<damo22>i should test it
<damo22>but for now i need to write my talk
<curiosa>what does it take to test it? Compile mach with SMP and lapic enabled and use it with rumpdisk drivers?
<damo22>yes almost, but you would need to use the acpi translator to provide irq mappings and it wont boot off rump with that yet probably
<damo22>acpi needs to be patched as well
<damo22>i will merge biblio's patch into my tree later today
<damo22>the reason for all this is that when you enable lapic, you are using a different piece of hardware to provide interrupts, the IOAPIC and it has a different way of mapping interrupts to devices
<damo22>the only way to know which irq is which is via ACPI
<curiosa>Ok it seems that it needs quite some patching to make it boot.. it's a bit scary for me
<damo22>yeah its very experimental for now
<curiosa>it would be cool if there was a ramdisk driver in gnumach (is there?), that way one could boot in the ramdisk and then test with the disk driver and irqs
<damo22>you can
<curiosa>I should try that
<damo22>feel free
<damo22>i think the ramdisk driver is part of debian's gnumach
<damo22>not sure if its merged into upstream yet
<biblio>curiosa: I will check. thanks
<biblio>damo22: I sent you acpi partially working libacpi code patch via email. Let me know if you have any feedback.
<damo22>yes thank you, i need to prepare my talk though, i will let you know
<biblio>damo22: welcome. good luck :)
<youpi>damo22: initrd support is not merged yet, it's quite dumb for now
<youpi>there is no way to free it, notably
<youpi>there was an idea of loading it as a task, that you can vm_copy(), and task_destroy()