IRC channel logs

2021-12-28.log

back to list of logs

<Pellescours>damo22: I’m able to boot with disk in sata. But is it possible to boot wit disk in ata with rump? By default disks are is ata with qemu. To be able to remove linux drivers from gnumach, we should supports ata too
<Pellescours>damo22: but when stopping the machine, there is some a timeout somewhere and the disk is not unmounted properly
<Pellescours>wd0d: device timeout reading fsbn 2491836 of 2491836-2491839 (wd0 bn 2491836; cn 2472 tn 0 sn 60) retrying
<Pellescours>and just after I get a message saying that ext2fs died (probably normal because I’m rebooting)
<Pellescours>I tried to write a file and now at reboot I have timeout messages for writing
<Pellescours>I removed completely linux from gnumach sources (locally) and I boot on it
<Pellescours>youpi: I have a strange bug in gnumach, when I build locally gnumach without kdb I have a pagefault and when I build with kdb, there is no problem
<Pellescours>error is
<Pellescours>trapno 14: page fault, error 00000002 \n panic ../i386/i386-trap.c:346: kernel_trap: trap
<youpi>I don't have an i386-trap.c ile
<youpi>*file
<gnu_srs>There is an i386/trap.c though at gnumach/i386/
<youpi>Pellescours: is there no other message before "trapno 14" ?
<Pellescours>there is
<Pellescours>where can a put a screenshot?
<Pellescours>it’s ../i386/i386/trap.c:346 ( / instead of - )
<Pellescours>youpi: https://drive.gitrekt.fr/index.php/s/QFmTkgRCJLEda8f
<Pellescours>to reproduce I just built gnumach with "./configure && make gnumach.gz" and then copied gnumach.gz to /boot in order to boot on it
<youpi>you can use gdb on gnumach to get the source line that poses problem
<youpi>with l * 0x12345
<youpi>where 0x12345 is the eip address
<ArneBab>youpi: it lives! :-) — it’s still a bunch of hacks on top of trivfs, but I now have a translator that asks a FIFO whether a given process should be allowed to access a resource.
<ArneBab>youpi: do you know whom I can ask whether there is still copyright assignment by me on file for the Hurd?
<Pellescours>l *0xf5a40fbf print nothing :/
<youpi>ArneBab: you still have it on the Hurd yes
<ArneBab>youpi: great — thank you for checking!
<youpi>Pellescours: I'd say go with prints in the kernel then
<youpi>to see where it bugs
<youpi>in setup_main()
<youpi>probably somewhere around machine_init()
<youpi>(I mean the call to it)
<ArneBab>and about the copyright assignment: I have a new employer (since 2017) and now have the employer disclaimer of rights on file, too. That’s much more work than the copyright assignment — and checking strictly, it is also necessary to have such a disclaimer of rights to contribute to any project outside work, regardless of copyright assignment. Which is kinda crazy …
<ArneBab>(though my work contract already states that my private work stays mine)
<ArneBab>youpi: my code is still very sketchy, but I have the first fully working prototype. Shall I send it as patch (WIP) to bug-hurd?
<Pellescours>heisenbug… when I try to investigate with print it becomes a "kernel threads accessed user space!" kernel trap
<Pellescours>Is it normal that servers started at boot (ext2fs) appears as ? in "ps aux" and all files in /proc/<pid>/ of the server generate "Input/output error" when we cat on them?
<Pellescours>actually I think that my page fault problem is related to the removal of linux, so something is not well working when we don’t enable linux
<ArneBab>There’s a magic in being asked on the second shell whether cat on the first shell should be allowed to access a file for 5 minutes — and all that in 150 lines of C and 30 lines of shell.
<ArneBab>The sudo-on-request that can be provided from another program and cannot only grant root but any group you like
*ArneBab loves it
<ArneBab>The Hurd is pretty cool
<ArneBab>(but you knew that ;-) )
<ArneBab>(though I have to admit that getting the C to actually work took ages)
***biblio_ is now known as biblio