IRC channel logs

2021-12-26.log

back to list of logs

<damo22>youpi: do you think this is a good title for my talk? "A practical solution for GNU/Hurd's lack of drivers: NetBSD's rumpkernel framework"
<jab>damo22  You
<jab>have my approval.  :)
<damo22>thanks, but i also want to get youpi's opinion as he invited me to speak
<damo22>jab: are you jabjabs?
<jab>I am not jabjabs.  :)
<jab>I am gnucode.me
<jab>I also occassionally post videos of me trying to code on peertube
<damo22>ok
***DiffieHellman_ is now known as DiffieHellman
<biblio>damo22: I was able to compile. First, I build libacpica (after cd libacpica then make.). Then I made a backup of compiled libacpica and remove libacpica compilation from main Makefile. After I applied your patch for acpi I can compile full hurd. and linked it with libacpica.
<Pellescours>biblio: iirc now, if you try to run the compiled program it will fail to acpi_enable_subsystem
<Pellescours>in acpi_init.c
<Pellescours>and we should make it working
<biblio>Pelescours: ok. But did you able to build only acpi ?
<damo22>biblio: you can cd build/acpi && make
<damo22>you dont need to compile all of hurd
<damo22>i just sent in new patches for rumpdisk. it should be working using develop branch of rumpkernel
<damo22>and could be mergeable
<damo22>Pellescours: i have two more working branches of acpica. just two forks with 1 commit each on top of acpica-integrate, one for single threaded and one for attempting to fix the semaphores
<damo22>i think the single threaded version actually works
<damo22>but its missing the critical part that i mentioned to biblio, for selecting the IRQ
<biblio>damo22: no I am getting version.h missing error. when i try to build/acpi it has many other dependencies. But I was able to build full hurd and also acpi with it.
<biblio>damo22: yes I was able to compile single threaded one. by compiling libacpica separately.
<damo22>"fshelp ports shouldbeinlibc netfs iohelp ihash acpica" are needed to compile for acpi i think
<biblio>damo22: yes
<damo22>so yea it actually needs a few hurd libs
<biblio>damo22: before start with IRQ. how can I test libacpica in my local system ?
<damo22>you can write a simple function
<damo22>main() { acpi_init(); return 0; }
<damo22>something like that
<damo22>and link with -lacpica
<biblio>damo22: ok. and for testing. I need also to install this hurd with acpi linked with libapica right ?
<damo22>not really, you can just install "acpi" and libacpica.a
<biblio>damo22: oh yes. ok
<damo22>libacpica.so.*
<biblio>damo22: OK i will try.
<damo22>:)
<biblio>damo22: ACPI Error: AE_IO_ERROR, During OSL initialization (20210105/utxfinit-50)
<biblio>damo22: when I run executable of my function calling acpi_init()
<biblio>damo22: https://paste.debian.net/1224797/
<damo22>EPERM you need sudo
<damo22>because it uses IO ports
<biblio>damo22: https://paste.debian.net/1224798/
<damo22>works
<damo22>so try to call the get_irq thing
<damo22>and you can work on fixing that
<biblio>damo22: ok
<damo22>your test program should call acpi_init() and then acpi_get_irq_number(bus,dev, func)
<damo22>you can find a valid b/d/f from sudo lspci -A hurd
<biblio>damo22: Yes i am trying find which parameter I can send
<damo22>bedtime for me
<damo22>nn
<biblio>damo22: i got irq number 10 for IDE
<biblio>damo22: ok thank you.
<biblio>damo22: gtg also.
<damo22>yes that is good, but there are two pathways remember, one is already coded
<damo22>the other one is missing
<biblio>damo2: 0k noted.
***nckxmas is now known as nckx