IRC channel logs

2021-12-24.log

back to list of logs

<biblio>hi, I want to update "Instant Development Environment" -redir tcp:2222::22 with updated kvm parameters. https://www.gnu.org/software/hurd/contributing.html "edit" button is redirecting to http://darnassus.sceen.net/cgi-bin/hurd-web?do=edit&page=contributing and "timed out".
<damo22>biblio: im not sure if the website is editable anymore
<biblio>damo22: now it seems that edit page is asking to authenticate instead of timed out.
<damo22>biblio: sorry, i dont have any visibility over the website
<damo22>you could suggest the changes as a diff perhaps on the mailing list if you have the source
<damo22>biblio: http://git.savannah.gnu.org/cgit/hurd/web.git/
<biblio>damo22: thanks for the info. It was a minor change I just wanted to replace "-redir tcp:2222::22" deprecated kvm command with newer one.
<biblio>damo22: overall, I am interested in 64bit port status of HURD. If in future, is it possible to port HURD in RISC-V architecture.
<damo22>yes of course its possible
<damo22>we are focusing on i386 port for now because it works, and we can port more drivers
<damo22>i think if people can see it working on at least one type of machine, it will encourage more developers
<damo22>the ACPI, and APIC/SMP stuff is needed for 64 bit support i think so we are getting closer
<biblio>damo22: I agree. I was interested in RISC-V as it has open design. I would be happy to run HURD on a real RISC-V in future.
<biblio>damo22: is there any small development task I can assist for 64bit port. I professionally work on C++. But I have sufficient theoretical knowledge on OS design and hardware (not much practical yet).
<damo22>yes definitely
<damo22>we need libacpica.a to exist so we can link with it
<damo22>we've done work on this previously
<damo22>ideally the ACPICA project will accept our changes upstream so that downstream, debian can compile libacpica.a for the hurd target
<damo22>basically we want ACPI to be a library that runs in userspace
<biblio>damo22: sure. I use Debian mainly. could you share any task link or background info for libacpica.a
<biblio>damo22: yes that's clear. But do I need to compile in QEMU HURD or cross compile in Debian for testing.
<damo22>biblio: so i integrated ACPI into hurd, but we need to break it out into a sepaate library: http://git.zammit.org/hurd-sv.git/log/?h=acpica-integrate
<damo22>separate*
<biblio>damo22: ok noted.
<damo22>you can develop hurd on hurd
<biblio>damo22: how can I run your code for testing ? should I just build inside qemu HURD and link libacpica.a to test ?
<damo22>that is probably the easiest
<damo22>my code actually builds libacpica.a as a hurd lib
<damo22>but what we want to do is extract the part that can be upstreamed and upstream that
<damo22>then we can just use the external lib
<biblio>damo22: yes I am familiar with this.
<biblio>damo22: I can run that inside hurd. But my qemu hurd is running on 32bit how can I test 64 bit functionality ?
<damo22>it will be testing i386 for now
<biblio>damo22: ok sure. I got the idea.
<damo22>once we have i386 working with ACPI it will be one step closer to 64 bit
<biblio>damo22: clear. I have an account in savannah if you need I can log my updates there ?
<damo22>updates?
<damo22>you can mail patches to the mailing list bug-hurd AT gnu.org
<damo22>but this will also require patches to upstream github.com/acpica/acpica
<biblio>damo22: ok. I assumes you are using savannah.gnu.org for this reason.
<biblio>damo22: ok sure. At least I can start with something.
<biblio>damo22: assumed*
<damo22>its a good starting point for someone with C experience
<biblio>damo22: yes I have C, basic assembly and lots of C++ experience.
<damo22>we dont use C++ as far as i know
<damo22>but its still helpful to know
<biblio>damo22: Ya
<damo22>i suggest getting familiar building hurd on hurd
<damo22>in qemu
<damo22>then you can play with my branch
<biblio>damo22: I am trying to follow "Instant Development Environment" https://darnassus.sceen.net/~hurd-web/contributing/
<damo22>that should work
<damo22>you can grab the working qemu image from the topic
<damo22>"disk image"
<damo22>ok gtg
<biblio>damo22: yes it is already running. I was trying to compile gnumach, hurd
<damo22>good luck
<biblio>damo22: thank you.
<damo22>biblio: this part is unfinished, and is critical to the functionality we need in ACPI http://git.zammit.org/hurd-sv.git/tree/libacpica/acpi_init.c?h=acpica-integrate&id=ca5ce0c9b66a8d4128b6c9292adb328bcb732fac#n555
<biblio>damo22: ok noted.
<damo22>it needs to get the IRQ mapping for a PCI card
<damo22>ive left a note on what to do but its a bit vague and requires knowledge of ACPI
<biblio>damo22: Ok. I have basic knowledge of IRQ and ACPI from Linux kernel development books. But I think I can manage.
<damo22>nice
<damo22>basically we just want to know the irq of a pci device by bus/dev/func
<damo22>ive fleshed out most of it
<biblio>damo22: ok
<biblio>damo22: exec-reauth.o failed to build. unknown type name 'const_string_t'; did you mean 'const_procinfo_t'. am I missing anything ?
<biblio>damo22: I was in another branch. now trying from acpica-integrate branch.
<biblio>damo22: I think your "acpica: Import codebase from upstream ACPICA" commit broke build in your local branch. I am getting error "No rule to make target 'acpi_S.h', needed by main.o" after resetting to this commit. But "machdev: Fix parent proc passthrough in fsys_init" commit works. I am trying to cherry-pick your other changes and build.
<Pellescours>biblio: are you targeting the most recent version of libacpia?
<biblio>Pellescours: I am trying with http://git.zammit.org/hurd-sv.git/?h=acpica-integrate