IRC channel logs

2021-12-14.log

back to list of logs

<damo22>Pellescours: i think that error is normal i cant do fdisk -l
<damo22>rekado_: the existing rump is functional but we are in the midst of upgrading rump to current netbsd version
<damo22>rekado_: the existing one is here https://salsa.debian.org/hurd-team/rumpkernel
<damo22>the reason for upgrading is that existing rump chews 600MB ram and that may be fixed in a later version
<damo22>we just dont know because its so old (2019)
<damo22>rekado_: that package gives you librump so you can compile and link with hurd "rumpdisk" from upstream savannah
<damo22>you also need upstream libpciaccess
<damo22>rumpdisk is a translator in the hurd project
<Pellescours>How a real disk is assigned to a device ? I mean how I can know that if I want to add another disk (with qemu) it will be assigned to /dev/wd0 for example?
<damo22>hmm, i think it is enumerated by controller, each rumpdisk instance belongs to an AHCI controller
<damo22>but im not sure how that maps to different disks
<damo22>/dev/wd0 might exist on two rumpdisk instances
<damo22>we're not there yet
<damo22>be aware there is a rumpfs inside the librump that contains the /dev/wd0d
<damo22>we are not exposing that exactly
<Pellescours>and how can I test rump with my build one ? Must I use it for the boot disk or can I use another disk and make that my local rump that I built ?
<damo22>you can boot off IDE controller and exclude the AHCI controller from being taken by gnumach
<damo22>then mount a disk with rumpdisk off the AHCI controller in userspace
<damo22>i think you need to build a custom gnumach with AHCI probe removed
<damo22>otherwise by default gnumach will take all disks
<damo22>its messy yes, but disk is hard
<Pellescours>oh I see
<Pellescours>I’m gonna try
<Pellescours>But this mean that I must use rump for the boot disk ?
<damo22>no you can keep IDE probe and remove AHCI probe
<Pellescours>great
<damo22>and attach your boot disk to IDE
<damo22>but thats not how i do it usually
<damo22>i have a 2.5" SATA disk just for hurd, with different kernels and grub configs
<damo22>and i attach via usb -> SATA dongle and pass /dev/sdd to qemu
<damo22>so i can test the same hurd install with and without rumpdisk
<damo22>booting off it
<damo22>and then when i think its good, i can unmount and plug the disk into X200 laptop and try booting it
<damo22>my code for dev is on a separate partition on that disk
<damo22>as far as i know, "master" boots on native hardware with rumpdisk, but uses a lot of ram
<Pellescours>ok, I don’t have a hurd installed on a real machine so I can only test with qemu
<damo22>i need to roll back from my experiments to prepare the hurd talk
<damo22>real machine just means putting hurd on a native disk
<damo22>you can plug it into any thinkpadish laptop
<damo22>but yeah, its a bit of money that you probably dont have to spend
<damo22>you can work with qemu
<damo22>i already had the spare parts
<damo22>OT: http://zamaudio.com/mbox2/mattndamo-20180211-take2.mp3 our jam seems like yesterday, but my friend had a baby with his gf since then
<Pellescours>with "-drive id=disk,file=test.img,if=none,format=raw -device ahci,id=ahci -device ide-hd,drive=disk,bus=ahci.0" I’m able to have /dev/sd0 being my test.img file :D
<Pellescours>but the kernel is still probing the sata devices, I built gnumach with "./configure --disable-linux-groups --disable-scsi-group --disable-block-group --enable-net-group --enable-ide" so I don’t understand why sata is still probed by the kernel
<Pellescours>Actually it’s maybe a problem with my local rump build
<Pellescours>Ok I’m able to test rump, now It needs implementation of pci_intr_alloc