IRC channel logs

2021-06-26.log

back to list of logs

<Guest36>Uhh the api feels so outdated.. someone smarter them me should port libuv and make a JavaScript wrapper so that we can finally use functional programming to program translators
<Guest36>Looking at https://git.savannah.gnu.org/cgit/hurd/hurd.git/tree/ftpfs/ftpfs.c that’s a _lot_ of boilerplate code
<damo22>Guest36: feel free to clean it up
<damo22>but im not convinced javascript-anything is good
<jrtc27>javascript
<jrtc27>god no
<paulusASol>Zambyte: I would not expect it to allow you to comfortably use USB devices, but you probably could access USB devices via the Rump API (with maybe some little work) in C programs.
<paulusASol>You might even use something like Rumphijack (I believe that was the name of it) that uses LD_PRELOAD.
<paulusASol>But I basically am only guessing, have not idea what is actually supported.
<jrtc27>and it sure is not a good *functional* language
<jrtc27>if you want functional programming use sml, ocaml, haskell, scheme/lisp/etc, ...
<dstolfa>web 3.0, hurd boogaloo
<damo22>paulusASol: after i figure out the last piece of the userspace disk driver puzzle, i can work on usb
<damo22>it will use librumpdev-usb
<damo22>we probably need a new set of RPCs for usb as well...
<damo22>i think its similar to the network stack, in that there are two functional blocks, the core driver and the gadgets that plug in to that
<drakonis>when's the year of hurd on the desktop?
<Guest36>jrtc27: Javascript is basically ubiquitous these days both in the front end as on the backend. It’s not a question of technology but a fact. ECMAscript is decently polished
<jrtc27>a is true, b is utter rubbish
<Gooberpatrol66>damo22: the hero we all need
<jrtc27>and just because it's used for some server-side code and client-side code does not mean it belongs as the low-level language in your operating system
<damo22>im hardly a hero, i cant even fix the thing i broke
<jrtc27>javascript is completely inappropriate for the kinds of things you do in non-trivial translators
<jrtc27>and not just because it is an awful language that should be purged from the face of the eart
<jrtc27>*h
<damo22>rm -fr javascript
<damo22>\o/
<jrtc27>if only
<Guest36>I wouldn’t use it in Gnumach but for everything else it’s junior worst than Visual Basic
<Gooberpatrol66>i can kind of see javascript being used to talk to libraries that are already written in javascript, for use in internet-related translators
<Gooberpatrol66>but probably go would be better
<Guest36>s/junior/not/
<jrtc27>visual basic is a better language than javascript yes
<jrtc27>doesn't mean I'd want to use it
<jrtc27>but it's at least a proper language
<dstolfa>jrtc27: if you had to rate a `git rm`... which has higher satisfaction for you, mips or js? :)
<jrtc27>js
<jrtc27>no question
<dstolfa>hah
<jrtc27>mips was a decent architecture in its day, javascript was never decent
<dstolfa>it was probably okay while it was still a lisp in the early pre-alpha days
<dstolfa>we never saw that js though
<damo22>i think webasm is even worse than js, who wants a compiled language forced into your browser with debug symbols optional??
<dstolfa>a few years ago i heard a talk that contextualized wasm in terms of capabilities and it made more sense than what it does when i just look at the IR and wonder what went wrong
<Guest36>webasm is useless crap, that is clear.
<Guest36>Problem is that it’s made for static languages defying the fact that the html DOM is inherently dynamic
<damo22>i dont mean from a technical point of view, i mean practically, trying to figure out what is running on your machine
<jrtc27>because minified JS is so much better
<damo22>its almost impossible with minified js source, but wont it be worse if its a compiled language?
<Guest36>unironically yea
<damo22>so we'll all need a decompiler built into our browsers
<damo22>to inspect the stream of binaries being injected into our machiens
<damo22>machines*
<damo22>we need HTML+1
<damo22>where everything is a tag
<damo22>and styling applied only
<damo22>no scripts
<damo22>i dont want my browser to be a platform for installing code anymore
<dstolfa>i'm not sure any of us have much a say, browser see ramstick, browser eat ramstick, browser grow functionality
<Guest36>damo22 how could that be touring complete?
<damo22>that sick joke has to stop
<Gooberpatrol66>i'm with the suckless guys, we should replace html with s-expressions
<damo22>touring complete is when i can tour the web without getting injected with code
<damo22>just delete the javascript interpreter
<Guest36>The tendency is to move more and more on the client side of web apps, you have no idea often even paying forms and serious business logics is run unchecked on your browser nowadays
<damo22>i know everything is pushed into a js blob
<damo22>because its faster to load
<Guest36>I could once buy a bus tickets for an unexistent bus in India by crafting the right html header
*dstolfa would like to get more than 6 hours of battery life when using a browser
<dstolfa>seems unlikely though
<damo22>but one can write a server that serves content
<damo22>and still use REST apis
<damo22>maybe html can have a tag that explicitly fetches json from a url
<drakonis> https://github.com/AlmuHS/GNUMach_SMP this owns
<damo22>drakonis: almuhs did a good job, its merged but doesnt quite work yet, we still need libacpica
<dstolfa>damo22: you know, the worst thing is that people nowadays build a bunch of applications using electron and the likes that are meant to be desktop applications. makes it even worse because now you have 10 different browsers all with their own versions of all this mess
<drakonis>what else is there in the vine for hurd atm?
<Guest36>dstolfa Just don’t install apps, the online version is often as good or identical
<drakonis>the mailing list doesnt touch on a lot of things
<damo22>drakonis: you can compile a smp enabled gnumach with this http://git.savannah.gnu.org/cgit/hurd/gnumach.git/commit/?id=214866d58ac2bd1060132b250bf391a495110015
<damo22>there are a number of fixes you probably need master
<drakonis>ah so the work was moved to the main tree
<drakonis>neat
<damo22>yeah but the commit above was also needed to add APIC support, you cant really have smp without apic interrupts
<damo22>and there is a bit of work left to detect how devices are wired to PCI interrupts, using ACPICA
<damo22>otherwise you cant even use the APIC
<damo22>since you dont know which interrupt to use for which device
<damo22>that part is still TBD
<drakonis>is there any plans to actually clean up the hurd website?
<drakonis>give it the guile treatment?
<drakonis>its really really messy and out of date right now
<drakonis>guile looks incredibly approachable
<drakonis>getting into hurd can be difficult due to how over the place everything is
<Gooberpatrol66>drakonis: i see patches getting merged for it, you can change what you think needs fixing
<drakonis>i aint no website designer
<damo22>youre welcome to ask questions about hurd on the mailing list
<damo22>or here if you can wait for an answer
<damo22>the mailing list isnt just for patches
<drakonis>i'm here all day, for the rest of the universe's lifetime
<drakonis>until the heat death of the universe
<Gooberpatrol66>i see you're optimistic about the year of the hurd desktop /s
<drakonis>i'm just working out how to host a mail server on my vps
<damo22>mail is not easy
<damo22>i gave up
<drakonis>i have guix here
<drakonis>i already own a domain
<Gooberpatrol66> https://github.com/LukeSmithxyz/emailwiz
<damo22>i used to run a mail server on a raspberry pi
<damo22>it kept getting spamed
<damo22>i dont have time to figure out mail. so i pay a 3rd party who isnt google / apple to take care of just my mail
<drakonis>well, guix has services for mail
<drakonis>the full range
<jrtc27>mail isn't just about installing the software
<jrtc27>making sure your mail doesn't get blocked can be a pain
<damo22>+1
<Gooberpatrol66>last time i checked, guix didn't have postfix packaged
<drakonis>aye
<drakonis>no postfix, yeah
<drakonis>sadly
<drakonis>there is exim though
<damo22>i find protonmail is good with BYO domain
<drakonis>dont you have to pay extra for that?
<damo22>yes
<damo22>you pay for them to take care of your mail
<damo22>but they dont sell your info
<drakonis>well that defeats the point of what i'm trying to achieve here
<damo22>or at least they claim they done
<damo22>dont*
<damo22>which is better than some other providers
<damo22>ideally my mail would arrive at my house
<damo22>on a server i control
<damo22>but its a lot of work to ensure your mail isnt getting blocked by other providers like gmail etc
<damo22>you need dmarc, spif records, dnssec all that extra stuff
<damo22>or whatever
<Gooberpatrol66> http://www.opendkim.org/
<paulusASol>drakonis: Getting even minor merged into the official website used to need forever, see e.g. (but it looks somewhat more up to date now, just no one writes anything new): https://lists.gnu.org/archive/html/bug-hurd/2019-09/msg00010.html
<drakonis>wonderful
<paulusASol>And anything more than updating the stylesheets probably just will be nearly impossible to achieve for the Hurd, without "losing" access to important old documentation.
<paulusASol>In my dormitory (with dozens of volunteering students, at least a dozen of which have acquired the access to the website), after two years we have not yet managed to put the information on how to use the printer properly on the "new" website, despite having replaced the website already two years ago and repeatedly receiving support requests about it.
<paulusASol>Now imagine how that would work for something more complex with even less volunteers (and presumably, invested time by most volunteers) like the HURD.
<yury_t_>hi, could anyone enlighten me please, what're modern hurd's hardware requirements and its footprint?
<yury_t_>also, how does the complexity of hurd's source compare with linux kernel's?
<Dumbo_p94>can an userspace driver in the hurd install his own IRQ vector?
<Dumbo_p94>reading https://www.gnu.org/software/hurd/open_issues/user-space_device_drivers.html#index1h2