IRC channel logs

2021-06-14.log

back to list of logs

***p2-mate_ is now known as p2-mate
<damo22> http://paste.debian.net/plain/1201148
<damo22>so wierd
<damo22>i dont know how to fix this
<damo22> https://paste.debian.net/plain/1201154 this is really strange
<damo22>it seems to insert /hurd/startup in the proc/?/exe where the stat is missing
<damo22>gnu_srs: youpi: ^
<damo22>youpi: in launch_core_servers, ess_tasks is empty
<damo22>so how do i get the list of filesystem tasks
<damo22>eg, pci-arbiter, rumpdisk, ext2fs
<youpi>damo22: according to the wiki bootstrap page, S_startup_essential_task is called after launch_core_servers, so that's why the list is empty
<damo22>currently proc_child () is called only on the fstask and auth initially, but i think it needs to be called on all of the filesystem tasks
<damo22>but i dont know how to retrieve what was booted
<damo22>the code currently assumes there is only one task involved with booting the filesystem
<damo22>i could hack it by looking through all the pids above 4 and matching the names of the processes to a list?
<youpi>that'd make the picture even more confusing
<youpi>look at the bootstrap page
<youpi>all bootstrap tasks call startup_essetial_task
<youpi>you can get the list from there
<damo22>but not so early in launch_core_servers
<youpi>that's after launch_core_servers yes, but I don't think you need to do the child mangling as early as launch_core_servers
<damo22>ok i will try to move it after the fsys_init call
<youpi>which fsys_init call ?
<damo22>in launch_core_servers
<youpi>ah, yes that should be returning after the startup_essential_task calls indeed
<youpi>but perhaps it'd hang because it's single-threaded ?
<youpi>Mmm, no it would have already hanged if so
<damo22>the reply is sent first
<youpi>ok but startup is blocked inside the fsys_init() call while others are calling S_startup_essential_task
<youpi>that other call needs to be processed in another thread
<damo22>why not do it once the fsys_init completely returns?
<damo22>"it" being the child mangling
<youpi>I wrote it above, yes that should be the right time
<youpi>I was just afraid that it might deadlock
<youpi>but probablky not
<youpi>anyway trying is the best way to know
<damo22>ok
<damo22>if you dont proc_child the auth and fstask it hangs
<youpi>it hangs where?
<damo22>if i dont proc_child the authtask, it fails on one of these calls and does a backtrace: err = proc_task2proc (procserver, authtask, &authproc); err = proc_mark_important (authproc);
<damo22>if i dont proc_child the fstask, it hangs somewhere i dont know yet
<damo22>i think it needs the fsproc to call fsys_init err = proc_task2proc (procserver, fstask, &fsproc);
<damo22>its hanging at this point Hurd server bootstrap: ext2fs[part:2:device:wd0] exec startup proc authHANG
<damo22>and fsys_init is not reached
***Pellscours is now known as Pellescours
***Alicia_ is now known as Alicia