IRC channel logs

2021-03-30.log

back to list of logs

***Server sets mode: +nt
<damo22>hmm it got to INIT: version 2.96 booting
<damo22> https://uefi.org/specs/ACPI/6.4/06_Device_Configuration/Device_Configuration.html?highlight=dsdt#mapping-fields
<damo22>These objects have _PRS, _CRS, _SRS, and _DIS control methods to allocate the interrupt. Then, OSPM handles the interrupts not as interrupt inputs on the interrupt controller, but as PCI interrupt pins. The driver looks up the device’s pins in the _PRT to determine which device objects allocate the interrupts. To move the PCI interrupt to a different interrupt input on the interrupt controller, OSPM uses _PRS, _CRS, _SRS, and _DIS contro
<damo22>l methods for the PCI Interrupt Link Device.
<damo22>this is very complex
<damo22>PRT says which "LNK" is mapped to which INTx pin and then you have to parse the LNKs to find methods to configure the actual PCI interrupt
<damo22>then you choose one from the resource list and call the ACPI method to switch the irq
<damo22>since actual APIC pin of device is configurable in software
<damo22>but there is also another option where all this is bypassed and the PRT routing table says which actual APIC pin is connected to each LNK
<damo22>but it depends what is in the DSDT
<damo22>youpi: what can i use for spinlocks in userspace?
<damo22>pthread_mutex_t ?
<damo22>ar: creating libacpica_p.a
<damo22>ranlib libacpica_p.a
<damo22>haha it linked
<damo22>well compiled anyway
<youpi>damo22: usually you don't want spinlocks in userspace
<youpi>so mutex should be fine
***Emulatorman____ is now known as Emulatorman
<youpi>damo22: the commit I have just pushed (Keep BIOS mapped even without Linux) is necessary for proper boot without linux drivers, apparently