IRC channel logs

2021-02-28.log

back to list of logs

***Server sets mode: +nt
<damo22>something is wrong with looking up netfs when you dont have a protid and assume the root node
<damo22>you always get the top level entries
<damo22>how do i traverse a netfs tree to do a lookup when i dont have a protid passed into netfs_S_dir_lookup ?
<damo22>it should be possible to do the lookup from the root node
<damo22>can i fake a protid with dummy credentials?
<damo22>argh, im close but no cigar
<damo22>it traverses one config file
<damo22>but cant seem to recurse and pick up the rest, dir_readdir seems to work once but when you increment the start, it finds nothing after that
<gnu_srs1>damo22: I'm really wishing for you succeed!! This would be a milestone for the availability of Hurd on real hardware ;)
<damo22>gnu_srs1: maybe you can help, how do i use dir_readdir properly
<damo22>dir_readdir (port, &data, &size, *first_entry, 1, 0, &nentries); <--- i am calling this to read each port = file_name_lookup_under (pci_port, ...)
<damo22>the "1" is supposed to only read one directory at a time, but when i call it with first_entry incremented i get no more directories
<damo22>im starting to wonder if dir_readdir keeps some internal state and does not like being called twice
<damo22>hmm unless there is a missing link in the directory structure
<gnu_srs1>damo22: Which implementation of dir_readdir do you target: libdiskfs, libnetfs, libtreefs,libtrivfs(not implemented)?
<damo22>libnetfs for pcifs
<damo22>i need to call the generic __dir_readdir RPC in libpciaccess because i cant make it rely on netfs?
<gnu_srs1>The only Hurd code where dir_readdir() is called is in trans/fakeroot.c
<damo22>get_dirents in pci-arbiter/netfs_impl.c is showing only one entry per directory
<gnu_srs1>and nfsd/ops.c
<grx>oh noes, gnu.org is down :(