IRC channel logs

2021-02-27.log

back to list of logs

***Server sets mode: +nt
<damo22>rekado_: hi, i use a separate disk with a debian native hurd image installed, and boot qemu off /dev/sdd
<damo22>plugged into usb with a usb->sata cable
<damo22>i build hurd from upstream savannah and install binaries to my native install and reboot into it
<damo22>reboot the vm
<damo22>my development environment is on a separate partition on that disk
<damo22>my root partition is at the start of the disk and only has 10GB size, because some drivers cant access large disks
<damo22>it sometimes has a truncated view of the block device
<damo22>rump is going to solve that
<damo22>at this point i am only compiling statically linked binaries to test the boot sequence, so im not replacing libs on my system
<damo22>pci-arbiter.static and rumpdisk.static
<damo22>the workflow is handy, i can run e2fsck on the native disk in linux outside of the vm
<damo22>does anyone know how RPCs find the right prefix such that eg, dir_readdir -> finds netfs_S_dir_readdir ?
<damo22>is there some kind of lookup involved that could be missing the root filesystem?
<gnu_srs1>damo22: If you want help from Samuel you have to use the bug-hurd ML.
<gnu_srs1>Here is some stuff on RPC: https://www.gnu.org/software/hurd/hurd/rpc.html
<damo22>im getting further
<damo22>no more hang
<damo22>i need to debug the pcifs netfs implementation
<damo22>so it can look up the filesystem without a dircred or user
***cbaines_ is now known as cbaines
<SlySven>Can I say something here, now?
<SlySven>Ah, so registering with the nickserver does help - it has been many years (close to 30 I think) since I used IRC "in anger"!
<ThinkT510>SlySven: tends to be quiet around here so you may have a long wait if you want an answer to a question
<SlySven>It's okay - I look through the channel logs in the listing at the top of the page (in the webchat client anyhow) - and I presume anyone who is dedicated enough would be reviewing them or using some other means to check that they haven;t missed anything useful...!
<SlySven>Sadly, I've been using Discord too much recently and have gotten all coddled by the ability to correct typoos in messages after sending them. 8-P
<ThinkT510>Matrix has that too
<SlySven>Matrix (?) that is some other IM/Chat system that has forged a link up to (Freenode's) IRC isn't it?
<SlySven>TBH I haven't used IRC "in anger" for close to 30 odd years so I am as rusty as heck!
<ThinkT510>Yeah, Matrix is a chat protocol that is free and distributed. Part of the decentralised/fediverse
<mdevos>SlySven: did you ask a question? I don't see any in http://richtlijn.be/~larstiq/hurd/hurd-2021-02-27
<ThinkT510>this channel seems to have a matrix bridge
<SlySven>I was getting blocked from posting - i think it was 'cus I wasn't registered and am using the "webchat" browswer client.
<SlySven>My question is about local keyboard handling in the Hurd - I've gotten it running on some real hardware but using a local keyboard and screen during install and afterwards is almost impossible - though SSH is fine.
<mdevos>SlySven: I can't help you with that, I haven't ever ran the Hurd outside a VM. But perhaps someone else could help ...
<jrtc27>hurd relies on your bios emulating a ps/2 keyboard
<jrtc27>it doesn't have a usb stack
<SlySven>Basically the local keyboard seems to mess up its "queue" of key-presses so that you press a key and nothing happens then you press a different key and the first one "fires" (shows up on screen and gets consumed).
<jrtc27>that kind of thing is intended to be dealt with by the effort to integrate rump-based drivers
<jrtc27>hm
<SlySven>Trouble is that the hardware only has USB.
<jrtc27>sounds like your bios's emulation is a bit borked
<SlySven>True - I started to talk with Samuel T about this...
<jrtc27>I forget the details about the IBM PC keyboard controller but it might be possible that a polling mode would paper over the problem, if the problem is that interrupts don't happen when they should
<SlySven>In the installer the size of the "queued" up keypresses never got beyond 5 or 6 which is consistent with one mode of operation apparently.
<jrtc27>although I'd then expect it to notice both keys on the second key press...
<SlySven>But once installed (using a different PC with a real(!) keyboard) and then the HDD was transplanted back - I found that once booted and at the local "console" the queue could grow to over 50 keypresses (by using num-lock to pad them out).
<SlySven>".. expect to notice both keys on the second key press..." nope - is more like a FIFO.
<SlySven>FTR The Hardware is a Dell Dimenson 5150 - there is a BIOS update available (from the current "A05" to "A07") but I'd have to find a floppy drive and a MSDOS type boot disk to do that  and it isn't obvious that it would fix anything...
<SlySven>... anyhow I am not giving up, just yet. I did make a patch (though it was not used) to get the second wheel on an mouse with an atypical protocol working properly in the Linux input drivers area. I just need to get a better idea on how it (the Hurd) hangs together. 8-)