IRC channel logs

2020-11-16.log

back to list of logs

***Server sets mode: +nt
***apteryx is now known as Guest7992
<gnu_srs2>Hi, any ideas on how to work around the linux-specific gettid()? From gettid(2): gettid() is Linux-specific and should not be used in programs that are intended to be portable.
<jrtc27>there's pthread_getthreadid_np() and pthread_threadid_np(pthread_self(), &tid);
<jrtc27>though I don't think hurd implements them
<jrtc27>could always resort to casting pthread_self() to an integre
<jrtc27>*er
<gnu_srs2>jrtc27: Thanks. Unfortunately pthread_getthreadid_np pthread_threadid_np is not in Hurd.
<gnu_srs2>And pthread_self() does not work either, see http://clanguagestuff.blogspot.com/2013/08/gettid-vs-pthreadself.html
<jrtc27>gettid can reuse ids
<jrtc27>just like getpid can reuse pids
<jrtc27>it's just less likelly
<jrtc27>if you need something that's unique across any thread ever spawned you need to manage that yourself
<civodul>with gdb, i'm unable to get usable backtraces from dumped cores or when attaching to a running process
<civodul>i mean usable backtraces
<civodul>i got get good backtraces on processes spawned from gdb, though
<civodul>does that ring a bell?
<oss9_>hi, I am trying to install hurd on my Lenovo S20 workstation for testing. I wrote debian-sid-hurd-i386-DVD-1.iso in a pen drive using dd. But, I am getting "No device for install media was detected." any clue ?
<jrtc27>hurd doesn't support USB
<jrtc27>you'll need to use an actual CD drive or an IDE/SATA internal disk
<jrtc27>but you will likely prefer using a VM under Linux+KVM
<oss9_>jrtc27: noted
<oss9_>jrtc27: I tested in VM but I wanted to try in a real machine. Thank you for CD, IDE/SATA info.