IRC channel logs

2020-10-25.log

back to list of logs

<AlmuHS>hi
<AlmuHS>reading the history, I noticed that some person from my spanish tg group about Hurd was talking here some days ago :-)
<AlmuHS>damo22: do you need help with your Thinkpads? ;)
<damo22>hi
<damo22>AlmuHS: i dont have very many currently, but i am collecting them
<AlmuHS>in T410, Hurd runs fine
<AlmuHS>even better than T60
<damo22>mainly sandy bridge and ivy bridge thinkpads
<damo22>because they run with coreboot
<damo22>and ME can be mostly removed
<AlmuHS>coreboot is a TODO for me
<AlmuHS>it required a difficult process to flash
<damo22>i know, sorry about that
<AlmuHS>so I have not installed yet
<AlmuHS>but, even with the default BIOS, Hurd seems to works well
<damo22>unfortunately the SPI chipset comes locked down from the vendor and we havent figured out how to unlock in software yet
<AlmuHS>in fact, i had some problems with the shutdown
<AlmuHS>in T410, the ACPI shutdown crash in a infinite loop
<damo22>yes, there are various issues
<damo22>oh i know why that is
<damo22>the ACPI is assuming the power off sequence is one of two values
<AlmuHS>in T60 and R60e, the shutdown works, but the system enter in a strange status, and when i try to turn on again the screen keeps in black
<damo22>but it needs to parse it properly
<damo22>so needs acpica code
<AlmuHS>could be possible to implement acpica as a Hurd server?
<damo22>currently hurd's ACPI only works with qemu for now
<damo22>yes
<damo22>that is on my todo list
<AlmuHS>btw, my SMP code for APIC is ready. Now you can implement APIC timer and IOAPIC
<damo22>yes i got your email but im not sure when i will have time to do it all
<damo22>AlmuHS: is that your group planning to teach people how to live in self-sustainable society?
***Server sets mode: +nt
<AlmuHS>now I'm resting before continue my SMP work. These weeks were tiring
<damo22>AlmuHS: you have interesting projects
<damo22>:)
<AlmuHS>the next stage of SMP will be difficult
<damo22>i have a branch where i made lapic timer almost working
<damo22>but it was based on old code
<AlmuHS>yes, i remember it
<AlmuHS>the lapic timer can be useful to create a good delay() function
<AlmuHS>to synchronize the IPI sending properly
<damo22>i got a new thinkpad W520
<damo22>its a very nice model
<AlmuHS>yes
<AlmuHS>good model to test Hurd ;)
<damo22>yes, 8 threads and 24GB ram
<AlmuHS>WOW
<damo22>i can upgrade to 32
<AlmuHS>in my T410, I tested 6 GB RAM. But It seems that gnumach has not enabled PAE by default
<AlmuHS>so gnumach only detected less than 4 GiB
<damo22>yeah
<damo22>we need to get the x86_64 port going
<AlmuHS>but PAE might be detected more than 4 GB
<AlmuHS>*might detect
<AlmuHS>but I'm not sure about how to enable it
<damo22>im happy with 4GB for now in qemu
<damo22>for testing
<AlmuHS>yes, i never filled all the RAM
<AlmuHS>but it's a curious thing
<AlmuHS>other curiosity was testing my old SMP microkernel in the T410. I noticed that, after enable a cpu, the machine reboots
<damo22>switching PIC -> APIC will be a big step
<AlmuHS>maybe the T410 are using x2APIC, which has different structure in IRC field
<AlmuHS>i will try to force the using of xAPIC in all machines after detect the APIC
<AlmuHS>x2APIC makes not sense by now
<damo22>im still stuck on rump trying to install the boot driver as a translator
<damo22>but i think we fixed most of the bugs with pciaccess
<AlmuHS>may you need an intermediate code to communicate gnumach with the translator
<AlmuHS>because, in any case, the boot will starts in gnumach
<damo22>gnumach is not involved with rump disks
<damo22>except to pass messages
<AlmuHS>ok
<damo22>rump runs as a process in userspace
<AlmuHS>but, the boot driver must be the first before the rest of translators, is not?
<damo22>there is a special dance to pass the bootstrap port to the rump driver
<damo22>it is a static binary
<damo22>so it can load as a standalone driver
<damo22>just like ext2fs gets loaded
<AlmuHS>ok, i think that i don't have enough knowledge about this
<AlmuHS>with ext2fs I had a problem some months ago, related with Mach
<damo22>your freeze is solved i think
<AlmuHS>i configure the cpu0 as bound processor (stop the rest of processors and boot only with cpu 0). And, with this, ext2fs get freezed
<damo22>it was a long standing bug in the code
<AlmuHS>the ext2fs thread problem?
<damo22>i think it was related to something like PIE binary and offset 0
<AlmuHS>i remember that the problem was in a thread which was never assigned
<AlmuHS>maybe the problem was this, the PIE binary and offset 0
<damo22>oh ok
<AlmuHS>i don't know if we are talking about the same problem
<damo22>me too
<damo22>anyway, what time is it there
<damo22>you need sleep
<AlmuHS>1:55
<AlmuHS>today is hour change
<damo22>ZZZzzzz
<AlmuHS>yes, all my family is sleeping, XD
<damo22>ok
<damo22>im really enjoying this 1920x1080 screen
<damo22>i can use two terminals side by side and compare
<AlmuHS>I have a FHD IPS panel in my T440p, and it's great
<AlmuHS>the HD panel of my X230 seems a toy together this
<damo22>yeah
<damo22>x230 has 1366x768?
<AlmuHS>i think yes
<AlmuHS>and it's a TN panel, with a very poor color quality
<damo22>ok
<damo22>i bought another x230 really cheap
<damo22>i will fix it and add it to the collection
<AlmuHS>there are a mod to put a FHD panel in X230, but the cable is more expensive than the self machine, XD
<AlmuHS>i bought a very beautiful x220
<AlmuHS>really cheap, 66 €
<damo22>nice!
<damo22>x220 has problem with coreboot you need to limit cstates to have it not crash randomly
<damo22>but it doesnt happen very often
<AlmuHS>my x220 has a little problem turning on, and sometimes it's necessary press the button two times
<AlmuHS>but it's not a great problem
<damo22>oh you can put the factory bios back on and reflash the EC
<damo22>it should resolve your issue
<AlmuHS>i research about this
<damo22> https://github.com/hamishcoleman/thinkpad-ec
<damo22>this lets you unlock battery restrictions on x230
<AlmuHS>some days ago, i tried to install advanced bios. But the installation requires execute some scripts over windows
<AlmuHS>yes, I applied this last week over my X230
<damo22>nice
<damo22>you can generate USB key that will boot
<damo22>and fix the bios
<AlmuHS>the advanced bios allows to unlock many interesting characteristics, but It required windows for installing :(
<AlmuHS>yes, I installed Thinkpad EC in my X230 using a USB
<AlmuHS>but there are a more advanced BIOS than this
<damo22>yeah, you probably want coreboot eventually, and then it will unlock everything including the ability to reflash any bios internally
<AlmuHS> http://x220.mcdonnelltech.com/resources/
<AlmuHS>yes, but coreboot required a hardware flashing, and I am affraid about damage my machine
<AlmuHS>*requires
<AlmuHS>this is the other advanced bios http://x220.mcdonnelltech.com/bios/
<damo22>you can safely flash your x220 with a pomona clip and raspberry pi
<damo22>because the first step is to read the flash only, to save a backup for restore if everything goes wrong
<AlmuHS>a friend used a clip like this https://www.amazon.es/gp/product/B07SNTL5V6/?tag=homelabbers_es-21
<damo22>yep
<damo22>but i find the cheap clips dont stay on the chip very well
<damo22>because their spring is usually too strong
<AlmuHS>yes, other friend broken its BIOS chip with a cheap clip
<damo22> https://i.ebayimg.com/images/i/181541352406-0-1/s-l1000.jpg
<damo22>thats the best one
<AlmuHS>thanks
<AlmuHS>it's difficult to find it to purchase
<damo22>search pomona 5250
<AlmuHS>ok
<damo22>if you need to do x200, you probably need 16 pin SOIC
<damo22>pomona 5252 i tihnk
<AlmuHS>i need x220
<AlmuHS>and maybe T60
<AlmuHS> https://es.aliexpress.com/item/32394998027.html?spm=a2g0o.productlist.0.0.fff42de94FPQjF&algo_pvid=fa3fc0eb-9543-4b8f-a948-2a3933feeb37&algo_expid=fa3fc0eb-9543-4b8f-a948-2a3933feeb37-1&btsid=0bb0623216035849969055974eb7a0&ws_ab_test=searchweb0_0,searchweb201602_,searchweb201603_
<AlmuHS>oh, I think that It is https://es.aliexpress.com/item/32811055460.html
<damo22>it should be blue
<damo22>the real ones are blue
<damo22>not black
<damo22>watch out for fakes
<AlmuHS>yes, I'm checking
<AlmuHS> https://ie.farnell.com/pomona/5250/test-clip-8-pos-1-27mm-soj-soic/dp/2406243
<damo22>yep
<AlmuHS>ok, i will wait until this will be back in stock
<AlmuHS>now I go to sleep
<AlmuHS>bye, and thanks
<damo22>bye
***Server sets mode: +nt
***Server sets mode: +nt
***Server sets mode: +nt
***nly` is now known as nly
<rekado>you can also flash with Zerocat: http://www.zerocat.org/chipflasher.html
<rekado>you can also flash with Zerocat: http://www.zerocat.org/chipflasher.html
<rekado>that’s how I flashed libreboot onto my (now broken) X200S a few years ago