IRC channel logs

2020-07-02.log

back to list of logs

***Server sets mode: +nt
***rekado_ is now known as rekado
<damo22>youpi: ive refactored IRQ handling such that gnumach "linux" drivers still work, but netdde does not know how to use the new interface
<damo22>im not sure how to implement the device_open("irq")
<damo22>i was hoping you could take a look at my changes
<damo22> http://git.zammit.org/gnumach-sv.git/log/?h=irq-as-device
<damo22>i kept the RPC interfaces mostly the same, but deprecated the use of certain parameters so they can easily be removed
<damo22>the main change is that line is now not needed but instead an ID for the irq
<damo22>the id is just an integer but points to a member of an array of arch-specific irq_t
<damo22>how do i implement "irqopen" instead of "nulldev_open" ?
<youpi>I'd say don't bother with RPC compatibility: we'll change the RPC id, so callers will know with BAD_ID when the new interface is not available, and fallback to the old one
<youpi>I'm not sure what you mean about “instead of "nulldev_open"”, you can follow how other drivers work
<youpi>for code reviews, it's much simpler to send a diff to the mailing list
<youpi>so we can comment altogether in mails
<youpi>it also has the advantage of showing on the mailing list what is happenin
<youpi>the problem of irq channels is that it's actually little exposed
***Server sets mode: +nt
***Server sets mode: +nt
***__shymega__ is now known as shymega
<youpi>yay llvm 11 builds fine unpatched :)
<plasma41>:-)