IRC channel logs

2020-04-28.log

back to list of logs

<damo22>almuhs: hi
<damo22>i got some advice and it might be better to use ACPICA in userspace instead of in gnumach
<damo22>the APIC/MADT table can be parsed in gnumach with minimal code
<damo22>i'll be back soon
<almuhs>damo22: you can use my current ACPI code, hardcoding the MADT address, and mapping the rest of the elements
<almuhs>if you knows the main address of APIC table, you can remove the "travel" from RDSP. https://github.com/AlmuHS/GNUMach_SMP/blob/smp/i386/i386at/acpi_rsdp.c
<almuhs>after this, the rest is to map lapic and ioapic
<almuhs>damo22: what is the APIC table address?
***Server sets mode: +nt
***Emulatorman___ is now known as Emulatorman
<almuhs>after damo22 has decided to build ACPICA in userspace, I've decided to refactor my current ACPI code, instead move It to a server, or use ACPICA
<almuhs>I want to move this code after paging configuration. But I'm thinking about hardcode the APIC table's address. Is this a good idea?
<almuhs>my current code is here: https://github.com/AlmuHS/GNUMach_SMP/blob/smp/i386/i386at/acpi_rsdp.c
<almuhs>if I hardcode the APIC table's address, then I could remove the code to find this table from RSDP
<almuhs>and only keep the APIC table parsing