IRC channel logs

2020-04-21.log

back to list of logs

***Server sets mode: +nt
<damo22>gday
***rekado_ is now known as rekado
<youpi>gnu_srs: Ineiev will not care what Debian does
<youpi>he will always strictly stick to the GNU principle
<gnu_srs> youpi: So adding copyright and license info to all patches larger than 10 lines is the only solution?
<youpi>yes
<damo22>gretings
<damo22>greetings
<damo22>i forgot what is next
<youpi>you were having issues with some processes dying ?
<youpi>and reboot not working
<damo22>ah yea
<youpi>concerning reboot, I'm thinking that rumpdisk is not registering itself as "don't kill me on kill -9 -1"
<damo22>if i pass the host-priv port to ext2fs using the same port as i pass to rumpdisk on the grub commandline, wont it fail?
<damo22>i thought rump will use the port and it will deallocate it soon after?
<youpi>what do you mean by "pass" exactly?
<damo22>'${host-port}'
<youpi>ok, AIUI that will give ext2fs another send right
<youpi>so that should just work
<youpi>but as I mentioned, passing it through getpriv should work as well, provided that you use COPY_SEND, not MOVE_SEND
<damo22>yea i updated my code to use COPY_SEND
<youpi>about termination: rumpdisk should be calling startup_essential_task(), otherwise it'll get killed by kill -9 -1
<youpi>see the call inside libdiskfs
<damo22>okay
<youpi>it's done in fsys_init(), which is called by startup, to tell the / translator it's ready for the startup_essential_task() call
<damo22>so i need to implement trivfs_S_fsys_init() ?
<youpi>I would say that libdiskfs should forward that fsys_init() call to its bootstrap parent
<youpi>and rumpdisk needs to implement it yeah
<damo22>how do you remember all this stuff?
<youpi>I don't
<youpi>I only thought about what is supposed to happen on reboot/halt
<youpi>which is basically what it prints on the console
<youpi>shutdown processes
<youpi>kill them
<youpi>tell translators to shut down
<youpi>but how does it know what is a translator
<damo22>yeah ok
<youpi>then I did remember about that "essential" thing
<youpi>so I grepped the code
<youpi>and startup_essential_task showed up
<youpi>and there the comment Called by init to give us ports to the procserver and authserver as described in
<youpi>really, one can not hope to remember everything, that just doesn't work with nowadays software
<damo22>indeed
<youpi>so one has to get used to browsing the code efficiently
<damo22>git grep
<damo22>and ctags
<youpi>yes
<damo22>i need to fix my ctags
<damo22>i used to have it print a dropdown
<damo22>and i could jump to a selection of things
<damo22>now it just jumps to first one automatically
<damo22>and sometimes its wrong
<youpi>you probably have a shortcut to ask for the next one
<youpi>in vim it's :tn
<youpi>and you can use :ts to select
<damo22>thanks!!
<damo22>set tags=tags\; <--- this works well for me
<damo22>ctrl-] is :tn i think
<youpi>ctrl-] is :ta
<youpi>and you can use :tn to get the next one
*civodul has code that hits "hurd: Can't add reference on Mach thread" (from libc's hurdsig.c)
***dingenskirchen1 is now known as dingenskirchen
<almuhs>damo22: could you implement the access to RSDT table in your ACPI translator?