IRC channel logs

2020-04-15.log

back to list of logs

<youpi>gnu_srs: AFAICT, flavioc's master is already merged into mig master
<youpi>there is a WIP c-type branch there, but it needs to be sorted out, there is a lot of stuff in there
***Server sets mode: +nt
<damo22>rekado_: if i recall correctly, rump has virtio pci device support as a library, you can link the lib with the libpci component and you get it for free
<damo22>librumpdev_pci
<damo22>i think luckyluke[m] tested it a long time ago
<damo22>but the interesting part is we now have rump working on real pci devices :) i just need to figure out how to make it boot from /
<damo22>in theory, one day you could link rumpdisk.static with librumpdev_virtio or something like that and you'd be able to boot from a virtio disk
***rekado_ is now known as rekado
<rekado>I wonder why the News section on the website does not reflect the contents of the news/ directory in the website repository.
<rekado>youpi: if the primary way to edit the web pages is through git (and not through the web interface), would you be interested in converting the website into a statically generated site (e.g. with Haunt)?
<rekado>I could take care of this if you want.
<damo22>i think libpciaccess uses /dev/mem which will not work at boot
<damo22>can gnumach provide an interface to flat memory space for special mmio
<damo22>all i need is some kind of handle into it
<damo22>mmio region is usually reserved in the memory map anyway, why cant it just pass it through?
<damo22>i assume thats where pci device memory ranges live
<rekado>damo22: looking at “kernel principles” I think you could expose a memory range as the memory map backing a Mach device.
<rekado>I’m looking at page 63 of “Mach 3 Kernel Principles”. The device memory is made available in the task, so as to bypass the need for IPC messages for each IO operation.
<damo22>i need it to be mapped from the start of memory so that the flat address still works
<damo22>i suppose i could store the start of it in the "device" and compute the offset when i need to mmap it
<damo22>ie, pci config reports the flat address to the memory range, so i need to mmap that raw block of memory as io
<damo22>but i dont want to expose all of memory to the device
<damo22>i guess i could figure out where the mmio lives and bounds check before mapping it
<youpi>damo22: gnumach already provides this, it's the mem device, see showtrans /dev/mem, it's just a translator for the gnumach mem device
<youpi>that device only supports the device_map operation
<youpi>which libstore can make use of
<youpi>probably the simplest way would be to use libstore
<youpi>to get all the paging stuff implemented
<youpi>Mmm, or maybe it can be simpler without a pager
<youpi>yes, it'd be a mere vm_map call
<youpi>i.e. roughly device_open(master_device, "mem", &dev); device_map(dev, &pager); address = 0; vm_map(&address, pager);
<youpi>and no need for libstore
***dingenskirchen1 is now known as dingenskirchen