IRC channel logs

2024-12-26.log

back to list of logs

<meaty>are we allowed to install "non-free" nonfunctional data as part of a package description?
<meaty>specifically assets for a game with a free-licensed engine
<meaty>or should I just let the user download that themselves
<bdju>good news, figured out why Sway wouldn't start. my old mpv session was still open and taking over the gpu or something. found out with `lsof /dev/dri/card0` and then kill -9'd it. once it was gone, Sway started.
<bdju> https://bbs.archlinux.org/viewtopic.php?id=299209 this helped
<dajole>I'm still stuck trying to set my console font. As far as I understand, I need to use `modify-services` to change `console-font-service-type`. The documentation says "The font can be the name of a font provided by the kbd package or any valid argument to setfont". However, I have not been able to find examples of valid font names. Playing around with `setfont` it seems to not have access to the fonts in the usual way.
<dajole>In other distros, the fonts are in `/usr/share/kbd/consolefonts` of similar.
<dajole>How do I figure out what fonts are available to setfont?
<dajole>Installing fonts with `guix package` doesn't seem to give the format setfont expects.
<iyzsong>dajole: it also accepts absolute path, eg 'setfont /gnu/store/.../*-font-terminus-*/share/consolefonts/ter-132b', with or without the ext. and I have '(file-append font-terminus "/share/consolefonts/ter-132b")' in my system config.
<dajole>Thank you for your reply. Interesting. How do you figure out the correct path in `/gnu/store`?
<iyzsong>'guix build font-terminus' will output paths, the console fonts in 'psf' format are in its 'out'.
<iyzsong>in the system config, you don't specified the path, but will use 'file-append' with 'package' to construct one.
<dajole>That's helpful, thank you. Is there a way to 'preview' what the result of `(file-append font-terminus "foo")` is before running `guix system reconfigure`?
<iyzsong>dajole: yes, run 'setfont' with the absolute path as root in the console.
<dajole>Ah, so how do I figure out the absolute path, given the large number of random hashes in `/gnu/store`?
<meaty>is there a command to find duplicate package definitions?
<dajole>Is there a better way to introspect whether my system configuration is working correctly other than making a change and running `guix system reconfigure` to see whether it worked?
<jakef>dajole: guix system container?
<dajole>Could you please elaborate? I'm looking at the documentation, but I'm unsure how I would use that to test sytem configuration changes.
<dajole>Ideally, I'd like to look at what some of the scheme forms evaluate to in order to debug things.
<jakef>have you seen the section in the cookbook? https://guix.gnu.org/cookbook/en/html_node/Guix-System-Containers.html
<jakef>perhaps you might want to use the guix repl
<dajole>I hadn't seen the cookbook page yet, thanks for pointing that out, I'll give it a read.
<yarl>Hello.
<yarl>issues seems down.
<Googulator>Bisecting the gcc-4.9.4 issue, so far, this is the oldest known broken revision: 9dbaa10aa755f33f8050082bb443d1f9eabf6e21
<Googulator>and the newest one where it builds successfully: 3db653a2c235207b347849200eeb3f89bb4ba513
<Googulator>The commit dates between these only differ by 3 minutes - in between, there are over 200 revisions, most of which are broken in ways that prevent time-machining to them to even try building gcc.
<homo>Googulator hi, considering microhs supports a lot of extensions, do you think it's possible to build some early version of ghc with it? I think the biggest obstacle is speed, mhs is slow and produces slow binaries
<Googulator>I'm not sure - probably not 0.29 or before, since those predate the invention of monads, and use an entirely different IO concept (either streams or continuations, not sure which one), which I highly doubt mhs supports.
<homo>mhs is haskell 2010 compiler and supports more than 40 extensions
<Googulator>If I had to guess, maybe 3.x has the best chance - but even by that point, GHC has not been built with anything other than GHC in several years
<Googulator>0.29 was written in "Haskell 1.2" - a Haskell 2010 compiler will probably balk at it
<homo>mhs even supports GADTs, and they appeared in ghc 6.8.1
<homo>and it is capable of mutually recursive modules
<Googulator>_New_ features it supports are entirely irrelevant - to successfully bootstrap GHC, we would need a compiler that supports sufficiently _old_ Haskell.
<Googulator>Modern GHC will never build with anything other than slightly less modern GHC.
<Googulator>Heck, some versions can't even _rebuild themselves!_
<homo>also considering I want to move to arm or riscv, the only available haskell to me are hugs and mhs...
<Googulator>The problem is that GHC depends on its own quirks - not just extensions
<homo>hm, in that case it is easier to build darcs with mhs than it is to build ghc with mhs?
<Googulator>In fact, GHC's build system lets you specify two different Haskell compilers to bootstrap from, called the "bootstrap HC" and the "bootstrap GHC" - the former is used for files that are meant to be standard Haskell (including documented extensions), the latter for those written in "GHC dialect".
<Googulator>Darcs has a better chance of building with an alternative compiler, yes.
<homo>and let me guess, ghc is such a big elephant that modifications to its build system are going to extend to more than 50000 lines of manually written code
<Googulator>The build system is not itself the problem, it just illustrates the depth of the expectation that GHC will only ever be built with GHC
<homo>well, microhs is the closest thing we have compared to other implementations
<efraim>I just tested and hugs builds fine on aarch64 and armhf
<homo>nice to know that patch I submitted didn't break build on other arches
<Googulator>MicroHs is unlikely to ever replicate GHC's quirks, even if it implements all the relevant extensions.
<homo>at the very least it has potential to make darcs available on arm and riscv
<homo>besides isn't mhs's developer a former ghc developer?
<Googulator>No, he's the former developer of hbc, a different Haskell compiler.
<Googulator>GHC was once bootstrapped from hbc, apparently - but those versions are completely lost
<Googulator>0.24 was the last GHC to ever support building with hbc
<Googulator>0.26 is the first to require GHC 0.24 or newer
<Googulator>and it happens to be also the earliest version whose source code survives
<Googulator>0.25's source code was never released (it was a bugfix release for SPARC only IIRC)
<Googulator>0.24's was. but it's lost today
<homo>from his blog he added some extensions to ghc
<homo>wow, even on archive.org browsing cvs leads to 0.26 as the earliest
<homo>still, that old ghc has no support for arm and riscv
<Guest93>Hi, enabling services can only be done through config.scm and reconfiguring the system, and cannot done by hotloading and unloading linke in other linux distro?
<Guest93>Does guix shell work only with a full guix system or insyalling guix packagemenager ina foriegn distro too?
<csantosb>I'm using guix as foreign with arch linux: shells works as a charm
<Guest93>thank yoou for the confirmation csantosb
<Guest93>same with guix container too? csantosb
<csantosb>Yes, same
<csantosb>I use it all the time
<csantosb>Idem with `guix pack`
<Guest93>awesome, this is so helpful and releaving, thanks a lot again, for confirming this csantosb
<csantosb>You're welcome !
<csantosb>Aside note: foreign is the killer app in guix, in my experience. Users are a `whaterver install guix` away from all things guix.
<Rutherther>Guest93 what do you mean by enabling? You can add services and keep them from starting automatically (though unfortunately not many services expose the attribute to turn them off, but it is still possible, just harder). But if you want to add a new service you typically do need to do that. With newest version of shepherd it is possible to add ad hoc, but there is no 'link' with guix services to that
<Rutherther>Also ad hoc services arent persistent. The initial services shepherd has on boot will still come from your config
<Rutherther>If you are used to something like systemd, there you just add a file to correct folder. This is not the case with shepherd, it gets services in a guile file
<aemogie>hi! im not sure if this is a bug or not, but when overriding guix with `guix-for-channels`, the `guile` repl loses some modules from it's load-path that the regular guix would have. `guix repl` has them though, due to the module-union being added to the load path
<aemogie>currently it's complaining about (git) and (gcrypt hash) when i try to evaluate my <operating-system>, but i assume it's all the transitive dependencies of guix
<Guest93>csantosb, "Aside note: foreign is the killer app in guix" - did  you mean that installing guix in a foriegn distro i the killer function of guix? or is there something i am missing with "foriegn is the killer app". Sorry, not a native english speaker and its hard for me to understand something, if its mentioned in colloqial language.
<aemogie>but arent those packages set as `propogated-inputs`? and `guix-for-channels` inherits from `guix` so those should be inherited as well, right?
<Guest93>Rutherther, that is what i wanted to know, "The initial services shepherd has on boot will still come from your config". SO if it comes from config.scm, then if i add a new service to start at boot through config.scm, then i would have to reconfigure my system for it to take effect right?
<Rutherther>Guest93 right. I am sure there would be ways around it (like loading another file that can come from elsewhere than the config), but the default its like that.
<Guest93>also, what did you mean by "there is no 'link"? @ "With newest version of shepherd it is possible to add ad hoc, but there is no 'link' with guix services to that", Rutherther
<Guest93>Rutherther, understood.
<Rutherther>Guest93: for example: you can add sshd service type and, have default sshd config or change it simply, all in your config.scm. But if you used ad hoc, you cannot use that, you need to do all the configuring yourself, saying what command to execute and parameters etc.
<Guest93>understood. Thank you very much Rutherther
<ngz>Hello. When I try to refresh a package with signed releases, Guix asks to add the key in a keyring, located at ~/.config/guix/upstream/trustedkeys.kbx. However, saving the key fails because the key server returns no data. My keyserver is keys.openpgp.org. What could be the issue ?
<ebrasca>Can you install GuixSD from another distribution?
<ebrasca>I have the package Guix there!
<ebrasca>When I try running the "herd start cow-store /mnt" I get "herd: error: /run/user/1000/shepherd/socket: No such file or directory"
<Rutherther>ebrasca you can. But you will probably need to configure the overlay yourself instead of starting with shepherd like that
<Guest93>ebrasca, yes it is possible, i had the same question yesterday or before, and was told them same, which made sense. You can do the manual installation if i am right (while in another distributionn that has guix installed), allthough i have not tired it yet.
<Guest93>sorry read your second message just now. :D
<ebrasca>Is there a tutorial for this?
<Guest93>As much as i have searched, i couldn't find any. If you do, do share
<ngz>Ah. I needed to change the keyserver. Problem solved.
<attila_lendvai>is vlc in guix feature equivalent wrt codecs compared to upstream releases?
<attila_lendvai>which i guess translates to: is the ffmpeg in guix missing some codecs?
<Rutherther>ebrasca you can look at the cow-service definition in guix repo for the command. I am only at phone so I cant do the same now
<Rutherther>That should be the only thing thats needed to change for foreign distro, since you dont have shepherd with cow-store available, but other stuff is under guix command
<csantosb>Guest93: What I meant is, there are lots of potential users of guix out there, for whom installing guix on top of their current os is simple enough and provides tons of new features they're willing to use inmediatelly.
<csantosb>Compared to this, guix system replaces their current os.
<Guest93>undertood, thanks again csantosb
<rovanion>issues.guix.gnu.org is known to be down?
<yarl>rovanion: It's known to me, but I am nobody :). I mentioned it this morning.
<yarl>here.
<yqshao>ebrasca, I tried to read what cow-store does and it seems to only redirect writes to `/gnu/store` to the `/mnt/tmp/guix-inst`, I am guessing it is only necessary for installation image (when /gnu/store livess in memory); if you are on a foreign system, it should be OK to skip this step?
<yqshao>In any case this is what I think is an approximation: https://paste.debian.net/1341311/
<Rutherther>could also just execute the function directly, as root, ie "echo "((@@ (gnu build install) mount-cow-store) \"/mnt\" \"/tmp/guix-inst\")" | guix repl"
<yqshao_>thats what I tried in the first place and it fails in the last step -- mounting the overlay to /gnu/store with "--move". I noticed /gnu/store is a mount in my Guix SD, but not on a foreign dist, which might be the difference
<Rutherther>yeah, you need to first remove the read-only bind mount
<Rutherther>but you're right it's likely not needed if /gnu/store is not on tmpfs. I initially thought this cow-store is for copying stuff /gnu/store to /mnt/gnu/store, but it doesn't seems to after all
<jeko>Hi Guix !
<jeko>I have set up a guix channel authenticated. two days ago I pushed a new commit, signed with the same key. but guix pull returns "guix pull: erreur : could not authenticate commit ad4cea635090b30d259dcf1cb690f07c831f6a1e: key EFBB 9626 457A C7F6 FAED  FA70 A2E0 F15D BF8E A5F0 is missing"
<jeko>do I have to do something else after git commit -S -m "…" && git push ?
<Guest93>I can install multiple versions of a package and reference or point to them when needed right?
<Rutherther>Guest93: you can use guix shell or refer directly to them, you won't be able to "guix install" multiple versions, that would result in a conflict
<Guest93>Rutherther, ah okay. I thought since the store has a hasjed versions, multiple version can be installed and references can be made based on what is needed. For example, here -> https://guix.gnu.org/manual/devel/en/html_node/Features.html , it talks about "alice installs GCC 4.7.2....bob had already installed GCC 4.8.0.......bob simply continues to
<Guest93>point to /gnu/store/…-gcc-4.8.0/bin/gcc—i.e., both versions of GCC coexist on the same system without any interference. So i thought this could be still done for the same user too.
<Guest93>hashed entries* (not versions*)
<Rutherther>Guest93: I am not denying that. That is talking about two different users, each user has their own profile, so there is no collision when Alice does guix install and Bob does guix install, it's isolated
<Guest93>yes i understand. I wasn't pointing out, i was just saying if diffrent versions existed for multiple users, it could have been nice for different versions for the same user too.
<Rutherther>but what I was saying is that you cannot "guix install" multiple versions as one user. At least not directly, you would need to ensure there is no conflict, ie. make a symlink package that would symlink bin/gcc-4.7 to gcc-4.7 package's bin/gcc (though it might get more complicated with certain packages)
<Guest93>:)
<Guest93>agreed, never messing with symlinks, especially with gcc, etc :D
<Guest93>so for example if i want a specific package for a specific task, like deveoplment or testing of an app or something, i just do that by invoking guix shell?
<homo>yes
<Guest93>thanks homo
<homo>you can setup different guix shells in different terminals for the same user
<Guest93>and thanks Rutherther
<Guest93>yup, got it, aware. :)
<homo>Guest93 you might want to write manifests and use them via "guix shell -m gcc47.scm" in one terminal and "guix shell -m gcc48.scm" in another terminal, and if you develop software in git repos, you can guixify them https://guix.gnu.org/manual/devel/en/html_node/Writing-Manifests.html https://guix.gnu.org/cookbook/en/html_node/Software-Development.html
<homo>one of the things I don't enjoy doing during development is cleaning up mess caused by build system, this is where guixifying entire git repo is handy
<Guest93>that's cool. :)
<Guest93>i don't understand much of it, but i get the gist. I will have to read more and try it on hand to have something make sense to me, some times.
<homo>I am noob in guix myself, so I can tell it's not that difficult
<Guest93>by the way, i was searchingn for having different version in guix and i came up with this, using guix inferior and modify inputs function -> https://unix.stackexchange.com/questions/699148/how-to-use-an-inferior-when-input-rewriting-in-guix
<Guest93>well, that scares me, when you (someone eho has expained quite a bit to me) call yourself a noob, i am just thinking of the state i am in, hehehe
<Guest93>but yeah i have to start somewhere
<Guest93>:P
<Rutherther>you might also be interested in guix time-machine
<Guest93>Rutherther: wow, cool. so many tools to achieve so many related things :)
<Guest93>i though time-machine meant roll back feature, seems this is one more scenario i was thinking
<Guest93>:)
<homo>btw, I wonder is it absolutely necessary to have qt5 when qt6 has compat package? I had enough nightmare building both of them as indirect dependencies of same package
<Guest93>i think everytime i read something about guix system, i go in a rabit hole. I was trying to find a way to have no pulse audio and only pipewire wireplumber, with wayland and kde plasma. so much information strewn around, i just need to compile all that and restructure and use as needed.
<homo>pipewire package depends on pulseaudio package to provide compat layer
<Rutherther>Guest93: having no pulseaudio is tricky as many packages depend on it, and when they do, you have pulseaudio. The easiest is to just configure it to not autostart with client.conf. If you really wanted to get rid of it you would need to rebuild the packages, which would take a lot of time to do, and also build resources as you will have to build it all yourself
<homo> https://debbugs.gnu.org/cgi/bugreport.cgi?bug=75002#11
<homo>here is a patch I sent to split pulseaudio into lib, daemon and utils
<homo>pipewire only needs the lib part to provide compat
<homo>the problem is that even if you install pipewire and wireplumber, they don't start by default and they don't have system service-type that would configure to autostart them for all users, only home service-type is available
<Guest93>yeah i was reading that, ina  reddit post, where a package like pipewire-pulseaudio with the libs are installed to help avoid the clash. I come from gentoo, media-libs/libpulse emulates pulseaudio for pacakges that need them.
<homo>Guest93 I copy a lot of code from other packages in guix, combined with reading manual and cookbook this is how I get 99% stuff done
<rekado>what clash?
<rekado>there is no clash
<homo>pipewire-pulse, pipewire-alsa and pw-jack are part of pipewire package in guix
<rekado>the easiest way is to use the home service for wireplumber. See the Guix manual for documentation.
<Guest93>homo i was reading here -> https://www.reddit.com/r/GUIX/comments/vpvcld/help_replacing_pulseaudio_with_pipewire_at_system/
<rekado>FWIW I don't know any of the Guix contributors who is active on that subreddit.
<Guest93>specifically, this -> https://www.reddit.com/r/GUIX/comments/vpvcld/comment/k4fdph4/ - does that make sense
<homo>rekado home service is not a replacement for system-wide config that autostarts pipewire, pipewire-pulse and wireplumber for all users, this is default I wanted to achieve, but after looking at full dependency graph of pipewire, I gave up on it
<Guest93>Rutherther yes i was reding that (that a lot of packages need pulse audio) , this message i posted earlier was a response to tyou. forgot to tag
<rekado>homo: that's your assertion, but I do not accept it as valid.
<homo>I can't rebuild so many dependencies when I split pulseaudio package into different outputs
<Rutherther>homo: you cannot really do a system-wide config that does that, at least not via shepherd, as shepherd doesn't support all-user functionality, the most it does is to run a service from the system shepherd as specific user, and you probably don't want X services running when user is not logged in. With systemd this is easy as it has user services that are not associated with user
<homo>Rutherther pulseaudio-service-type doesn't autostart pulseaudio either, it is /etc/xdg/autostart/pulseaudio.desktop that might be autostarting it, what if pipewire-service-type simply generates something like that? how do other distros autostart pipewire for all users?
<rekado>In my bash_profile I export LD_LIBRARY_PATH=$HOME/.guix-home/profile/lib/pipewire-0.3/jack/ (to do without pw-jack) and the home service launches wireplumber and tells pulseaudio not to autostart. That's enough so I never have to deal with pulseaudio.
<Rutherther>homo: it doesn't. No /etc/xdg/autostart doesn't start it. What starts pulseaudio is clients
<orahcio>Hi, what is the best way to change icons on pcmanfm, I'm using gdm to login, https://paste.debian.net/1341326, and I insert gnome-shell-assets with the icon-theme and font, or it's better to install these packages on system wide? If I install icon-theme packages with home reconfigure I can not to change icon theme on pcmanfm
<homo>Rutherther then what in other distros autostarts pipewire, pipewire-pulse and wireplumber for all users?
<Rutherther>homo: as for your question how other distros start pipewire, I think I already answered the case for systemd, there it's just a file in /etc/systemd/user/services instead of /etc/systemd/system/services. As for other init/service systems, I don't know
<homo>you mean that enabling user service in systemd make autostart happen for every user that logs in?
<homo>anyway, I don't mind using pulseaudio after trying to build dependencies for pipewire
<Rutherther>yes, if it's enabled in the user's 'system' location (a symlink to the service at "/etc/systemd/user/services/<<target>>.wants/name-of-the-service.service")
<homo>ok, then home config is not that bad, but as I understand making pipewire default instead of pulseaudio would mean simply modifying default template for home config
<homo>and that might be bad for hurd users
<homo>btw, doesn't elogind make it unnecessary to have user in audio and video groups?
<divya>Just sent a little patch for adding `emacs-lucid`, if any committer is free just check if everything builds fine :)
<homo>alright, deleting alsa and pulseaudio from %desktop-services and enabling home pipewire works as expected
<homo>also I removed my user from audio, video and netdev groups, nothing is broken
<Guest93>homo could you share your config, if you can?
<homo>here is my home config, it is simply added home-dbus-service-type and home-pipewire-service-type to the list https://paste.debian.net/1341331/
<Guest93>thank you homo, really appriciate it.
<attila_lendvai>is tsc (typescript compiler) available in a guix channel?
<homo>and in /etc/config.scm replace %desktop-services with (modify-services %desktop-services (delete alsa-service-type) (delete pulseaudio-service-type))
<attila_lendvai>err, wait, i think i just had to run a `node install` to get it fetched.
<homo>Guest93 after that run "guix home reconfigure ~/guix-home-config.scm" and "sudo guix system reconfigure /etc/config.scm"
<Guest93>homo could you just paste bin that part for %desktop-services
<homo>and reboot
<Guest93>sure will do
<Guest93>homo the reason i am asking to paste bin that prticular part, ven though this is striaght forward is beccause i usually tend to mix up somthing (like plascement, brackets, etc) and spend countless hours scratching my head
<Guest93>sorry if that soujded too lazy or stupid :D
<Guest93>anyway thank you for the info. :)
<homo>Guest93 here is an easy way https://paste.debian.net/1341333/
<homo>if you don't have neither ed nor 9, use guix shell plan9port
<the_tubular>Anyone has any idea on how to fix : https://github.com/minad/vertico/discussions/501 ?
<the_tubular>It seems guix and emacs-next specific
<Guest93>homo, so kind of you. Thank you :)
<homo>still, I use guix for just a month, most answers to my questions are in manual, cookbook and source code of guix
<homo>I don't even know guile nor meaning behind its cryptic quotations
<Guest93>yes i agree, most answers are available, some even with a bit more searching, etc. Unfortunately, my main issue is contextual understanding and implimentation. I lack the visualisation with regards to coding.
<Guest93>I take a long time to learn and even more time to implement :)
<homo>there is one concrete problem I cannot find answer for - why building custom kernel from macbook41 example doesn't work https://guix.gnu.org/cookbook/en/devel/html_node/Customizing-the-Kernel.html
<Guest93>its nice to know that you can figure things out quickly and well :)
<homo>every time I put that config into /etc/config.scm just to enable one driver, everything else gets disabled and linux-modules package complains it can't find usb-storage module
<Guest93>i don't know scheme as well. I used to be good at cooding when i was in middle school, and that;s it, never had the opportunty. I did learn python and javascript for some projects but lost trac and cluless now. I am slowly starting to get back into this. One thing i am a bit confortable is linux environment (or general unix to an extent - meaning
<Guest93>bsds)
<homo>most of my pain with guile is keeping () balanced, my eyes don't follow them well while reading code
<homo>I prefer programming in haskell instead
<Guest93>i think we both have the skills the other needs :D
<Guest93>My eyes can folllow, but my brain can't hehehe
<rekado>homo: many of us use paredit to have the editor take care of balancing parens.
<homo>guile is part of gnu identity, I guess this is why this fork of nix remove nix language
<rekado>Guix is not a fork of Nix.
<homo>how is it not a fork?
<homo>also I deliberately avoid languages that require features from text editor to write code
<homo>I program in ed and acme
<rekado>I use M-x butterfly
<efraim> https://xkcd.com/378/
<Guest93>by the way, although i've heard of ed, never used or know much about it. First time here plan9 port and acme.
<homo>when language requires features from editor, programming stops feeling like programming and starts feeling like bureaucracy
<clone>i sent a patch to guix-patches@gnu.org about an hour ago but I don't see it on https://lists.gnu.org/archive/html/guix-patches/2024-12/threads.html . Am I in a spam filter or something?
<homo>be patient
<homo>my first patch took many hours to be listed
<homo>and my second patch also took many hours
<rekado>clone: the mailing lists employ greylisting
<rekado>clone: if it's your first message to the list it will be held up for a while by default.
<clone>thanks
<the_tubular>Any idea for that vertico bug ? is it know here ? Or am I doing something dumb ?
<david96>Hello everyone. Please tell me if there are VPS servers where GUIX is installed by default? Or recommend a VPS
<meaty>Can guix be used as router software
<homo>also another annoyance language might have besides requiring text editor features is requiring it's own package manager like pip, cargo, cabal, stack, npm, etc. instead of trusting to guix, apt, pacman, etc.
<Guest93>meaty, never tried that, but i found this -> https://timmydouglas.com/2021/02/07/guix-router.html today while i was searching for something else. This is regarding guix in home routers, i think
<Guest93>anyway got to go, thanks for all the info, support, help, advise and time. Thank you again very much :) homo Rutherther and everyone esle that helped
<Guest93>bye
<ekaitz>david96: i know this exists: https://guix-hosting.com/ but i don't know if they are good or not
<david96>Thanks for the link, I saw this site when I was looking for an answer on the Internet. As I understand it, this is a private server of an advanced user who offers his services.
<ekaitz>yes i think so
<ekaitz>but it might be a guy that is reselling other infra
<orahcio>Hi
<ekaitz>orahcio: hi
<orahcio>ekaitz: hello, may I ask you about icon themes on Guix?
<ekaitz>orahcio: yes, but can't promise a good answer :)
<homo>it seems there are no "3D" icon themes like in old days :(
<orahcio>ekaitz: No problem, I made some experiments, but I could change the pcmanfm icons just when install icons packages with guix system reconfigure nor with guix home reconfigure
<homo>and good like finding buttons that look like buttons
<orahcio>homo: everything is flat nowdays :(
<ekaitz>i'm not sure about it homo, i've been fighting against them yesterday
<ekaitz>i think the icons are processed after installing them, with some kind of hook
<ekaitz>and apps look for them the freedesktop way
<ekaitz>in freedesktop the fallback icon set is called hicolor
<ekaitz>(for historic reasons)
<orahcio>ekaitz: I need to run `GTK_THEME=another_theme pcmanfm` to change the icon theme
<ekaitz>yes
<ekaitz>that is part of the GTK config probably
<ekaitz>that is not being loated properly
<ekaitz>i had issues with that kind of config in the past too, mostly because of the dark-theme...
<ekaitz>in gtk4 you are supposed to use gsettings for it
<ekaitz> https://wiki.archlinux.org/title/GTK
<homo>can themes be configurable via guix home?
<ekaitz>that i don't know
<orahcio>nice ekaitz, the arch wiki always is helpful
<Franciman>in principle yes, homo
<ekaitz>i have issues with that too, i'm on i3 so it looks like i'm not allowed to change things with gsettings because that doesn't exist in my system and doesn't work really
<Franciman>i don't know if you already have the service for that
<orahcio>homo: emacs for example just need the file ~/.config/gtk-3.0/settings.ini, and the packages can be installed via home reconfigure
<ekaitz>and how do you configure for gtk4?
<Rutherther> https://git.ditigal.xyz/~ruther/guix-exprs/tree/main/item/ruther/home/services/gtk.scm I have made a service for configuring gtk themes, was too lazy to contribute it though
<homo>orahcio .ini file doesn't ensure that the theme you want is installed
<homo>the more you store in .scm files, the easier it is to move configs between machines
<Rutherther>ekaitz: gsettings it just wrapper for dconf, so you can just use dconf directly
<orahcio>homo: that file is just to select the theme, you can list the icon-theme on your packages list of the configuration home scm
<Rutherther>s/it/is
<homo>orahcio and I am asking about selecting theme with guix home, not with .ini file
<ekaitz>Rutherther: but how?
<orahcio> https://f-a.nz/dev/all-in-on-sway/ there are many tips here to configure gtk
<homo>doesn't work with netsurf
<Rutherther>ekaitz: I don't know what you mean by that
<orahcio>homo: I could unsderstand now, I could not see any way to select via home
<Rutherther>ekaitz: if you want the exact steps see the link I sent, and also the accompanying file dconf.scm in the same folder which it uses under the hood
<homo>anyway, only flat themes are packaged in guix :(
<orahcio>In the pcmanfm I could select the icons theme just with GTK_THEME variable, idf the package was installed with system reconfigure
<homo>I don't understand this trend, how comes everyone universally agrees to reject "3D" themes
<orahcio>homo: my vote is with you, I want 3D themes too
<homo>orahcio: I wonder if themes in haiku are appropriately licensed, but to import them to guix someone will have to convert them to formats that gtk, gnome, qt, kde, tk and openbox understand
<homo>add cinnamon, mate and lxqt on top of that
<homo>and xfwm
<homo>and icewm
<ekaitz>homo: freedesktop is the thing all of them are supposed to follow, so the effort would be done only once
<ekaitz>Rutherther: i meant how do i replace gsettings by a dconf call
<homo>ekaitz icons are a piece of cake, but what about widgets? is there a single standard for widgets that all of those mentioned projects obey?
<ekaitz>it's not that obviouse in the link
<homo>I don't recall xdg standard for format of widgets
<ekaitz>homo: that's true, i didn't think about the widgets
<Rutherther>ekaitz: instead of gsettings set you use dconf write, replacing dots with slashes
<olafes>is https://issues.guix.gnu.org/ down?
<ekaitz>Rutherther: oh yeah now it worked!
<Deltafire>olafes: down for me
<ekaitz>Rutherther: also it needed the quotes in the value, that's why it didn't work... thanks!
<homo>haiku's icons seem to be licensed under expat, as there is no separate license file for them
<orahcio>thanks ekaitz, I could see many tips here to make more experiments
<civodul>issues.guix is back (i just restarted it)
<olafes>nice
<homo>there is also gtk theme for haiku, but I don't understand how can someone claim it to be gpl licensed when haiku itself actively rejects gpl
<homo>s/gtk theme for haiku/haiku gtk theme/
<homo>I guess that claim is only for gtk css file
<the_tubular>Anybody is able to run vertico with emacs-next ?
<the_tubular>It crashes my auto completion, the second time I load it
<the_tubular>I found : https://github.com/minad/marginalia/issues/158
<the_tubular>But can't make sense of it
<the_tubular>Added (require 'compat) to my config, and no changes
<the_tubular>Any idea ?
<stochastic>Is it possible to start a guix shell in guile, or smarter to just use `system*` ?
<clone>the_tubular: how did you install emacs-next and vertico? and how are you launching emacs?
<the_tubular>Not too sure I understand your question, I installed both using guix system reconfigure and passing them in my packages list
<the_tubular>my command to launch emacs is emacs --debug-init for now
<Googulator>Any idea why Gash / Gash-utils is so sensitive to memory bandwidth? I've hit a revision in my bisect of the gcc-4.9.4 failure that ended up rerunning the whole bootstrap, and I see a *massive* performance difference between my 2 systems on this task
<Googulator>Even though it's only using one core, so it's not exploiting the higher core count on my AMD system
<Googulator>For other single-threaded loads in Guix, I measured a roughly 2x difference in performance - however, on the Gash part of the bootstrap, the speedup is about 7-8 fold on the newer AMD machine
<the_tubular>Should I pass them in a manifest, does that matter clone ?
<Googulator>Which happens to coincide with the memory bandwidth difference (DDR2 vs DDR5)
<clone>the_tubular: maybe it's something about having emacs be in system, i've never done that so I don't know. But this works for me to use vertico with no errors: guix package -p /tmp/emacs -i emacs-next emacs-vertico --with-input=emacs-minimal=emacs-next-minimal --with-input=emacs=emacs-next; GUIX_PROFILE=/tmp/emacs; . GUIX_PROFILE; emacs;
<the_tubular>It might crash, as there is a font that I can't compiled and crashes on some guix command
<the_tubular>Mind explaining a bit what your command does ?
<the_tubular>Specifically this part : GUIX_PROFILE=/tmp/emacs; . GUIX_PROFILE; emacs;
<the_tubular>Also the --with-input aren't suppose to be in the package definition itself ?
<clone>well for one it's meant to be . $GUIX_PROFILE/etc/profile, i failed at copying it. it sources the profile
<clone>package transformations can either be in the package definition or as command line args https://guix.gnu.org/manual/en/html_node/Package-Transformation-Options.html