IRC channel logs

2024-10-14.log

back to list of logs

<krascovict>Guest85, deu certo?
<Guest85>então, eu adicionei, só que agora aparece aquele problema que comentei
<Guest85>In procedure length: Wrong type argument in position 1: delete
<Guest85>como se o campo que eu estou deletando alguns serviços, estivesse errado
<krascovict>mostra a primeira linha no arquivo ~/.config/guix/guix-system-bak.scm
<krascovict>nesse esta dando erro de procedural
<Guest85>meu arquivo começa assim:
<Guest85>;; Indicate which modules to import to access the variables
<Guest85>;; used in this configuration.
<Guest85>(use-modules (gnu)
<Guest85>             (guix)
<Guest85>             (gnu system nss)
<Guest85>             (gnu system pam)
<krascovict>(use-modules (gnu))
<krascovict>(use-service-modules cups desktop networking ssh xorg
<krascovict>no meu caso
<krascovict>(use-modules (gnu))
<krascovict>(use-service-modules cups desktop networking ssh xorg)
<krascovict>pode te ajudar
<krascovict>ta usanod Gnome Guest85?
<Guest85>esses modulos já estão na config. E comecei usando o gnome, mas agora to usando o awesomewm
<krascovict>(use-modules (gnu))
<krascovict>tenta colocar os ")"
<krascovict>pra usar o GUIX tem que aprender sobre Scheme
<Guest85>tu diz algo assim:
<Guest85>(use-modules (gnu))
<Guest85>(use-modules (guix))
<Guest85>...?
<krascovict>só na primeira linha
<Guest85>é uma das metas estudar Scheme msm
<Guest85>mas aí os outros módulos vão ser carregados?
<krascovict>aí um exemplo
<krascovict> https://git.savannah.gnu.org/cgit/guix.git/tree/gnu/packages/package-management.scm#n183
<krascovict>sobre a página
<krascovict>(service openssh-service-type
<krascovict> (openssh-configuration
<krascovict> (authorized-keys
<krascovict> (list (local-file "/caminho/para/sua-chave.pub")))))
<krascovict>via chatGPT
<krascovict>Scheme é tenso
<krascovict>to aprendendo ainda
<Guest85>ta complicado ahaaha
<weary-traveler>um. please use paste sites
<acrow`>Of course it will be me -- but (modify-services %desktop-services (delete screen-saver-service-type) triggers screen-saver-service-type 'undefined'. I also tried the (remove pred lst) syntax and got the same outcome. I added (gnu service xorg) to my modules, bc that seems to be where screen-locker-service-type is defined, but again it's not passing muster. I see in the code that it seems to be (define screen-locker-service-type ...);
<acrow`>I expected to see a define-record-type for this... What am I missing?
<clarkf>seems to be defined in (gnu services xorg), not service, as far as i can tell
<acrow`>clarkf: yes! How can I select and remove these from %desktop-services?
<acrow`>clarkf: I don't see any corresponding record selectors but screen-locker-service-name is exported. Maybe (eq? (screen-locker-service-name svc) 'screen-locker) would be the ticket...?
<acrow`>clarkf: Of course, I'd have to already know it's a screen-locker-service-type to apply that function without erroring things; so that isn't going to do it.
<clarkf>i meant, specifically, that i think it should be "(use-modules (gnu services xorg))" rather than "(use-modules (gnu service xorg))"
<clarkf>services being plural
<acrow`>clarkf: my irc goof... the code used was correct.
<acrow`>I'm looking at the mechanics inside services.scm...
<clarkf>gotcha. the one thing i'm noticing is that some portion of the screen locker code was marked deprecated, though i don't see any info about it
<clarkf>i don't think that's it, actually. i'm not sure, as far as i can tell, your config should work
<acrow`>clarkf: Yeah!, but there is always something I've missed...... no progress but by changing things again to see if I can see my error.
<acrow`>clarkf: It's running --- I failed to add (srfi srfi-1). It seems.
<peanuts>"SRFI 1: List Library" https://srfi.schemers.org/srfi-1/srfi-1.html
<clarkf>weird. must be for the "(remove pred lst)" syntax?
<acrow`>clarkf: yeah, I'm curious if I should put back (modify-services %desktop-services (delete screen-lock-service-type)) to see if srfi-1 allows it to work. I bet it does.
<peanuts>"SRFI 1: List Library" https://srfi.schemers.org/srfi-1/srfi-1.html
<krascovict>Olá, as traduções que estou fazendo do GUIX vão aparecer na próxima atualização?
<krascovict> https://translate.fedoraproject.org
<krascovict>Hello, will the translations I'm doing for GUIX appear in the next update?
<krascovict> https://translate.fedoraproject.org
<krascovict>already translated around 10% of English into Portuguese
<Guest85>hey guys
<Guest85>i've reported some needed help earlier, and krascovict was helping me out. We spent a few hours trying to fix it, but now i got some new problems hahaha. I'm getting this error: guix system: error: service "term-console" provided more than once
<Guest85>the problem is, that apparently, some service is providing this item. However, this is not the first item that appeared. It is stuck on a loop, indicating that something is being declared more than once, and when i delete the associated service with that item and run guix system reconfigure again, it returns the same error but with some new item
<Guest85>that is supposedly duplicated
<rodrigo-morales>Guest85: could you share your entire configuration file in a pastebin? I believe doing so will provide more information to those willing to help you.
<Guest85>yes sir
<Guest85>one sec
<Guest85> https://privatebin.net/?51308e45299fe5eb#Awh7XoWAmPW6iWtrhq9V1EzqSNhtRQZdAfDxcG5ZaSD1
<Guest85>here it is
<Guest85>i've been deleting services like crazy hahaha. but everytime a new "duplicate" entry gets spilled out as an error
<krascovict>rodrigo-morales...
<krascovict>1k lines translated inglês to Portugueses Brazilian
<Guest85>nice!
<krascovict>good night
<Rutherther>acrow`: just tried (modify-services %desktop-services (delete screen-locker-service-type)), works for me, I see also in extension-graph output the services are removed
<sepeth>Hi Guix ^-^ when I pull the guix git repo, it can't auth this commit: https://git.savannah.gnu.org/cgit/guix.git/commit/?id=e4f5eb6c01727ef143e533019e74830e00d6f5d2 - anyone else getting the same? Is there something I need to do?
<sepeth>This is the exact error: guix git: error: could not authenticate commit e4f5eb6c01727ef143e533019e74830e00d6f5d2: key 01FD 85F4 1A7B 7F82 0583 06A5 935E BE07 36DC 857E is missing
<peanuts>"gnu: Add bin-graph. - guix.git - GNU Guix and GNU Guix System" https://git.savannah.gnu.org/cgit/guix.git/commit/?id=e4f5eb6c01727ef143e533019e74830e00d6f5d2
<ds-ac>sepeth: I had the same thing. I had to update my keyring branch first (which I had not done in a while). `guix git authenticate' worked afterwards.
<sepeth>Thanks ds-ac, that worked ^-^
<sepeth>On this note, is it a good idea to set an upstream branch? Just thinking outloud, that would probably break the point of guix git authenticate, git pull would also fetch keyring branch from potentially compromised origin. If this is right, how do you update your keyring branch?
<Rutherther>sepeth: You could verify keyring commits against previous keys, no?
<attila_lendvai>if i git pull now, i get: "guix git: error: unknown introductory commit and signer"
<sepeth>Rutherther: Oh right, the post-merge hook would still run guix git authenticate.
<attila_lendvai>Rutherther, thanks for your work on the arm gcc toolchain!
<nckhexen>Subject: Rigid Boxes Custom packaging
<nckhexen>We are clearly on a packaging list. Sigh.
<nckhexen>sneek: later tell sepeth: The commit adding an attackers key to a compromised upstream must still be signed by a previously-trusted key, or authentication will loudly stop. Guix doesn't have two upstreams either.
<sneek>Will do.
<nckhexen>sneek: later tell sepeth: The point of authentication was to remove trust in the git host altogether (in a TOFU fashion, anyway), not to simply double the number of hosts that need to be compromised.
<sneek>Got it.
<mrvdb>hi guix, i am trying to set up git signing/ guix authentication on my local repository. I sign with gpg subkey, which may be problematic for guix? (cfr. https://issues.guix.gnu.org/57091) Is there a best practices doc somewhere? The manual does not seem to cover this. It's also a bit unclear on the keyring branch practice.
<attila_lendvai>mrvdb, i think i'm also using a subkey, and it works. you need to add your subkey to the keyring, not your main key.
<attila_lendvai>mrvdb, what i do is add my key to the keyring branch, then add it to .guix-authorizations, and use that commit as the introductory commit when i refer to my channel
<attila_lendvai>the introductory commit is trusted unconditionally, so make sure to add one more commit to test your setup. otherwise you may forget the whole thing, and be baffled by the second commit being rejected (details are in https://issues.guix.gnu.org/50814)
<mrvdb>attila_lendvai thanks
<sepeth>Thank you nckhexen ^-^ just saw your messages, that makes sense.
<sneek>sepeth, you have 2 messages!
<sneek>sepeth, nckhexen says: The commit adding an attackers key to a compromised upstream must still be signed by a previously-trusted key, or authentication will loudly stop. Guix doesn't have two upstreams either.
<sneek>sepeth, nckhexen says: The point of authentication was to remove trust in the git host altogether (in a TOFU fashion, anyway), not to simply double the number of hosts that need to be compromised.
<krascovict>Does anyone approve GUIX translations? https://translate.fedoraproject.org
<Marco20>Hello there! I have an issue with guix when using --emulate-fhs and installing both gcc-toolchain and clang-toolchain:
<Marco20>guix shell: error: symlink: File exists: "/bin/cc"
<Marco20>Can someone help me?
<apteryx>do you really need both in the same profile?
<Marco20>yes :(
<Rutherther>what for? probably could be overcame by making a different package that will symlink to the original one and remove that one file
<Marco20>the root issue is with llvm pachage:
<Marco20>gnu/packages/llvm.scm:
<Marco20>                     (symlink "clang" (string-append out "/bin/cc"))
<Marco20>                     (symlink "clang++" (string-append out "/bin/c++"))
<Marco20>Rutherther apteryx yes i really need both of them.
<Marco20>can someone help me to patch my manifest.scm to use a patched version of llvm?
<Marco20>diff --git a/gnu/packages/llvm.scm b/gnu/packages/llvm.scm
<Marco20>index 9f851a478e..874864bc81 100644
<Marco20>--- a/gnu/packages/llvm.scm
<Marco20>+++ b/gnu/packages/llvm.scm
<Marco20>@@ -509,12 +509,6 @@ (define-public (make-clang-toolchain clang libomp)
<Marco20>                        (((names . directories) ...)
<Marco20>                         (union-build out directories)))
<Marco20>(use-modules (gnu packages)
<Marco20>             (gnu packages autotools)
<Marco20>             ((gnu packages bash) #:select (bash-minimal))
<Marco20>             (gnu packages bison)
<Marco20>             ((gnu packages certs) #:select (nss-certs))
<Marco20>             ((gnu packages cmake) #:select (cmake-minimal))
<Marco20>             (gnu packages commencement)
<Marco20>any help?
<ulfvonbelow>do you want to replace the llvm in your profile or recursively replace all instances of that llvm in the entire dependency graph of your profile?
<lockbox____>Marco20 Also fysa using something like https://paste.debian.net for code next time makes it much easier to read
<Rutherther>infinitely easier since now it's not readable at all, because some lines were removed :)
<lockbox____> Marco20 If you just want a temp solution you could just change that one line you pointed out, but ulfvonbelow's question will help you towards a better long term solution
<skrech>Can I send Patches to already opened bug in debbugs? Or I have to create new issue by sending to guix-patches@gnu.org?
<acrow`>Rutherther: Thanks for the check on modify-services .. delete. It was just a matter of realizing I needed to use srfi-1, duh..
<peanuts>"SRFI 1: List Library" https://srfi.schemers.org/srfi-1/srfi-1.html
<nckhexen>krascovict: The translations are periodically pulled into Guix, so your changes won't be immediately available, but AFAIK there's nobody on our side proactively reviewing them.
<nckhexen>I'm not aware of any abuse of that trust so far :-)
<nckhexen>Translating hundreds of lines is a pretty tedious price to pay to sneak in a fart joke. And the project would still come out ahead.
<wehlutyk>z572: I just saw the update for https://issues.guix.gnu.org/73630
<nckhexen>skrech: You can use '--to=12345@debbugs.gnu.org' just fine, but please increment the 'reroll count' (e.g., '-v2') each time.
<peanuts>"24.2.50; doc string of `text-scale-adjust'" https://issues.guix.gnu.org/12345
<wehlutyk>z572: I got gexp and removed the #t, but what's to be pushed?
<nckhexen>skrech: Opening a new bug is a great way to get missed, not attention, so don't do that.
<z572>wehlutyk: i push this patch, and made these changes, see https://git.savannah.gnu.org/cgit/guix.git/commit/?id=9460c7ed8a9314dbfe1b34bf840b65063bdca8c9
<sneek>Welcome back z572, you have 1 message!
<sneek>z572, podiki says: do you know the fix for qtwayland@5 as well?
<wehlutyk>z572: aha, thanks!
<skrech>nckhexen: Thanks, I'll submit the patch in the already opened thread. I don't need to use reroll in my first submittion, corrent?
<skrech>nckhexen: The currently opened bug doesn't have patches submitted so far.
<krascovict>nckhexen, How do I review translations within Savannah?
<krascovict>yesterday translated more than 1.2k lines to Brazilian Portuguese
<nckhexen>skrech: No -v1 needed, correct.
<Rutherther>when I make a single patch and want to add a comment to the issue, not to the commit body, should I make a cover letter or is there better way?
<nckhexen>Add your free-form Hiya peeps so here's a patch that'll frob your knob off messages for humans after the '---' in the generated patch, under the commit message. It's ignored.
<nckhexen>krascovict: Uhm, I'm not sure what you mean by 'review translations on Savannah', but the imported messages are at <https://git.savannah.gnu.org/cgit/guix.git/tree/po>. They are updated about once a month: <https://git.savannah.gnu.org/cgit/guix.git/log/po> but it's not automated.
<nckhexen>They frow from Weblate to Guix.git, not the other way 'round.
<nckhexen>krascovict: And thank you, again. I've never managed more than a few hundred lines without burning out for the week^Wmonth.
<krascovict>nckhexen, you have to have focus and motivation
<krascovict> https://translate.fedoraproject.org/
<krascovict>I am using the Fedora translation service
<krascovict>recommended to me
<nckhexen>That's what I meant by Weblate.
<nckhexen><focus and motivation> Ah. Oh dear. That'll be the problem :-)
<krascovict>all right
<krascovict>in the website translation it is ok, 100%
<krascovict>I'm not sure if I can translate the functions in parentheses
<krascovict>example: (@pxref{Derivations}).
<nckhexen>No, leave @pxref exactly as they are. Same for @ref and @xref.
<krascovict>ok... nckhexen thanks
<nckhexen>The name of these 'nodes' is translated separately, so the users sees them in their language, but the links themselves will break if you translate them.
<nckhexen>Good question.
<nckhexen>I think this is documented, but I have no idea where in the Weblate interface.
<krascovict>nckhexen, https://share.riseup.net/#rP80ZrJzxFhTc3_mc_IBFg
<krascovict>exemple
<krascovict>Fetching source code from the @uref{https://archive.softwareheritage.org,Software Heritage archive}.
<krascovict>Obtendo código-fonte do @uref{https://archive.softwareheritage.org, arquivo de programa Hereditário}.
<krascovict>exemple
<krascovict>when it involves flags it does not translate
<nckhexen>@urefs are fine to translate.
<krascovict>of this type "(@pxref{Search Paths})."?
<krascovict>Implementando caminhos de pesquisa (@pxref{Caminhos de pesquisa}).
<krascovict>Implementing search paths (@pxref{Search Paths}).
<nckhexen>Only @ref, @xref, and @pxref are special, because their content is actually the 'address' of an internal link, which will break if you translate it. @urefs separate the 'address' (URL) and label, so there's no problem.
<krascovict>just the labels, I understand
<nckhexen>You *could* 'translate' the URL, i.e. link to the Portugese version of a Web page instead of English. I don't actually know what the bestest practice is. I assume that's fine.
<nckhexen>But that's different from @{,x,px}ref and I'm drifting.
<nckhexen>ACTION drifts away, bye.
<krascovict>I understand... in the future the JUDGE can make a 100% Portuguese version available, then I will review and retranslate it
<krascovict>nckhexen, thanks for all
<wehlutyk>z572: so, back to testing guile-cv, I'm just trying out (im-load ...) as documented https://web.archive.org/web/20220311045337/http://www.gnu.org/software/guile-cv/manual/html_node/Features.html (gnu.org was down last I checked)
<wehlutyk>in a "guix shell guile guile-cv", running (im-load "bla-bla-bla.png") fails with "Not a GRAY, RGB nor an RGBA image"
<gabber>sounds like a guile error (or guile-cv) - you may want to ask in #guile
<wehlutyk>which was discussed in the guile-user list https://lists.gnu.org/archive/html/guile-user/2017-12/msg00020.html
<wehlutyk>gabber: thanks -- I'll ask there too -- just starting here as given the guile-user list it might be a "access to vigra" problem
<wehlutyk>(for which the answer will be different under guix)
<gabber>i see. i have no idea about any of this or whatever guile-cv does or vigra is. but you might want to add vigra (or whatever provides it) to the guix shell
<wehlutyk>gabber: oops, I'll check my mistake as it seems to load a simple png
<gabber>this may be a bug (or an incenvenience) in the guile-cv package - no need for shame (:
<roptat>hi guix!
<sneek>Welcome back roptat, you have 1 message!
<sneek>roptat, apteryx says: is lieserl supposed ot be reachable via 10.0.0.14? it's not
<gabber>hi!
<roptat>not sure when this message was sent, but I'll have a look at the console. Lieserl is still running in my living room, it would be a shame if it wasn't building substitutes
<roptat>there have been students who helped me with the LFS translation for a few years now (in their last year of master, so it's always been different people each year). They do "voluntary" translations (using quotes because I think it's part of their cursus, although I never had to grade them) and they finally finished revising French LFS and BLFS last year
<roptat>since they contacted me again, I suggested they could work on Guix translation :)
<roptat>(it's a master in translation, not CS, they will probably do technical translation as their job after graduating)
<roptat>they have never tried using weblate before, they prefer to interact with someone, so I could send them a file to translate, and then integrate their translations back, but I'm not sure how best to credit their work
<roptat>if I just send the translation to weblate I'll get all the credit :/
<roptat>this also made me think, we have a copyright section with the authors of the English manual, but the translators are never visible
<roptat>also one more question, I'm trying to update josm, but guix fails to download the repository with SVN, saying the certificate is expired, which is not the case (valid between September and December 2024)
<roptat>any idea how to solve this? I used the same command successfully to get the repository, and I forgot the command to get it in the store
<gabber>roptat: is the clock on the machine you are working showing the right time?
<krascovict>more 2k lines tralsated to PTBR
<roptat>yes, outside a guix build, the same command works
<theesm1>hi guix, is there a better/existing other way to generate (json,plaintext,ini etc.) config files for services from s-exp than doing something like this in your config.scm? https://paste.debian.net/hidden/43a37b84/
<roptat>theesm1, you could use plain-file
<roptat>but otherwise, this looks fine
<roptat>oh, (symbol->string 'content) always evaluates to "content"
<roptat>and define should be enough, instead of define-syntax-rule
<roptat>ah nevermind
<roptat>the syntax is more clever than I expected :p
<theesm1>roptat: thx for the feedback on this, what advantage would plain-file have over computed-file?
<roptat>plain-file just takes a string instead of a gexp, so it's simpler
<roptat>although, you could pass a gexp, but you'll have trouble getting (json) inside it
<roptat>if you want to use computed-file, you could simplify it with (plain-file name #$~(with-output-to-file #$output (lambda _ #$content-string))) I think
<roptat>err, (computed-file name #$~(with-output-to-file #$output (lambda _ #$content-string)))
<theesm1>that's much more terse than my approach, i'll try that
<roptat>(computed-file name #$~(with-output-to-file #$output (lambda _ (format #t #$content-string))))
<roptat>I might be tired...
<roptat>or simply (plain-file name content-string) :p
<theesm1>went along with the latter plain-file approach, thx a lot
<roptat>I suppose this means you can't ungexp a store path in these files, if that matters
<silicius_>I was thinking of writing a dyndns service (mcron job) for my system config, but that would mean writing secrects into the store. Can't think of a better way
<roptat>like a config file that would say where to find tool foo, without you having to install foo in the profile explicitely
<roptat>the store is world-readable, not a good idea :/
<roptat>usually the solution is to have an out-of-band file (say /etc/dyndns-secrets) and use the service's configuration syntax to include it
<silicius_>oh yeah, that's a good idea.
<theesm1>roptat: ungexping store paths could be useful in some scenarios; but for now i don't have any configs where that's necessary (e.g. where i would need paths to other store items)
<silicius_>though, under what user are mcron job run under by default? I'd guess root
<nckhexen>Yes.
<silicius_>theesml: I think it's useful for public keys and similar. At least my home and system config reference them like that
<roptat>ah, untested but maybe (with-imported-modules ((json)) #~(begin (use-modules (json)) (with-imported-modules ...))) would work as a gexp to pass in make-my-config-file
<civodul>should be (with-extensions (list guile-json) …) i think
<roptat>(with-imported-modules ((json)) #~(begin (use-modules (json)) (scm->json-string ...)))
<civodul>because ‘guile-json’ is the package that provides json.scm
<roptat>oh
<roptat>I never used with-extensions before
<roptat>(nor with-imported-modules, I just found it first in the manual :p)
<civodul>(BTW, salut roptat! :-))
<theesm1>am considering keeping the scm->json-part outside of the function though, so i could reuse it with sxml->xml and possibly scm->other-possible-config-formats as well
<roptat>yes, you could do (define daemon.json (with-extension …)) and pass that to your make-my-config-file (if it still uses computed-file)
<theesm1>i think i'll toy around with that a bit
<roptat>I don't think you can do without with-extension though, since scm->json would execute inside the gexp
<roptat>maybe with a macro
<theesm1>i like that guile-json works the other way around as well (json-string->scm), converting some of my existing configs to s-exp with cat someconfig.json | guile -c '(use-modules (json) (ice-9 rdelim) (ice-9 pretty-print)) (pretty-print (json-string->scm (read-string)))' for use in config.scm with this approach
<luca>Hi, did the disarchive.guix.gnu.org cert expire? Or is there something on my end
<PotentialUser47>is there a reason this: (packages->manifest (list "awscli@2.2.0”)) doesn't work in a manifest file? I get this error In procedure struct-vtable: Wrong type argument in position 1 (expecting struct): "awscli@2.2.0"
<roptat>I think it takes a list of packages, not a list of strings
<roptat>you might want specifications->manifest instead
<gabber>is there an example of how to configure nginx to rewrite/redirect requests to https if they arrive on port 80?
<gabber>i figured it out (:
<krascovict>I have already translated the website section and GUIX section, but out of 1.5k lines translated to PTBR
<x8dcc>Something I thought was funny: https://bpa.st/A5SQ
<x8dcc>By the way, do I need to add `~/.guix-profile/share/fonts` to some environment variable? fc-list doesn't seem to detect it
<x8dcc>(`ln -s /home/username/.guix-profile/share/fonts/ /usr/local/share/fonts/guix-fonts` seemed to work)