IRC channel logs

2024-09-22.log

back to list of logs

<jamincollins>futurile: from that write up they were able to get it to boot to the installer, this is loop backtracing before that point. I'll try one of the latest images
<galois`>I updated my packages (and glibc) and now I get the following when running gcc: guile: warning: failed to install locale. Does anybody have an idea what this is?
<galois`>There is an issue but it didn't help: https://issues.guix.gnu.org/41603
<jamincollins>well, the latest image at least gets to an ncurses display and shows the backtrace
<jamincollins> https://asgardsrealm.net/tmp/2024-09-21_16-16.png https://asgardsrealm.net/tmp/2024-09-21_16-17.png https://asgardsrealm.net/tmp/2024-09-21_16-17_1.png
<futurile>jamincollins: sorry, I don't know what the backtrace is trying to tell you. I would try the nonguix install image next in case it's some driver thing.
<futurile>Q: anyone know the magic incantation to add a header to git send-email ? I'm trying --add-header="X-Debbugs-cc=blah" but it will not add it
<PuercoPop>h4: I've had success using the rustup channel https://toys.whereis.みんな/channels?search=rustup at least for development. For packaging I used the import functionality to package the missing crates.
<PuercoPop>If I want to define an enum in a service configuration, does guix provides a specialized construction or should I just look at how to do defin enums in guile?
<futurile>h4, PuercoPop: someone mentioned this project yesterday - https://git.sr.ht/~look/cargo2guix/tree/main/item/README.md
<jamincollins>well, the noguix installer got me farther, seems the wifi is a non-starter on the unit... so will have to wire it up but at least I have a path forward now
<PuercoPop>What is the iterative development story for configuration/services? How do I test/check the result of a configuration before adding it to my configuration? For package I do guix build -L . $package-name or the equivalent on the REPL
<PuercoPop>where are configuration helpers like serialize-string defined? I was expecting them to be in (guix serialization) but that is not the case
<PuercoPop>hmm I see several (define (serialize-string field value) ...) cross different service modules in the guix tree. I guess that means I should define my own then
<char>Hello guix, can anyone run blender 3.6.13? I get an immediate segmentation fault with no elaboration. I tried to update the guix package, but I am getting a cmake error related to FFTW3_LIBRARY_F not being set (I do not know what it should be set to).
<PuercoPop>char: FFTW3 probably refers to fftwf in (gnu packages algebra)
<erin93>Hello, I was just wondering if I had done something wrong. I have emacs installed in my guix system configuration and emacs-geiser installed in my guix home configuration but noticed that .guix-home/profile/share/emacs/site-lisp doesn't seem to be being added to EMACSLOADPATH, so I am unable to load geiser without adding it manually. Is this expected, or have I gone wrong somewhere?
<char>PuercoPop: I think so too. It is already an input to blender, but it the environment variable is not set.
<erin93>Would it be better to install emacs and all emacs packages either in system or home configuration rather than splitting between both?
<apteryx>PuercoPop: there are some basic set of serializers pre-defined in (gnu services configuration)
<PuercoPop>I used serialize-configuration, from (gnu services configuration) to get a gexp object. How I print it, inspect it?
<apteryx>You can build it; ',build object' at tE REPL may work I think
<apteryx>in the past I was doing (build-derivations store (list (lower-object $gexp))) or something like that
<apteryx>,build comes from (guix)
<apteryx>so ,use (guix) at the REPL first
<PuercoPop>apteryx: it says input error (and for some reason using ,build x pulled a new guile?)
<PuercoPop>This is the 'gexp object' $13 = #<gexp gnu/services/configuration.scm:163:2 7fede837a8d0>
<apteryx>I guess ,build is just for package then
<apteryx>You'll have to use the more general though verbose build-derivations
<apteryx>the store args it wants can be obtained using (open-connection), which opens a connection to the store monad
<apteryx>s/monad//
<apteryx>gexp->approximate-sexp may be useful to inspect its content too
<PuercoPop>This is the configuration I have so far, it is supposed to serialized to a TOML file https://git.sr.ht/~puercopop/glue/tree/default/item/glue/services/atuin.scm
<PuercoPop>Btw is there something similar to ,build but for services? Because when trying to package something new I normally use ,build on the package ot inspect it. This is the first time I'm trying to write a service
<apteryx>for services, no, you could have a basic os definition using it, and write a system test for it
<apteryx>see under gnu/system/tests/ for examples
<apteryx>we don't yet have a policy but services with system tests are usually easier to review since they give us better confidence that it works
<apteryx>so it theory should be accepted faster
<PuercoPop>This would be more a home service thing. Although it wouldn't be up for submission until the atuin issue moves forward. I'm using binary releases to get it work it in guix
<apteryx>OK. We don't have home services test yes (!). We should sit down and think of a way to do that.
<ngraves>Hi Guix ! How can I recover from "Throw to key `sqlite-error' with args `(sqlite-exec 8 "attempt to write a readonly database")'." when using guix gc ? I haven't touched at anything manually and it seems I've broken my database.
<Rutherther>bigbookofbug: hi, you still around? if I am looking correctly no one answered your question from yesterday. To add to your system profile bin folder, you just add a package that has a file in bin to the system profile. To do that, you can either just put it to packages list in operating-system, or make a service that will extend profile-service-type. If that service would do only that, probably better to just put it to packages. extra special files...
<Rutherther>... won't work, you cannot and shouldn't write that way to gnu store, which is what is symlinked at that location.
<nutcase>Hi guix. Has anyone configured seatd as replacement for elogind and can point me to some example?
<Franciman>+1 nutcase
<PotentialUser-17>Can I disable to missing free firmware warning that comes on startup?
<h4>>> How to do Rust coding in Guix? It seems that many crates are available on Guix repository, so how to use these and avoid internal Cargo downloading these himself and so?\n> h4: Create a container with all the Rust crates you need or run guix shell..\ngalois`: I mean, you did your code and you want to compile. How do you use https://packages.guix.gnu.org/search/?query=rust instead of downloading throu
<h4>gh `cargo`?
<h4>galois`
<h4>>> h4: I've had success using the rustup channel https://toys.whereis.みんな/channels?search=rustup at least for development. For packaging I used the import functionality to package the missing crates. If I want to define an enum in a service configuration, does guix provides a specialized construction or should I just look at how to do defin enums in guile?\n> h4, PuercoPop: someone mentioned this projec
<h4>t yesterday - https://git.sr.ht/~look/cargo2guix/tree/main/item/README.md\nPuercoPop, futurile: Why you need a channel instead of https://packages.guix.gnu.org/search/?query=rust? So you haven't made new Guix packages for missing crates? If that project make automatically Guix packages for crate that's neat. Maybe a script should be made to retreive Rust crates sorted by popularity and generating packag
<h4>es for them in that order and submit to Guix repository. That would made those things available without much hassle
<h4>futurile
<h4>PuercoPop
<Rutherther>I noticed "%user-log-dir" at couple of places in guix, but I cannot find its definition. What dir is it supposed to point to? Seems that mcron is supposed to log to mcron.log inside of it, but I can't seem to find the log file
<necto>Hello!
<necto>How long is the typical moderation delay if I send a reply to a guix issue like this one: https://issues.guix.gnu.org/50883
<necto>from a yet-unknown e-mail?
<noneofyourbusine>o/ would a translation to C89 of the nix/ C++ source files in guix.git be a welcome change?
<noneofyourbusine>typical reasons of dropping C++ apply, including a simpler compiler
<noneofyourbusine>link related https://250bpm.com/blog:4
<Rutherther>necto: it should be quite fast even for unknown e-mails, unless you get to manual moderation queue. Like 5 - 15 minutes. But for example, I had some trouble with it and my e-mails were not arriving for hours. One of the maintainers tried to check it, but it hasn't even arrived in the manual review queue, so there was not much to do... After like a week or so, it was fine.
<necto>Thank you, Rutherther
<necto>May I ask someone check if it has arrived to the manual review queue? It's been 1h since I've sent it
<necto>It is sent to 50883@debbugs.gnu.org with the subject "Suckless packages marked as 'x11' instead of 'expat'" as the issue topic
<peanuts>"Suckless packages marked as 'x11' instead of 'expat'" https://issues.guix.gnu.org/50883
<nckx>noneofyourbusine: The daemon isn't actively maintained, and basically touched only when there's a (security) bug. Otherwise it's 'done'. Which is fine for stability. For maintainability, we've always wanted a rewrite in Guile, but despite hard work by several people this still hasn't happened yet.
<nckx>Depending on C++ isn't considered an issue since GCC already does and we bootstrap to C++ anyway.
<nckx>necto: Nothing in the bug- or -patches queues.
<noneofyourbusine>nckx: fascinating. I feel like going from C++20(?) to C89 would be easier than jumping to scheme+extensions
<sham1>Really? Why do you think that
<nckx>(Extensions?)
<necto>thanks for checking nckx
<sham1>Extensions is probably the way Guile has extended the Scheme language in things like ice-9 and such
<sham1>So basically implementation-specific libraries and the like
<noneofyourbusine>sham1: as long as you keep your translation to C89 compatible with the subset of C++ it uses, you can keep it in the same source file, translating piece by piece
<nckx>Oh, okay. The daemon wouldn't need anything weird though. You could implement it in standard Scheme (however you interpret that) quite easily.
<noneofyourbusine>nckx: yeah as sham1 says - whatever is beyond portable rnrs
<sham1>noneofyourbusine: the thing is that you'd only know whether it's going to be valid C90 once you've translated all of the C++ away
<sham1>And that would require a full rewrite anyway
<nckx>I just mean there's no hard reason that Guix isn't purely rnrs. We use all of Guile because it's there, and because I suspect the creator is biased towards Guile (I'm collecting evidence of this), not because we 'need' to.
<noneofyourbusine>sham1: if you rely on a toolchain to report that yes - piece-by-piece translation is just how to get to that goal
<noneofyourbusine>nckx: yeah I would also like guix scheme parts to be portable rnrs. idk what the current state is
<sham1>You'd really want to wait until R7RS-large is a thing before we'd get to translating things to "standard" Scheme
<noneofyourbusine>sham1: I figured, although r7rs-small was 2013
<sham1>It was
<nckx>Just this minute came across <https://github.com/RyanWelly/lisp-in-rs-macros>; good to bookmark when someone suggest a daemon rewrite in Rust.
<sham1>Hah!
<sham1>That does look like a weird mismash of CL and Scheme
<umanwizard>Hi all
<umanwizard>I'm trying to create some Go packages for local use, and I'd rather vendor all the dependencies into the source rather than add a new package for everything in the dependency tree. So what I want to do is: (1) get the source from GitHub, (2) run "go mod vendor" in the root directory, (3) tar up the resulting directory and use that tarball as the source for some package.
<umanwizard>Is it possible to automate this in Guix?
<umanwizard>The problem is that running "go mod vendor" requires network access, which we don't have in the builder ...
<Rutherther>umanwizard: look up how stuff like git-fetch or url-fetch works. There is nothing stopping you from doing your own "go-vendor" fixed-output derivation. The only important thing is that you specify the output hash, to make it fixed output derivation.
<old>ehh I keep getting a "alist-cons-after install install-binaries" error on a package that adds a phase after 'install in guile-build-system
<efraim>are you trying to use alist-cons-after instead of the modify-phases syntax?
<Rutherther>because there is no install phase in guile-build-system
<old>right I just saw that
<old>but there were a install phase before
<old>because it was building before
<old>hm
<Rutherther>there wasn't for couple of years
<old>anyway to "append" a phase at the end
<Rutherther>but modify-phases changed after core-updates. Before it just appended as last, now it throws an error if the phase doesn't exist
<old>ahhh
<umanwizard>Rutherther: thanks for the tip, this is enough to get me started I think
<umanwizard>I didn't realize url-fetch and git-fetch just return a derivation, so it can be anything. I thought they returned some special hardcoded kind of thing
<char>I successuly build blender 4.2.1 on guix, but I still get a non-elaborated segmentation faut. Does anyone have insights?
<char>You can see the code on my blender branch here: https://git.sr.ht/~charje/guix/refs. Let me know if you find anything. You can reach me at charles@charje.net if I am not on IRC later.
<nckx>sneek: later tell necto Your mail hit the moderation queue 5h after I checked, so it was stuck ~somewhere~ else.
<sneek>Okay.
<rovanion>Anybody ever get a CMakeError when including HarfBuzz? https://paste.debian.net/1330071/
<Rutherther>anyone here has a vps with guix? which provider did you choose, and was it easy to set up?
<Elouin>Rutherther: yup, Hetzner. Asked support to add the guix iso to available images to my account and did a manual install.
<Elouin>After the initial install i started using `guix deploy` for the management.
<Hamled>Guix has a module for defining a machine to use with guix deploy which is intended to be used with DigitalOcean, however I've been trying to use it lately and I think it may require some patches before it's working again.
<zamfofex>Rutherther: I had success booting to Guix on Vultr before. Fairly straight forward, you add the ISO to your account, then you can set up a VPS with any system (e.g. Debian), boot it with the installer image, use their inbuilt “noVNC” (in browser) to install it, and reboot to Guix.
<futurile>can anyone get python-sphinx@5.1.1 on master to build?