IRC channel logs

2024-07-14.log

back to list of logs

<PotentialUser-56>Is it normal for guix refresh to take a loong time even if I don't have any explicitly installed packages
<elpogo>PotentialUser-56: from the manual "By default, guix refresh reports *any packages provided by the distribution* that are outdated compared to the latest upstream version"
<lfam>dariqq: For me, it peaked at 20GB used. With 12 cores
<lfam>PotentialUser-56, elpogo: `guix refresh` is a tool used by Guix package maintainers. It is not used to update packages. What are you trying to do?
<Cessation>I'm trying to make static my linux version number so it stays working. Something is wrong with my syntax, though. Can anyone help?
<Cessation>```lisp
<Cessation>(define my-kernel "linux-6.8.10")
<Cessation>(operating-system
<Cessation>(kernel my-kernel)
<Cessation>;;; ...
<Cessation>)
<lfam>Cessation: Share your paste on this site: <https://paste.debian.net>, not sure
<lfam>I mean, not here
<Cessation> https://paste.debian.net/1323220
<lfam>Thanks Cessation. Guix doesn't include the 6.8 kernel series any more, so you have two options: Downgrade your Guix to a version that contained 6.8, and stay there. Or define your own custom 6.8 kernel package and use it. Note that 6.8 is no longer supported by the kernel developers
<Cessation>I would love to stay where I am, but won't it automatically change to the latest thing?
<lfam>For option two, you'd put (kernel linux-6.8) in your OS configuration file, and make sure your custom package was defined with that name
<lfam>Then it would stay
<lfam>Is that what you meant?
<Cessation>Custom package... I am not sure how to do that
<lfam>It's totally possible and supported by Guix, but doing it for the kernel is not as simple as a basic package, because the kernel packages have some supporting files such as the kernel config, and you'd have to make those available in your channel too. I know you can get help to do it here or on the help-guix mailing list. In the long run, you'll probably want to get off this abandoned kernel series. Maybe use long-term supported kernel series like 6.6:
<lfam> https://www.kernel.org/
<lfam>I assume that something breaks for you with 6.9?
<attila_lendvai>i think there's a bug in GPT image partition layout: "Warning! Secondary partition table overlaps the last partition by 33 blocks!" (that's suspiciously close to the 34 sector gap at the head, which is probably not accounted for)
<lfam>That doesn't sound good
<attila_lendvai>err, wait
<attila_lendvai>i assumed it's a gpt partition table, but it's DOS
<attila_lendvai>the error is printed by gdisk
<attila_lendvai>IOW, it's a false alarm
<lfam>Oh, good!
<attila_lendvai>yeah, i double checked it. the "issue" is that gdisk implicitly converts the DOS partition table to GPT, and GPT has a backup table at the end for which the DOS layout doesn't leave space.
<attila_lendvai>IOW, it's a gdisk bug
<attila_lendvai>unmatched-disk-image is a very misleading name. it should be called hifive-unmatched-disk-image, or at least a damn comment at the file header that this is the name of an ARM board...
<lfam>Yeah, 'unmatched' doesn't sound like a "name"
<lfam>Not like 'core' for a CPU brand ;)
<Cessation>yeah, I spent a long time debugging an obscure guix error about v9-ice something or other, only to find that it was a result of the kernel and things were fixed by reverting
<lfam>ice-9 is a Guile Scheme thing. It would be great to know how to trigger the bug
<lfam>If you just want to stay on an older kernel, putting (kernel linux-libre-6.6) in your OS configuration is the easy way
<lfam>You'll probably have to import (gnu packages linux) as well, at the top of your OS configuration where modules are imported
<lfam>If you're using linux and not linux-libre, adjust accordingly
<Cessation>I'm using `(nongnu packages linux)`
<Cessation>so would it be `(kernel linux-6.6)`
<lfam>Right
<lfam>That will keep you on the 6.6 kernel series until it is no longer supported, which is currently schedule for December 2026: <https://www.kernel.org/category/releases.html>
<lfam>Presumably whatever bug you experienced will not be a factor by then
<theesm>Cessation, is the bug that locks you to =<6.8.10 already known/filed/discussed on lkml? haven't followed much of the discussion here, but maybe there'll be a chance of it being fixed in upstream sooner than later anyways
<oriansj>how would one manually tweak a shepherd service on guix when reconfigure was in a broken state until the guix-daemon gets running again?
<Cessation>theesm it looks like I was wrong. The ice9 stuff was earlier, and did go away -- but I almost bricked my computer and had to intercept loading based on this pipe-a error: https://bbs.archlinux.org/viewtopic.php?id=263884
<oriansj>(as changes need to be made to the guix-daemon service to get it working again)
<lfam>oriansj: Hm, not too sure about tweaking the services. But it's not too hard to start guix-daemon "by hand" on the command line, if that helps
<lfam>Almost certainly something like this: `guix-daemon --build-users-group guixbuild --substitute-urls https://bordeaux.guix.gnu.org https://ci.guix.gnu.org`
<lfam>Run it as root
<oriansj>lfam: I'll give that a try
<lfam>Cessation: This won't help, but I can confirm that what seems like common hardware that should be supported on recent kernels does tend to lose support as time goes by. I have an Intel Core i5 and things started breaking in the last couple years. So I use the 5.15 kernel series. The alternative is to send bugs to LKML
<lfam>I meant to say that the i5 is from 2016
<lfam>So, "only" 8 years old
<Cessation>on system reconfigure I'm getting errors like `error: file system with UUID 'E1A0-CD4D' not found`. That makes sense; but how do I find my actual drive uuids?
<lfam>I use the blkid command, and also look at /dev/disk/by-uuid
<oriansj>/dev/disk/by-label is handy if one has the foresight to label one's partitions
<oriansj>lfam: looks like it is working to solve my problem. Thank you
<Cessation>I  don't have a /dev/disk/by-label/
<Cessation>I do have a surprising three entries in /dev/disk-by-uuid
<hiecaq>Cessation: I think you need to label a FS upon creation. See https://wiki.archlinux.org/title/Persistent_block_device_naming#by-label
<hiecaq>(So if you didn't there wouldn't be labeled devices in that path)
<Cessation>Ah -- got it, thanks to `sudo blkid` . I didnt realize that I have a section for swap in my system.scm just above where I was looking
<glenneth>Hey Folx o/ are the folx at guix.gnu.org aware their certificate has expired?
<PotentialUser-85>Seems like it's not serving a certificate at all to me.
<spenc>whats the proper procedure if I want to edit the source of a guix package?
<spenc>fwiw- im getting: Error code: SEC_ERROR_EXPIRED_CERTIFICATE
<spenc>Websites prove their identity via certificates, which are valid for a set time period. The certificate for guix.gnu.org expired on 7/13/2024.
<spenc>and can see the cert in about:certificate?cert=MIIE5DCCA8ygAwIBAgISBOEoqRSw9uY%2F6I59xyXeTt9KMA0GCSqGSIb3DQEBCwUAMDIxCzAJBgNVBAYTAlVTMRYwFAYDVQQKEw1MZXQncyBFbmNyeXB0MQswCQYDVQQDEwJSMzAeFw0yNDA0MTQyMTQ4MDdaFw0yNDA3MTMyMTQ4MDZaMBcxFTATBgNVBAMTDGd1aXguZ251Lm9yZzCCASIwDQYJKoZIhvcNAQEBBQADggEPADCCAQoCggEBAJqmer1edRIGCvf7XfI%2FQp5BGqbnTLKQwgzCukR6%2FdzNlLu0lvzhM%2FBCI%2Fl2wrufT078wDSb7VdhHFIVmsG6uGdqHZZStDnlLRfWkTC64bW2jb2oy9ZJQF3LhI%2BbU
<spenc>%2BrRkvm15HFaVg9l%2FZqiJ1%2FgsEJRCKCSX3IFZnhQ1S9%2FXxT4TZYbxn6YMhAFYagZWtIkszAhD45ireKpns%2FxWceo3zlhCDY2R2H2AdTUbYPegGkCfuwmTLHt28wmdLrWlaEFNQ2TqmaRrjz%2F2Cee8MByLhn2Vv55afHNYdV3zxH3QmL32Tpxh7cM8gJGTWCwevVCf8BndhwwkPXp2eYp7eJltL8CAwEAAaOCAg0wggIJMA4GA1UdDwEB%2FwQEAwIFoDAdBgNVHSUEFjAUBggrBgEFBQcDAQYIKwYBBQUHAwIwDAYDVR0TAQH%2FBAIwADAdBgNVHQ4EFgQUMglxUWhBzdXKwtvq4%2BJANPfmMDIwHwYDVR0jBBgwFoAUFC6zF7dYVsuuUAlA5h%
<spenc>2BvnYsUwsYwVQYIKwYBBQUHAQEESTBHMCEGCCsGAQUFBzABhhVodHRwOi8vcjMuby5sZW5jci5vcmcwIgYIKwYBBQUHMAKGFmh0dHA6Ly9yMy5pLmxlbmNyLm9yZy8wFwYDVR0RBBAwDoIMZ3VpeC5nbnUub3JnMBMGA1UdIAQMMAowCAYGZ4EMAQIBMIIBAwYKKwYBBAHWeQIEAgSB9ASB8QDvAHUASLDja9qmRzQP5WoC%2Bp0w6xxSActW3SyB2bu%2FqznYhHMAAAGO3svi%2FQAABAMARjBEAiAZ3nEQBDNbuMSWtWsn694OGsvs85tz7KdnEyIuOoldDwIgWoHGN5DsGvyT4KuHHqcAGcNSEABpzU8krB7BAibgiDYAdgA%2FF0tP1yJHWJQdZRyEvg0S7ZA3fx%
<spenc>2BFauvBvyiF7PhkbgAAAY7ey%2BMJAAAEAwBHMEUCIQDKdSPgZQk1IXiCEODagxxIXReHizkuobacKh3vbxf4ewIgXuE2H%2Bl%2BHsHiMvNQ%2BXd%2FRVib8dzQyzjVMUTbAqlDjCAwDQYJKoZIhvcNAQELBQADggEBAHRCnrFDLaDffJAbwrooeiECihbNRJOfUCqVmY04QcQDwK2PhodFnYk6bJmu%2BCvjkScrdOwthA2NQu6kv%2B%2Be1gMN8OWZocErko7ziUjrrEr26Uy7DvIhmhatAOVmWl%2FwsE0XYh%2FWO%2Bd42MsIgnJCNrR6uCYtMjFuMGpacS%2FbABhsbonbd50Jp7iMF6%2FHkeZVBv0u8kgxsgrB7ayso9tYgAWHnf%
<spenc>2BoI99N6nhp6UMOferyVrmqWVolJGZI6LiwxbVhJ%2Bx27Z7lAG4TiI7SAkmMUQtO%2Fod58%2BbspmXpQviQIfC8bbkUBz4JRvKPD3tu%2F4RXqJYumdmGed8Z5sdSw6W1AcQ%3D&cert=MIIFFjCCAv6gAwIBAgIRAJErCErPDBinU%
<spenc>2FbWLiWnX1owDQYJKoZIhvcNAQELBQAwTzELMAkGA1UEBhMCVVMxKTAnBgNVBAoTIEludGVybmV0IFNlY3VyaXR5IFJlc2VhcmNoIEdyb3VwMRUwEwYDVQQDEwxJU1JHIFJvb3QgWDEwHhcNMjAwOTA0MDAwMDAwWhcNMjUwOTE1MTYwMDAwWjAyMQswCQYDVQQGEwJVUzEWMBQGA1UEChMNTGV0J3MgRW5jcnlwdDELMAkGA1UEAxMCUjMwggEiMA0GCSqGSIb3DQEBAQUAA4IBDwAwggEKAoIBAQC7AhUozPaglNMPEuyNVZLD%2BILxmaZ6QoinXSaqtSu5xUyxr45r%2BXXIo9cPR5QUVTVXjJ6oojkZ9YI8QqlObvU7wy7bjcCwXPNZOOftz2nwWgsbvsCUJCWH%2BjdxsxPnHKzhm%2B%
<rickame>so we configure our OS in a guile file, then apply it, then the guix daemon that's made in c++ makes the scheme config become real?
<Deltafire>not sure about the c++ part, but the rest sounds about right
<rickame>but im pretty sure the guix daemon is c++
<Deltafire>i think it's basically the nix daemon, which is c++
<rickame>ok so here's what i don't get. when we set host-name in the guile file, how does the c++ daemon take that guile in and translate it into the OS now having the new hostname?
<Deltafire>so think of guix as nix, but with scheme instead of whatever custom language nix uses for its config
<Deltafire>i think the scheme code converts it into a derivation (.drv) which the guix/nix daemon uses to perform the build
<Deltafire>the reference manual explains it in more detail
<rickame>know where the code is that handles the host-name part of the config? i wonder what it looks like
<Deltafire>no, but try grepping the guix repo
<rickame>is it on github?
<Deltafire> https://git.savannah.gnu.org/git/guix.git
<rickame>no search button wtf
<Deltafire>yeah, it's a bit basic.. probably easier to checkout the repo locally
<glenneth>;l8frrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrd'''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''/*\]
<eftsoon>sigh! guix.gnu.org certificate expired
<rekado>letsencrypt challenges for guix.gnu.org fail because also bayfront responds to guix.gnu.org
<rekado>certbot ends up talking to the wrong server and the cert isn't renewed
<rekado>I have renewed almost all certs manually now
<rekado>letsencrypt still talks to the server at bayfront, though. I've temporarily disabled nginx on bayfront.
<rekado>does anyone know how to tell knot on bayfront to point the DNS record to berlin again?
<rekado>I have to go now
<mfg>Hi, how do i get a arm-none-eabi-toolchain? I can't find a package for it.
<freakingpenguin>mfg: arm-none-eabi-toolchain was changed from a package to a function that returns a package a while back. You can do something like "guix shell -e '((@ (gnu packages embedded) make-arm-none-eabi-toolchain-6))'" or call that function from a manifest.
<dariqq>lfam: without the (somewhat) recent bpf addition the requried free space is 3-4GB
<lfam>Interesting
<dariqq>Also would it be possible to create a new stable kernel header/ update the older one such that updating the latest kernel does not rebuild all kernels?
<lfam>Which headers package are you referring to? Each kernel series has its own headers package, and then there is a package 'linux-libre-headers-5.15.49' which is part of the Guix bootstrap, and thus can't be updated often
<lfam>Also, I hadn't noticed that updating the latest kernel caused the other packages to be rebuilt. Does that in fact happen?
<dariqq>lfam: problem is that linux-libre-*->dwarfes->libbpf->linux-libre-headers-6.9. So even if only the 6.9 kernel has its weekly update all kernels are rebuilt because also its header package change
<lfam>I see
<lfam>Can you file a bug report? That is suboptimal
<dariqq>And it also ties all packages that need a newer header than the 5.15.49 to the update cycle of the latest kernel (currently it is only libbpf but i tried updating mutter to 46 and it needed newer headers to build)
<dariqq>will do
<lfam>Thanks
<lfam>Were you able to figure out which headers version is required by the new mutter, dariqq?
<dariqq>let me check if i still have that attempt somewhere
<dariqq>found it. Need to rebuild a few things before getting to see what exactly mutter wants
<dariqq>appearently a few things inlcudes mesa, gstreamer gtk, qt, ...
<Kolev>How do I "install updates"?
<sepeth>Hi Kolev, run guix pull, then guix upgrade (it is an alias to guix package -u).
<Kolev>sepeth: Thanks.