IRC channel logs

2024-07-01.log

back to list of logs

<adanska>using `substitute*`, is there a way to escape parentheses in the matching expression? `\( \)` doesnt seem to work.
<jaft``>adanska: does your string look like "\(stuff\)" ?
<adanska>yes
<adanska>well, it looks like `"find_package\(stuff\)"`. The actual string im trying to match does not have the slashes.
<jaft``>I think you need "find_package\\(stuff\\)"; one backslash tries to escape the parenthesis in the string (which, since they don't need escaping, results in `find_package(stuff)`).
<jaft``>Two backslashes should result in `find_package\(stuff\)`, thereby escaping the parenthesis in the regexp, instead.
<weary-traveler>guile needs something like elisp's rx
<weary-traveler>maybe they already have something
<jaft``>weary-traveler: Do you find it easier? I haven't used it much but it always feels like an extra abstraction layer that makes thinking about regexp harder than just working directly with it. Like my brain has to do two conversions, now.
<weary-traveler>jaft``: regd rx? i do find it easier. i don't remember syntax much. rx is easier to read when you're looking at code after a while. and the documentation makes writing a new expression straightforward as well. not to mention i can never remember how many times to escape things
<ngz>weary-traveler: There is guile-irregex
<weary-traveler>oh handy. thanks ngz
<ngz>cbaines: FYI, there are recent errors such as "tar: persim-0.3.2: Cannot mkdir: No space left on device" on CI.
<futurile>Morning all
<efraim>o/
<efraim>oh wow, that was more than an hour ago
<futurile>heh
<futurile>time flies when you're debugging a build?
<graywolf>Hello Guix! I am writing my first shepherd service, and it seems I need to do (respawn-limit ''(3 . 300)). That seems... weird. I that expected or documented somewhere?
<z572>hello, i pushed openssh 9.8p1 to master, Fixes a critical security bug allowing remote code execution as root.
<z572>see https://www.openssh.com/txt/release-9.8
<fnat>I've something that resembles this https://paste.debian.net/1322006/ in my Guix Home configuration. Most of it work but msmtp doesn't. I must be using this wrong: '(service-extension home-msmtp-service-type (const (list my/msmtp-config)))'.
<fnat>'guix home reconfigure config.scm' terminates successfully, but the resulting msmtp file only contain the string "defaults".
<fnat>Anybody has any idea on what I might be doing wrong?
<fnat>*the resulting msmtp config file in '~/.config/msmtp/config'.
<efraim>fnat: try (const my/msmtp-config)
<ngz>There are disk spaces issues on CI at the moment…
<fnat>efraim: Thanks! Unfortunately it doesn't seem to have changed anything. The config file is still just "defaults".
<fnat>Odd...
<efraim>fnat: for comparison here's my msmtp accounts config: https://git.sr.ht/~efraim/guix-config/tree/master/item/efraim-home.scm#L653-686
<fnat>Brill, thanks Efraim, that'll help.
<tschilp>Hi guix! Assuming I'd like to contribute a package, is there a way/best practice to inform/control on which kernels it should be available? It's a wifi usb dongle kernel driver (using it for some two years now, but github sources have to be adapted after kernel updates of linux-libre most of the time)
<tschilp>It's like linux-libre@6.8.5 needs commit-at-a-certain-point-of-time and linux-libre@6.9.5 needs commit-at-a-certain-later-point-of-time, but I don't know how to implement this!
<tschilp>It typically survives minor-minor-updates like kernel x.y.z->z+n, but tends to break at x.y->y+n.z
<cwebber>Oof this openssh vulnerability looks truly nasty
<cwebber> https://www.qualys.com/2024/07/01/cve-2024-6387/regresshion.txt
<efraim>oh, i see regreSSHion now
<sepeth>Hi there, after some attempts I got `guix system init ...` working, and I see Guix' grub! But, when booting, the root partition cannot be mounted, and it says possibly non-existent device. I specified the root like /dev/sda2 (I also tried label and uuid, but got similar results). I am trying to install this on a VM, so I checked the initramfs and it contains virtio_blk.ko{,zst}. So, I am not sure why
<sepeth>it can't find the device. Any help is appreciated (´▽`)/
<sepeth>Also, I can't type in the guile REPL that comes up :( keyboard doesn't seem to be working, not sure if it is a red-herring, or somewhat related.
<jackhill>cwebber: some kind soul has already submitted a patch (not sure if the security team is aware): https://issues.guix.gnu.org/71873
<jakef>that patch is already in
<jakef>does it warrant a news entry?
<futurile>is it actually exploitable, the Ubuntu release they exploited is from 2006, but the Debian package was far more recent if I understand it?
<futurile>it's a bit of a weird jump
<efraim>I assume it had something to do with ubuntu pulling from debian testing and having different release schedules
<jackhill>sepeth: sorry, I don't have any more ideas for you other than making sure the modules you need are in the initramfs which you've done :/
<sepeth>jackhill: thank you in any case, that at least confirms I am on the right path!
<gabber>aloha!
<gabber>what is the go-to way to add special routes to wireguard-service-type?
<jackhill>gabber: aloha! what do you mean by special routes? I've only done wireguard's automatic routning with allowed-ips
<gabber>i have a specific IP address i need routed through some address available through wireguard. with networkmanager this is available through IPv4 Configuration / Routing. e.g. i set wg up with an address of 192.168.0.25/24 and want 12.13.14.15/32 routed via 192.168.0.13
<dariqq>I am trying to run the test suite for guix after installing the dependencies manually and the test just hangs in the container.scm after 4 succesful tests. Any ideas?
<futurile>dariqq: there's a tests.log file you can look at
<dariqq>it just seems not do anything after succesfull first 4 tests. I have changed the file to skip all of them right now and seems to be doing fine for the rest for now (after adding a #include <stdio.h> for the gremlin.scm test)
<h4>I need a channel for my config.scm to compile but when I add it, `guix pull` simply ignores it, do like the channels.scm wasn't modified
<h4>he does like
<h4>*
<h4>In fact he do only identify the last channel in the channels.scm file. It's like every new definition overwrite the previous one
<h4>I need to find a structure that accept all channels
<sham1>Show your channels.scm, with a pastebin of some sort
<h4>It's something weird where every channels advise to add them with a structure like cons channel %default-channels, but that overwrites instead of adding each time, so you have to use a list, but when using it with cons to add to default-channels it doesn't return anything to guix pull, so you have to give up on cons default-channels and define
<h4>manually guix main aswell
<h4>Maybe you know a structure that adds multiple channels to/aswell as default-channels while returning something to guix pull? to avoid manually defining guix main
<h4>Why chromium is one year old?
<jackhill>h4: I think because it is a lot of work to update it and no one has put in that work. It's made worse by needing a powerful computer to build the new package, so it reduces the pool of people who can work on it. An unfortunate situation indeed. Hopefully in the future the chromium developers will make it easier for us.
<h4>bind provides mdig but not dig, how to get it
<ieure>h4, bind:utils
<ieure> https://packages.guix.gnu.org/packages/bind/9.19.24/
<h4>Thanks! Where can I read about that ":" structure?
<ieure>h4, https://guix.gnu.org/manual/en/html_node/Packages-with-Multiple-Outputs.html
<ngz>Interestingly, in bordeaux, woodlands has a build list of 725 elements although its load is 1 % (this may be related…). I'm not sure it is expected.
<h4>Thanks! How to use Mozilla Password Manager on Guix?
<ieure>h4, No idea. Is that a standalone thing, or built in to Firefox?
<h4>Built-in
<ieure>Firefox isn't in Guix, because of Mozilla's policy around branding and trademarks.
<ieure>You could try Librewolf? I think it can use the Mozilla PWM, though I don't personally use or recommend that.
<h4>Why not recommending LW over IC?
<dthompson>h4: are you aware of the guix channel that has firefox? i just use that
<h4>I only know [DM] and none of them gives FF
<sarg>hi guix, can a shepherd service be optional? I.e. I want that it could be started manually, but otherwise it should be turned off even after rebooting.
<dariqq>sarg: there is an auto-start? option but it depends on the service if it allows you to configure this (https://guix.gnu.org/manual/devel/en/html_node/Shepherd-Services.html)
<PotentialUser-36>Can I even run monogame and c# on guix or do I need some kind of vm for that? AppImages don't work as I figured out..
<PotentialUser-36>I have my suspicion that it's not gonna be possible..
<PotentialUser-36>But I'd be happy if someone could confirm it
<apteryx>regreSSHion... hm.
<apteryx> (https://blog.qualys.com/vulnerabilities-threat-research/2024/07/01/regresshion-remote-unauthenticated-code-execution-vulnerability-in-openssh-server)
<dariqq>almost all tests succed now. tests/guix-build-branch.sh fails because notabug and tests/style.scm has some whitespace issues. Need to recheck what the problem which container.scm and gremlin.scm is
<PotentialUser-36>Sorry for this kind of spam.. But I'd really like to know if it is possible to use monogame/c# on guix :)
<gabber>PotentialUser-36: i've found guix's container with fhs simulation working wonders in getting stuff to work that "just works" on other distributions
<gabber>so, maybe try adding necessary dependencies to a container with --emulate-fhs and start the appimage from there?
<PotentialUser-36>gabber: Ok thanks! What is fhs simulation though..?
<PotentialUser-36>But yeah I can give it a shot. Thanks already for the answer!
<attila_lendvai>diffoscope build fails due to test errors
<freakingpenguin>It seems like the openssh update to 9.8p1 broke diffoscope's test suite
<attila_lendvai>oh, right. they have disabled some encryption at compile time
<freakingpenguin>Failure also occurs on 271 it seems so upgrading won't fix it
<freakingpenguin>Bah, can't report the issue upstream until an admin approves my account it seems.
<msuperdock>Hi, I'm trying to get openssh to use a custom config at `/etc/ssl/openssh.cfg`. If I use wpa_supplicant, I can do this by setting `$OPENSSLDIR` before the wpa_supplicant command. But I want NetworkManager to also pick up the config file. Is there a way I can set an environment variable ($OPENSSLDIR) for all users including root in my config.scm
<msuperdock>file?
<msuperdock>(I'm struggling to see any other option since the openssl package is configured to use the default config in the guix store otherwise.)