IRC channel logs

2024-06-23.log

back to list of logs

<JetpackJackson>how would one go about packaging a package that is just a shell script? i want to add sway-launcher-desktop to guix but its just a script lol so theres nothing to compile
<singpolyma>JetpackJackson: copy-build-system
<singpolyma>You just give it a list of files to copy and that's it
<JetpackJackson>alright ill look into that, thanks!
<singpolyma>I think shebang rewrite still runs in that (since you actually do want a minor build step for scripts to fix the shebang) and if it calls any other binaries from other packages you may need to rewrite those at build time as well
<JetpackJackson>ah ok good to know
<JetpackJackson> https://paste.debian.net/1321202/ ok it builds but i cant run it/it doesnt show up when i run "which --all sway-launcher-desktop"
<peanuts>"debian Pastezone" https://paste.debian.net/1321202
<singpolyma>JetpackJackson: maybe it lost +x ?
<JetpackJackson>singpolyma: how would I check?
<redacted>if it doesn't show up in which --all, it's not in your path
<singpolyma>JetpackJackson: ls -l on the build output in /gnu/store/whatever
<redacted>ls -l /gnu/store/g2q7mkmm578cwq2ijs2863dcal2cihh9-sway-launcher-desktop-1.7.0
<redacted>Maybe you need to supply the install-plan argument to move the script into /gnu/store/g2q7mkmm578cwq2ijs2863dcal2cihh9-sway-launcher-desktop-1.7.0/bin
<redacted>i'm really speculating though
<redacted>the copy-build-system docs: https://guix.gnu.org/manual/en/html_node/Build-Systems.html#index-copy_002dbuild_002dsystem
<peanuts>"Build Systems (GNU Guix Reference Manual)" https://guix.gnu.org/manual/en/html_node/Build-Systems.html#index-copy_002dbuild_002dsystem
<redacted>JetpackJackson: you can see an example of a simple script using the copy-build-system with `guix edit wl-color-picker`
<JetpackJackson>Alright I'll look at that in a sec, thanks!
<freyacat>does anyone know how to properly package egl? i got hyprlock to build but it always fails to launch with the error "EGL_EXT_platform_base not supported"
<JetpackJackson>singpolyma, redacted: ls -l /gnu/store/<path to build> shows the script, license file and readme, so im going to try looking at the sample copy-build-system thing and test if that works for my file
<JetpackJackson>(side question, is that how you mention two different people on irc?)
<singpolyma>Probably the script should be in bin/
<singpolyma>And it has +x?
<JetpackJackson>yeah
<JetpackJackson>oh whoops need to add fzf as a dependency lol
<Kolev>I haven't used a real computer in a week.
<JetpackJackson>any idea on why (use-modules (gnu packages fzf)) doesnt work/what is the right way to get fzf available as an input?
<singpolyma>try guix show fzf to find it
<JetpackJackson>location: gnu/packages/terminals.scm:1052:2
<redacted>so that's (gnu packages terminals)
<JetpackJackson>ah ok nice
<JetpackJackson>thanks
<JetpackJackson>alright it works
<JetpackJackson>(it has a bit of a problem cause it cant find direnv for my shell hook but thats not a problem with the package lol!)
<JetpackJackson>ok so the package works, so tomorrow ill have to spruce up the file and then i guess i submit it to the mailing list? i might need some help with that lol
<singpolyma>You could always submit to guixrus first so people can benefit right away
<JetpackJackson>ive never heard of guixrus
<JetpackJackson>im worried that im going to have something formatted wrong or smth that i shouldve fixed beforehand lol
<Guest3>How do I find the module which corresponds with a package? As I try to declare packages I keep having to add more modules but I keep guessing and copying other people's configs...
<redacted>`guix show <package name>` has a line that starts with "location"
<redacted>The name of the package will be similar to the file path
<redacted>so gnu/packages/terminals.scm would be the (gnu packages terminals) module
<Guest3>Ohhhhh. I keep seeing people say they use guix show but I never understood. Thanks.
<Guest58>Good morning,
<Guest58>I just installed guix 6.0.10 on a framework 16, but I get cross_eclpcs cross_ec_lpcs.0: EC ID not detected after first start and then guix hangs. Anyone any ideas, what to do?
<Guest58>also hc0  missing free firmware (non firmware loading disabled)
<Guest58>But I think the problem is different, it is just bluetooth not working
<cbaines>Guest58, when you say it hangs, can you be more specific? How far through the boot process does it seem to get, and what's on the screen when it hangs?
<Guest58>cbaines one moment please, I try reinstalling without encryption for now to have that as error out of the way.
<Guest58>cbaines also with the framework, I got the following error in the beginning of the installation:
<Guest58>ardware support warning
<Guest58>Devices not supported by free software were found on your computer:
<Guest58>  - 1002 15bf
<Guest58>That might be conncted. Is there a way to circumvent this problem?
<cbaines>Using the nomodeset boot option should help
<cbaines>But as the installer says, there's no free firmware for the AMD graphics you're using
<Guest58>cbaines how do I boot with nomodeset?
<cbaines>Guest58, when you get to grub, edit the boot option and add nomodeset to the end of the appropriate line
<cbaines>I forget how to describe the right line, but it'll probably have the quiet option towards the end
<Guest58>cbaines now it loaded, thank you, but why? does the kernel not need the drivers?
<cbaines>I think nomodeset tells Linux/Linux-libre to handle the graphics hardware differently
<cbaines>In this case there's a distinction between drivers and firmware I think, and given free firmware is lacking, nomodeset switches to a simpler mode of operation that doesn't break without firmware
<Guest58>cbaines do you think, that this has any disadvantages for me?
<cbaines>That entirely depends on how you're planning on using the machine
<Guest58>cbaines I want to have a second monitor, which is also not loading atm
<Guest58>cbaines is there a way to get the free drivers for the gpu?
<cbaines>as I say, I think there's a distinction between drivers and firmware here
<cbaines>Linux-libre does include drivers, but doesn't include firmware and that seems to be a problem for current AMD graphics hardware
<dariqq>I am a bit confused. Emacs today has been updated to 29.4 and is being grafted to 29.4 right now?
<Guest58>cbaines okay, thanks a lot for your help, you made my day
<cbaines>dariqq, yeah, that seems wrong
<cbaines>either the graft should be sufficient and the package shouldn't be updated, or the package should be updated and the graft removed
<cbaines>lilyp, is updating emacs-minimal necessary for this fix? I ask mostly because it's got quite a few dependent packages.
<dariqq>7e15704613b67ec54df8f1269916bc72b76bb785 is the update to emacs and 868a022cdca164941a6fe8dcf205aefc693781cb grafted the update earlier today
<peanuts>"guix.git - GNU Guix and GNU Guix System" https://git.savannah.gnu.org/cgit/guix.git/commit/?id=7e15704613b67ec54df8f1269916bc72b76bb785
<peanuts>"guix.git - GNU Guix and GNU Guix System" https://git.savannah.gnu.org/cgit/guix.git/commit/?id=868a022cdca164941a6fe8dcf205aefc693781cb
<lilyp>cbaines: Sorry, no. Please revert.
<lilyp>All of our emacs packages have package/inherit so the graft ought to be propagated.
<cbaines>feel free to revert it if you want to
<cbaines>I'm often conflicted when this happens, since we don't really have a process to stop the builds, so now the change has been pushed, it's going to be built anyway, reverted or not
<cbaines>I think it should either be reverted, or the graft removed, since it doesn't make sense to have both
<lilyp>the graft is the right mechanism
<lilyp>We can ungraft on emacs-team.
<attila_lendvai>`guix build fontconfig` returns two outputs. how can i select from them? my ultimate goal is comething like: `less $(guix build fontconfig)/share/fontconfig/conf.avail/70-no-bitmaps.conf`
<attila_lendvai>FTR, this works, but it's ugly: cp $(guix build fontconfig | grep -v -- "-doc")/share/fontconfig/conf.avail/70-no-bitmaps.conf ~/.config/fontconfig/conf.d/
<pkill9>could guix ever become as fast as apt?
<cbaines>some bits are harder to be faster, whereas some bits are easier to be faster, so the answer is yes, and no, it's complicated
<lilyp>cbaines: re emacs, it appears that with the input trick, we're now building packages twice
<lilyp>I still need to work out build-system and packaging boilerplate to do multiple emacs variants at once, as we have with cl
<lilyp>also, it's possibly once, plus once per regrafting and I just happened to run GC
<apteryx>can we consult http-hosted files with TRAMP?
<abbe__>Hi, is CI stalled ? I noticed no builds since June 19th, while there are commits.
<eftsoon>hi!
<lykso>Trying to figure out what the syntax is for referring to a particular output of a package with multiple outputs in the context of a g-exp
<lykso>I see the syntax for referencing it in a package's "inputs" list is `(,<package> "<output>") and have used it successfully as such, but it doesn't seem like I can just transpose that to a g-exp. Gives me "wrong type to apply."
<cbaines>If you move beyond trying to figure it out, the documentation states the syntax https://guix.gnu.org/manual/en/html_node/G_002dExpressions.html#index-_0023_007eexp
<peanuts>"G-Expressions (GNU Guix Reference Manual)" https://guix.gnu.org/manual/en/html_node/G_002dExpressions.html#index-_0023_007eexp
<lykso>Ah, I'd been looking in the wrong place, I guess
<lykso>I'd figured there was a generic syntax to get a reference, so I was searching for things related to packages with multiple outputs, which brought me nothing in Kagi
<lykso>Except the same documentation page about packages with multiple outputs
<lykso>Thanks!
<Googulator>I'm reading https://guix.gnu.org/manual/devel/en/html_node/Customizing-the-System_002dWide-Guix.html and I'm left with one glaring question: *where am I supposed to put that* on an already installed Guix system?
<peanuts>"Customizing the System-Wide Guix (GNU Guix Reference Manual)" https://guix.gnu.org/manual/devel/en/html_node/Customizing-the-System_002dWide-Guix.html
<cbaines>where are you supposed to put what Googulator ?
<Googulator>The modified channel definition, to have it affect the system-wide Guix
<Googulator> /etc/guix/channels.scm is read-only, so it's clearly not it
<cbaines>the docs are suggesting changing your operating system configuration
<Googulator>which is...
<cbaines>wherever you put it?
<cbaines>do you know what arguments you've passed to guix system init or guix system reconfigure?
<Googulator>oh, config.scm - I'll have to bring that over onto the actual Guix SSD, since it's only on the bootstrapping system atm
<parnikkapore>Hi, it looks like the TLS cert for https://10years.guix.gnu.org didn't get renewed?
<Googulator>parnikkapore: same for hpc.guix.info
<Googulator>even worse, hpc.guix.info has had HSTS enabled, so now I can't even add an exception for it
<Isaz>Hi, is there an easy way to see which devices plugged externally into my computer require non-free firmware? I see non-free firmware messages when I boot, but cannot read them
<Isaz>dmesg does allow me to review the nmessages
<Isaz>and I can tell what devices they are :)
<cbaines>I'm not sure what's up with these broken certs, but I'll have a look at fixing it...
<parnikkapore>thanks!
<Guest42>I have now guix version 6.9.5 and during start I get the error USBC000:00 ups-handle_connector_change ACK failed. Anyone any idea?
<Guest42>I get con4: failed to register partner part modes -5
<Guest42>Unknown error 256
<Guest42>All with ucsi_acpi USBC000:00 in front of the errors
<eftsoon>hi, what's the time line for binary packages to be available in substituters, once they're committed to master branch ?
<cbaines>eftsoon, sometimes instantly, sometimes it may take many hours or maybe even longer
<eftsoon>oh, I see, thanks! I was expecting it to be similar to nixos, where stuff to nixos-unstable branch gets merged post build of master branch