IRC channel logs

2024-06-21.log

back to list of logs

<jaft>I dunno if anyone else has run into this but, every time I suspend my computer, my bluetooth is disabled. It didn't happen with my old laptop (likewise, running Guix) so I don't know if it's hardware specific, any. Same setup. I'm using the bluetooth service and blueman as a simple-service of the dbus-root-service. Any way to have it turn itself back on whenever the computer resumes?
<eikcaz>jaft: I think the implication there is that the bluetooth is crashing at suspend (which it should not be doing). I don't think there is a hook that specific, but you could always add a cron job to restart it periodically as a work around
<eikcaz>But if you are interested in fixing the actual problems, you should check the shepherd log to see why it is crashing
<jaft>eikcaz: Mmm; hadn't even thought of that. Yeah; that'd make sense. (if you don't mind) Remind me how to do that, again? I always have to relook it up because I forget, again, by the time I need to do it.
<eikcaz>I think its /var/log/messages
<eikcaz>wait, those look like guix home messages, not guix system
<eikcaz>(I don't actually remember where the log file is either)
<eikcaz>Oh wait, I see guix system serices in there too
<jaft>Ahh, cool; thanks!
<Guest6217>I'm having a hard time understanding use-modules. are you just supposed to guess which ones need to be declared?
<mange>You can find out which ones, by looking at the output of "guix search" or "guix show". For example, "guix show emacs" has "location: gnu/packages/emacs.scm:432:2" which means it's defined in (gnu packages emacs).
<mange>That said, I usually just write the code I want assuming the names are in scope, then loop "try to run it, use the error to work out what to add to use-modules" until it works.
<Guest6217>I get hints that say "Did you forget a 'use-modules' form?" and I have no idea what I'm supposed to fix. I've been having a hard time just declaring packages and services.
<Guest6217>I don't understand how use-modules is supposed to work. I keep getting a "hint" whenever I try to declare home services like dbus or pipewire saying something like: hint: Did you forget a `use-modules' form?
<Guest6217>I'm having a hard time figuring out when I need to declare a module and what modules are even available to be declared
<trev>Guest6217: general rule of thumb for me is to refer to the manual first, which tells which module to use. if it doesn't then i usually traverse through the guix repository and look for the module myself or grep the entire thing
<trev>but yeah, guix search and show are more useful
<Guest6217>How do you check with guix search and show?
<Guest6217>On the manual it doesn't say what module to use for pipewire
<Guest6217>unless it doesn't need any special module and I'm screwing up...
<Guest6217>I'm so confused, nobody goes over the modules when talking about Guix. Nowhere!
<Guest6217>I can't make progress
<mange>Modules are a Guile language feature. When you're writing "Guix" code, you're actually writing in Guile Scheme. They aren't talked about in Guix documentation because they're talked about in the Guile documentation instead. "(guile) Using the Guile Module System" https://www.gnu.org/software/guile/manual/html_node/Using-the-Guile-Module-System.html
<peanuts>"Using the Guile Module System (Guile Reference Manual)" https://www.gnu.org/software/guile/manual/html_node/Using-the-Guile-Module-System.html
<mange>Actually, I think "(guile) Modules" https://www.gnu.org/software/guile/manual/html_node/Modules.html is probably more helpful, but you've disconnected now either way.
<peanuts>"Modules (Guile Reference Manual)" https://www.gnu.org/software/guile/manual/html_node/Modules.html
<Guest7716>No I'm not disconnected lol
<Guest7716>I had to rejoin
<Guest7716>I kind of understand that it's a Guile feature, and I plan on delving into Guile, but I'm trying to setup pipewire and a few other things to create a usable system but I haven't been successful thus far.
<trev>you need to know minimal guile first to write your own, in my opinion
<trev>Guest7716: don't forget elogind for pipewire, cause wireplumber needs it
<Guest7716>I have elogind setup in my system config
<trev>are you looking for a guix home config then?
<trev>there is a service for pipewire and it's dead simple https://guix.gnu.org/en/manual/devel/en/html_node/Sound-Home-Services.html
<peanuts>"Sound Home Services (GNU Guix Reference Manual)" https://guix.gnu.org/en/manual/devel/en/html_node/Sound-Home-Services.html
<jaft>trev: something I've always wondered – do you have to make sure you remove the PulseAudio service from %desktop-services or do you just run the PipeWire home service in addition to it?
<Guest7716>if i add dbus and pipewire home services i get "hint: Did you forget a 'use-modules' form?
<Guest7716>I have the home services module as well
<Guest7716>it works without the pipewire service so i'm very confused it should be dead simple
<Guest7716>(use-modules (gnu home)
<Guest7716>             (gnu packages)
<Guest7716>             (gnu services)
<Guest7716>             (guix gexp)
<Guest7716>             (gnu home services shells)
<Guest7716>             (gnu home services sound))
<Guest7716>(services
<Guest7716>sorry i am missing the (home-environment smh
<Guest7716>but either way I can't get it to work with just that simple config
<mange>Can you tell us what the full output is, not just the "hint: " bit, but the full output of the command.
<jaft>Guest7716: Are you using the "(gnu home services desktop)" module? That's the module that the DBus home service is in.
<Guest7716>OMGGGGG I literally tried that earlier and it spit out an error but not this time!
<Guest7716>what the heck i was literally fiddling around for like 5 hours
<trev>jaft: i don't use %desktop-services, so i couldn't tell you :]
<jaft>Heh, fair.
<adanska>is there a procedure that roughly maps to `guix build` in the guix repl that isnt the `,build` meta command? i want to pass a manifest to build in the repl, but the `,build` meta command only takes one package at a time, and i cant use `map` with it because its a meta command
<adanska>or, alternatively, would anyone be able to direct me to where the meta commands are defined?
<glenneth>Hi. Can anyone help out? Does anyone know how to get GDM Wayland
<glenneth> to source bash profile on login when using Guix Home? Thanks
<bdju>speaking of pipewire, how do you run it without using guix home? the manual isn't clear on that and I've been wanting to switch to it for a while
<adanska>bdju: i think you have to use the guix home service. there was talk on the xmpp server a while ago about trying to incorporate it as a system sheperd service but there were some difficulties... i cant remember what
<adanska>but running it on a user sheperd using guix home works fine
<adanska>just remember to add the dbus service to your home conf too.
<bdju>doesn't guix home involve declarative configs for user stuff? I currently manage my configs by hand and use a manifest for packages. don't really like the idea of messing with some whole new thing
<adanska>im not sure how to use it otherwise, but you can just keep the config completely minimal with just the pipewire service and home-dbus service
<adanska>you can integrate it as much or as little as you want
<adanska>but it is a 'whole new thing' as you said.
<adanska>are you running guix system?
<jonsger>why can I not delete the profile path of a `guix shell` which is no longer active (I have exited the shell): guix gc: Fehler: cannot delete path `/gnu/store/fjhb8sycwaasvfygw4m96aw5bqcpq1bl-profile' since it is still alive
<futurile>Morning all
<futurile>jonsger: can you use the 'references' switch to see what's causing - or is it 'referrers' - I always get those two confused
<jonsger>futurile: I think its `--referrers` but this only lists itself
<futurile>huh, weird - no idea how you debug beyond that
<ircenjoyer>Can I configure i3-wm within Guix using Guile?
<thanosapollo>ircenjoyer: I dont think so, but you could try dwl-guile
<ircenjoyer>Where can I look which applications I can configure using Guile, is there a option/module search?
<ircenjoyer>So I can't configure i3-wm via Guile?
<jmes>ircenjoyer: Usually configuring a program via Guile means using a service which wraps the configuration of the program. You can search for such services with `guix system search`
<jmes>AFAIK there is no such i3 service yet
<jmes>but you can install your i3 configuration files with Guile through Guix Home, for example
<ircenjoyer>I'm on NixOS, I don't have Guix installed yet; can I search for services from Web?
<ircenjoyer>I don't actually have a universal configuration file; everything is configured via NixLang.
<jmes>Well the source is all available here: https://git.savannah.gnu.org/cgit/guix.git/tree/gnu/services, you could download and grep it or maybe there's another way someone knows.
<peanuts>"services\gnu - guix.git - GNU Guix and GNU Guix System" https://git.savannah.gnu.org/cgit/guix.git/tree/gnu/services
<cbaines>there's also the docs which have a list of services
<jmes>ircenjoyer ^^ Thanks, cbaines
<jakef>sorry i missed that cbaines, is there an equivalent of guix edit for services?
<jmes>jakef `guix system edit <service name>`
<ircenjoyer>Thanks for all but seems like Guix doesen't have what I'm looking for.
<jmes>It sounds like you want an i3-service, but no one has written it yet. Check back again every once and a while, or you could try to write it yourself :)
<ircenjoyer>I actually want to configure ALL of my dotfiles via same language like in NixOS
<ircenjoyer>I like the Guile but Guix cant manage my Firefox, Neovim, i3, rofi, alacritty etc.. configuration at the same time
<jakef>jmes: so guix system edit cups-service-type is supposed to work?
<ircenjoyer>and I don't want to try to migrate
<jmes>jakef: try `guix system edit cups`
<jakef>oh gotcha, its the name field of the service
<jakef>thanks
<futurile>Q: does anyone have an example of call-with-container? dthompson mentioned it in his talk, but I can't find it
<jmes>ircenjoyer: Yup, that's totally possible. But it's just not as convenient as it could be in your case (yet). If you just want to write some sexps and get an i3 config file, you could implement that fairly quickly for yourself. But proper guix services are often doing more than just that.
<ircenjoyer>I actually don't know how to configure my programs in their native languages so I can't migrate/this will take so long. But I love the Guix&Guile.
<ircenjoyer>Why does GNU insist on linux-libre rather than using Linux?
<jakef>ircenjoyer: nix doesn't ultimately write a config file that the program understands?
<jakef>bit off topic but that's surprising
<ircenjoyer>It writes
<ircenjoyer>But it also grabs required plugins etc.. from Nixpkgs
<jmes>Yeah, that's what a guix service would do for you. Hopefully next time you check it'll be there :P
<ircenjoyer>Hopefully
<jmes>As for why linux-libre, I guess it's because it's Libre ;)
<ircenjoyer>But.. I don't think we have any modern hardware that supported by linux-libre or hurd.
<futurile>ircenjoyer: due to being a GNU project it doesn't distribute nonfree drivers, but you can use nonguix which contains drivers - nonguix is another 'channel' so your system sees the union of packages across both
<ircenjoyer>I don't think GNU follows the correct route to spread their software.
<futurile>ircenjoyer: fair enough - but that's a philosophical discussion - and they've been consistent in their opinion for 40 years or something. It's fairly standard for the free software focused distributions to put nonfree drivers in a different location - Debian/Ubuntu that I worked on before did the same.
<jmes>Everyone is welcome to their own opinion. I'm not a spokesperson. My opinion is that there is value in drawing the line clearly and holding the line. Perhaps the objective is not to spread GNU software fastest/furthest, but to offer the freest choice for those that want it.
<futurile>ircenjoyer: the channels concept in Guix gives a lot of flexibility - for example there's a specific science channel, and various users who have a focus on an application area run their own channels
<ircenjoyer>NixOS also have channels and different repos.
<ircenjoyer>Thanks for all helps and answers
<futurile>ircenjoyer: no worries - have fun
<ircenjoyer>I hope I can use the Guix in the future.
<mawumag>Can I use X-Debbugs-Cc as a pseudoheader (first line of the message body) instead of a header when sending patches? My setup unfortunately strips custom headers
<sturm>how do you download the source for a package again - sorry, I'm having trouble finding it in the manual
<ngz>sturm: guix build -S PACKAGE
<sturm>thanks ngz!
<futurile>mawumag: yes - it's a debbugs instance behind
<mawumag>futurile: thank you! I think the maintainers will be happier now :)
<futurile>mawumag: I packaged bts, which can work with the GNU debbugs just like Debian's - it's called debian-devscripts-bts
<futurile>mawumag: some example of using it are on this page https://libreplanet.org/wiki/Group:Guix/PatchReviewSessions2024
<peanuts>"Group:Guix/PatchReviewSessions2024 - LibrePlanet" https://libreplanet.org/wiki/Group:Guix/PatchReviewSessions2024
<mawumag>futurile: that looks great! I'll try to participate to the next meetup
<sturm>I'm working an a guix package and getting error "error: in phase 'ensure-no-mtimes-pre-1980': uncaught exception: system-error "utime" "~A" ("No such file or directory")"
<sturm>is there a better way to fix this than deleting the phase (as I see some packages do)
<sturm>oh, I think it's failing because due to a broken symlink
<sturm>in a git submodule
<oleander>Hello everyone, lately when I run `sudo guix system reconfigure myconfig.scm`, at the end of the procedure it gets stuck at
<oleander>"guix system: bootloader successfully installed on /(dev/sda)" and it does not go forward, I have to hit Ctrl+C to get back to the prompt. Do you have any idea why this happens?
<df0>does anyone have remote desktop working with gnome/wayland?
<apteryx>daviid: for your info, digging further into my linphone chat history issues, messages are not correctly saved in the database, but only my outgoing messages get shown (rendered) in the UI, although received ones are in the database.
<apteryx>I've opened an issue with upstream here: https://gitlab.linphone.org/BC/public/linphone-desktop/-/issues/36
<peanuts>"Chat history problem: only outgoing messages are shown in UI (incoming are in database but hidden) (#36) ? Issues ? BC / public / linphone-desktop ? GitLab" https://gitlab.linphone.org/BC/public/linphone-desktop/-/issues/36
<apteryx>ACTION tries to pinpoint where the selection of chat messages from the DB happens in the code
<apteryx>mawumag: GNU Debbugs support that yes (pseudo mail headers in the body)
<ieure>bbur
<ieure>fffff
<apteryx>it doesn't support concatenating multiple X-Debbugs-Cc though, so you'll want to ensure only one gets sent, otherwise I think the last one wins
<mawumag>thank you apteryx
<apteryx>ieure: does the 'read mode' works for you in Librewolf? For me it does nothing.
<apteryx>e.g. I was reading https://doc.qt.io/qtcreator/creator-breakpoints-view.html, then pressing Ctrl+Alt+R doesn't seem to do anything
<peanuts>"Setting Breakpoints | Qt Creator Manual" https://doc.qt.io/qtcreator/creator-breakpoints-view.html
<apteryx>works on other pages, so perhaps that page is too weird or something
<apteryx>ieure: nevermind, it works after restarting librewolf; it seems librewolf processes sometimes get killed by earlyoom due to my limited amount of memory (8 GiB) which results in erratic behavior until a restart
<ieure>apteryx, Bummer. :( Reader mode does work for me.
<Aarush>Can I use a wayland compositor like Hyprland work in guix?
<yelninei>speaking of librewolf: I am using gnome and librewolf windows have no icon. Do i need to configure something extra for this?
<ieure>yelninei, Hmmm, this was a problem when I was packaging, but I thought I'd fixed it.
<ieure>Maybe something regressed in one of the updates.
<ieure>yelninei, I'll take a look when I have some time, maybe over the weekend.
<yelninei>thanks :)
<WilhelmVonWeiner>Can I boot Guix into RAM so I can install it with only one disk? i.e. write Guix installation ISO to disk, boot and load Guix boot image into RAM, install Guix onto disk from RAMdisk-booted installer
<rekado>Googulator: ghc 0.26 isn't going to be useful
<rekado>I've tried bootstrapping from those versions
<rekado>I packaged Yale Haskell, too, but since a few years the package fails to compile (the build succeeds, but compilation actually failed)
<rekado>ghc 0.2 contains generated C, just like ghc 4, and it uses non-standard Haskell so it cannot be compiled with Hugs.
<rekado>I don't think it's worth going back to ancient versions of GHC.