IRC channel logs

2024-06-09.log

back to list of logs

<deedend>I can reach pretty much any website, but for some weird reason I cannot reach gnu.guix.org
<gyiwr>hi ! I'm trying to create a package for unicorn 2.0.1. I'm using a patch from 2023 to do that, but I've a problem : it doesn't find pyproject build-system, even if I import the module (build-system pyproject). do you have any idea about that ?
<chubbymomo>Hey, all! I just wanted to ask if anyone has an issue where, when reconfiguring guix, a particular shepherd service stops and disables itself? It works perfectly otherwise...
<wolfdog>deedend: gnu.guix.org? don't you mean guix.gnu.org?
<deedend>wolfdog: yes, I meant guix.gnu.org . Not working for me
<wolfdog>weird, I can ping it just fine
<deedend>wolfdog: where are you located?
<deedend>Maybe it's because I'm in Australia
<wolfdog>Chile here.
<wolfdog>Anyone knows how to stop GNOME from firing up its own SSH agent?
<wolfdog>got it, one needs to copy `/run/current-system/profile/etc/xdg/autostart/gnome-keyring-ssh.desktop` to `~/.config/autostart` and add a line `Hidden=true`
<roundduckkira>can you change the login manager from the default gdm to lightdm
<roundduckkira>it looks like I can but reading documentation there is this mate desktop service thing but then lightdm seems to be its own thing too
<roundduckkira>attempting leads to me getting unbound variable errors
<roundduckkira>I realize I can delete gdm in the config but idk how to do it right
<roundduckkira>I am confused
<roundduckkira> https://termbin.com/3maw here is my config file
<roundduckkira>i'll look over logs and be back tomorrow, pls answer if anyone can
<adanska>by the way roundduckkira you can just use the `specifications->packages` procedure and pass it a list of strings corresponding to packages
<adanska>you dont need to have all those procedures
<adanska>sneek: later tell rounddickkira: you can use the `modify-services` procedure like this: `(modify-services %desktop-services (delete gdm-service-type))` in the `services` field of your `operating-system` record. then, youd add the session manager of your choosing to your list of services.
<sneek>Okay.
<adanska>make sure to construct your services list using `cons*`, with all the services you want coming first and the `modify-services` form at the end
<adanska>is there a guile procedure that allows you to modify the build system arguments of a package?
<adanska>all of the package transformation procedures i can find seem to focus on input modification
<thanosapollo>is anyone able to build `guile-emacs`?
<jakef>not i thanosapollo
<jakef>guix 580d77d
<fnat>I'd like to configure an IPv6-only machine and let the device liaise with the router and self-assign an address. How would I do that? Do I still need to use some variation of 'static-networking-service-type'?
<efraim>hello guix! Does anyone have an OS config for a router? Or for using wifi and connecting without hooking up a screen and keyboard to enter the password?
<gyiwr>I'm coming back with my guix problem: I got Unbound variable: pyproject-build when I try to launch my manifest. I'm importing (guix build-system pyproject). I don't really understand what I'm missing ? maybe I must do a guix import or smth ?
<apteryx>efraim: I think wpa_supplicant could be used for that
<efraim>apteryx: I see the wpa-supplicant-configuration-config-file option, I suppose that would work. And then I obviously just wouldn't add that to the store
<FlaminWalrus>Is it considered a bug if I write a bad enough system config that guix will init without error but which Shepherd is unable to take to TTY?
<FlaminWalrus>s/init/return from =guix system init=
<FlaminWalrus>I set verbose kernel logging from GRUB; it seems that the kernel hands it off to Shepherd just fine (I'm getting PID1 printk's) but the last line of logs before it stops and doesn't listen to anything but SysRq's says "The following services could not be started in the background: <every single element of my =services= declaration>"
<FlaminWalrus>Normal hardware, rather normal configuration (trying some stuff out with guix-home-service-type, but no device-mappers or crazy base service modifications)
<mroh>FlaminWalrus: could be bug 71193, perhaps.
<peanuts>"Shepherd fails to start a system when given an incorrect form to the start field of any service" https://issues.guix.gnu.org/71193
<apteryx>efraim: reading a secret file from /etc or /root is a classic low-cost solution to "keeping secrets out of the store"
<FlaminWalrus>Thanks for the pointers mroh, peanuts. Long development cycle here (gotta =guix pull && guix system init= from the ISO on every test); I do worry that it seems the daemon is hanging at a later time than reported in that issue, going by the installer's dmesg. It's probably it though.
<peanuts>FlaminWalrus: Hi, for comments please contact my maintainers at https://codeberg.org/lechner/irc-helper-bot
<civodul>o/
<efraim>o/
<civodul>ACTION looks into the evaluation failure of the rebased ‘core-updates’
<efraim>I have an initial 'tune-for-multi-psabi' function, but I think with how glibc handles psABIs I can just reuse the tuned-package function entirely
<efraim>oh no, the -march option we have for C/C++ won't work with ppc64le
<efraim>oh, even better, clang might support -march for ppc64le but gcc doesn't
<ngz>I would like to retrieve the contents of a file using `svn cat', such as the following command `svn cat svn://www.tug.org/texlive/tags/texlive-2023.0/Master/tlpkg/texlive.tlpdb' and bind them to a string. I saw `pipe-command' function from "mdate-from-git.scm" module. Is is an appropriate way to proceed?
<efraim>that's a lot of lines
<efraim>I think I like call-with-output-string when doing things like that
<ngz>OK. Thanks. I think the call will need to be memoized too.
<efraim>with nearly 330k lines I think that would be a good idea :)
<ngz>Yup :)
<lykso>Can't seem to find a way to get the contents of a file-like object as a string. Any advice?
<freakingpenguin>lykso: plain-file supports that but I don't know if the others do before they get passed to the build daemon
<lykso>Ah, I'm using mixed-text-file because I need to interpolate store paths with strings
<lykso>I'm really only working with a file here because I can't figure out how to make a gexp work in the context I need it
<lykso>Trying to get a store path into the "configs" string argument passed to customize-linux.
<freakingpenguin>The defconfig argument supports file-like objects, would that work or would it overwrite too much in your case?
<lykso>I've already got a defconfig I'm using there and had been hoping there was a simple way to just use string interpolation or something, but yeah, I could probably just generate a new file on the fly with the two configs concatenated.
<lykso>Thanks!
<freakingpenguin>lykso: I think you could use gexps with configs if the following line was quasiquoted in customize-linux: (modify-defconfig guix_defconfig '#$configs)
<freakingpenguin>But since it's quoted I don't think you can evaluate the (file-append foo "/bar") at build time
<freakingpenguin>If putting store paths in guix_defconfig via configs should be supported maybe that's a bug.
<lykso>I dunno who decides or how "should" is decided, but it'd help me in the particular situation at least.
<lykso>TBH, a way to just interpolate store paths with strings and get a string out would be generally useful, as this is the second time I've had to do that kind of interpolation.
<freakingpenguin>If configs just took a gexp and left the quoting to the user I think it'd be possible. I don't fully understand how lowering a file-like into a store path works but as far as I can tell you need a connection with the build daemon to do it.
<lykso>Yeah, that'd solve my problem in this particular case at least.
<freakingpenguin>Out of curiousity what config option are you trying to set?
<lykso>CONFIG_EXTRA_FIRMWARE_DIR
<freakingpenguin>Ah, sounds like a bug to me then.
<unfroq>Hej Guix! I need an installation image for Guix in order to rescue my system in case of a bootloader error. My Guix spits some errors regarding grub-install... so I need a usb-image to make sure, I can recover.. But the iso images on the website are not downloadable. If I click latest build on the download page it refers me to
<unfroq> https://ci.guix.gnu.org/download/2053 which gives me a ""Could not find the requested build product.""
<unfroq>Could someone please have a look and fix this or point me to a recent build which I can download?
<freakingpenguin>unfroq: The dead download links was reported https://issues.guix.gnu.org/issue/71312. Not sure as to the cause, would the 1.4.0 release image suffice?
<peanuts>"Dead download links on guix.gnu.org/en/download/latest" https://issues.guix.gnu.org/issue/71312
<unfroq>Sorry, haven't checked the issues page. Did not think such an error would persist longer than a few hours.. 1.4.0 would be better than nothing, I guess. I go for that one then. Thanks!
<unfroq>But since I am here, does anyone have an idea, what might cause my grub issue that I receive while reconfiguring? /gnu/store/xxx...xyz-grub-efi-2.06/sbin/grub-install: error: cannot find a device for /boot/grub (is /dev mounted?).
<cmiller>Jun 9 19:53:15 localhost syslogd (GNU inetutils 2.3): restart
<cmiller>My system was idling and randomly restartet several times.
<cmiller>Anyone know why it received that command?
<cbaines>regarding core-updates, I did try running guix weather before pushing, and it did fail, but with a meaningless backtrace
<Someone16>Hello. Does anyone have an idea on why only Guix has has the Indian English Layout out of all of all the Gnu/Linux distros?
<Someone16>Is anyone here?
<PuercoPop>I'm trying to setup a guix shell file/package for a personal rust project. So far I have the following https://git.sr.ht/~puercopop/sisyphus/tree/default/item/guix.scm
<peanuts>"~puercopop/sisyphus (default): guix.scm - sourcehut git" https://git.sr.ht/~puercopop/sisyphus/tree/default/item/guix.scm
<PuercoPop>The problem is one of the crates, the rusqlite crate depends on having a CC to compile SQLite3. How do I add gcc to the dependencies?
<PuercoPop>cargo-inputs is only for rust crates iiuc
<unfroq>PuercoPop: Have a look at inputs and native-inputs https://guix.gnu.org/en/cookbook/en/guix-cookbook.html#Inputs and at rust-apps.scm https://git.savannah.gnu.org/cgit/guix.git/tree/gnu/packages/rust-apps.scm
<peanuts>"GNU Guix Cookbook" https://guix.gnu.org/en/cookbook/en/guix-cookbook.html#Inputs
<peanuts>"rust-apps.scm\packages\gnu - guix.git - GNU Guix and GNU Guix System" https://git.savannah.gnu.org/cgit/guix.git/tree/gnu/packages/rust-apps.scm
<cbaines>PuercoPop, you probably already have gcc, you might need to set CC=gcc though
<cbaines>Guix also has a package for rusqlite, so you shouldn't need to package it yourself
<podiki>on git pull for a guix checkout: guix git: error: unknown introductory commit and signer
<podiki>i'm guessing from it trying "guix git authenticate" and that's the message
<podiki>...so with the change to defaulting to "guix git authenticate" manual intervention is needed on existing guix checkouts? (specifying a commit and key to start from?)
<PuercoPop>cba the message
<PuercoPop>14:18 *** PotentialUser-84 JOIN
<PuercoPop>14:19 <podiki> ...so with the change to defaulting to "guix git authenticate"
<PuercoPop> manual intervention is needed on existing guix checkouts?
<PuercoPop> (specifying a commit and key to start from?)
<PuercoPop>14:22 *** PotentialUser-84 QUIT Client Quit
<PuercoPop>14:26 *** altomcat` JOIN
<PuercoPop>sorry for the spam I didn't realized I copied previous messages from the channel
<podiki> https://guix.gnu.org/en/manual/devel/en/html_node/Building-from-Git.htmlthe answer, of course, isin the manual:
<PuercoPop>cbaines: If I'm using another version of rusqlite in my cargo toml I can't use the packaged version of rusqlite for development right?
<cbaines>I don't know, I don't use cargo
<civodul>cbaines: hey! i briefly tried to investigate the post-rebase evaluation failure of ‘core-updates’ but didn’t go very far: https://ci.guix.gnu.org/eval/1389627
<civodul>any ideas?
<peanuts>"Evaluation" https://ci.guix.gnu.org/eval/1389627
<cbaines>civodul, the answer might be in the data service log https://data.qa.guix.gnu.org/revision/7dbf3753cc4dd2b6e6810252df2c146fcd5af757
<cbaines>but if it is, it's hidden under a mountain of existing errors
<civodul>heh
<civodul>ah! (misc-error #f unsupported openssl target kernel () #f)
<cbaines>it looks like the data service is going to succeed in processing the revision, but I think it has more error handling than cuirass
<civodul>looks like a déjà vu
<civodul>yeah, Cuirass is almost all-or-nothing
<civodul>wasn’t this openssl target thing fixed already?
<civodul>(like, several times, even? :-))
<cbaines>I sent some patches, but it's difficult
<civodul>oh right
<civodul>but even before that i think?
<civodul>there’s ‘%bare-platform-triplets’ in (gnu ci) for instance
<cbaines>the data service doesn't use (gnu ci), plus I still think it's a bug in guix if computing a derivation for a valid target causes a crash
<cbaines>which we have a lot of currently
<cbaines>civodul, I've found one needle in the haystack, computing the gnome-photos derivation for x86_64-linux seems to crash
<ekaitz>civodul: sent you some questions in the fediverse, maybe you prefer email or something else? anyway no pressure to answer or anything like that. It's not important neither urgent
<wolfdog>is there any way to build grub-efi-netboot-removable-bootloader for aarch64-linux in a non-ARM machine? or will i need to get a VM running Guix for it :<
<wolfdog>ARM VM running Guix*
<juli>wolfdog: in fact, there is! 'guix build --system=aarch64-linux'
<juli>the setup instructions associated with point 6 at https://guix.gnu.org/en/manual/devel/en/html_node/Submitting-Patches.html should make that work
<peanuts>"Submitting Patches (GNU Guix Reference Manual)" https://guix.gnu.org/en/manual/devel/en/html_node/Submitting-Patches.html
<wolfdog>so if I'm doing `guix system image os.scm --system=aarch64-linux` i'd only need to add that service to my system for it to work?
<wolfdog>I'll give it a try now, thanks for the pointer :-)
<wolfdog>(i realize i should've given that context of trying to make an image for an SBC earlier, sorry :S)
<juli>I'm not sure exactly which commands accept the `--system` flag, but you can certainly try it :)
<juli>if that doesn't work, you may be able to use the `--target` command which cross-compiles
<juli>`--system` uses qemu-binfmt (as you probably gathered from that link)
<cbaines>civodul, I've figured out the problem with gnome-photos, git-minimal was named git which led to there being #f in disallowed-references, which causes Guix to crash