IRC channel logs

2024-06-05.log

back to list of logs

<tacocatgirl>does anyone know if it's possible to install the shepherd package without the reboot command? I'm using guix home on a foreign distro, when I try to use the home shepherd services it adds a reboot command that overrides the default one which doesn't work since shepherd isnt running as an init system.
<viaken>tacocatgirl: This isn't what you asked for, but when I had that problem, I put the host /sbin higher in my PATH.
<dmirth>Hi, just having a stupid config question: with a statement like the following: #:use-module (guix gexp)
<dmirth>I'm assuming the '#' is not a comment and where would I go to find out what the guix and gexp modules encompassed?
<jakef> https://git.savannah.gnu.org/cgit/guix.git/tree/guix/gexp.scm
<peanuts>"gexp.scm\guix - guix.git - GNU Guix and GNU Guix System" https://git.savannah.gnu.org/cgit/guix.git/tree/guix/gexp.scm
<dmirth>Thanks "jakef" and "peanuts"
<peanuts>dmirth: Hi, for comments please contact my maintainers at https://codeberg.org/lechner/irc-helper-bot
<dmirth>I guess for a question that simple, a bot would probably work
<dmirth>It just wasn't for me
<jakef>sorry dmirth, peanuts is a bot but i'm not
<peanuts>jakef: Hi, for comments please contact my maintainers at https://codeberg.org/lechner/irc-helper-bot
<dmirth>Oh, ok
<dmirth>jakef: then why after a define module do all use-module lines begin with a '#'?
<Googulator># is not a comment sign in Scheme
<dmirth>Oh, ok
<dmirth>Need to learn more Scheme
<PotentialUser-96>Hello everyone, someone knows where can I download pkg binaries?
<jfred>Hmm... so I have a guix checkout at ~/src/guix, but when I enable guix-devel-mode in e.g. (gnu machines digital-ocean) and press "C-c . u", I get this error in *Messages*: https://paste.debian.net/1319218/
<peanuts>"debian Pastezone" https://paste.debian.net/1319218
<jfred>It looks like something somewhere isn't able to deal with gexps. Any thoughts on what I might be missing?
<jfred>geiser-guile-load-path is ("~/src/guix")
<PotentialUser-96>Someone knows where could I download the full source code of the GNU Guix System?
<PotentialUser-96>I tried in the official web but it is incomplete.
<ieure>PotentialUser-96, What specifically are you looking at which is incomplete?
<PotentialUser-96>I download the version 1.3.0 binary iso (size 250 MB) and source (size 39 MB)
<ieure>What do you believe those are missing?
<PotentialUser-96>I just found the source code for guix package management but the system is missing.
<ieure>I believe the source tarball is built directly out of the Guix git repository, which has all the Guix source code, including Guix System: https://git.savannah.gnu.org/cgit/guix.git/
<peanuts>"guix.git - GNU Guix and GNU Guix System" https://git.savannah.gnu.org/cgit/guix.git
<ieure>PotentialUser-96, That contains the source code for Guix System. I suspect you're confusing that with "the source code of the packages which Guix System can install."
<ieure>I do not believe there is a single location where you can download the source code for every package in Guix.
<PotentialUser-96>ieure: Thank you let me check.
<ieure>If you can give a specific example of something which you believe the source is missing for, that will help.
<PotentialUser-96>ieure: Brief review I do not see a tar.gz file for guix system just guix management
<ieure>PotentialUser-96, Guix System is included in the Guix Git repo. Here's part of it: https://git.savannah.gnu.org/cgit/guix.git/tree/gnu/system.scm
<peanuts>"system.scm\gnu - guix.git - GNU Guix and GNU Guix System" https://git.savannah.gnu.org/cgit/guix.git/tree/gnu/system.scm
<ieure>Many of the files in there are Guix System source code.
<ieure>Is that what you're looking for?
<PotentialUser-96>ieure: No I was looking for a tar.gz file with the source code of Guix System e.g coreutils, grep, etc. include into a file system.tar.gz
<PotentialUser-96>is something similar in guix?
<ieure>PotentialUser-96, Right, so this is what I was saying before. Those are not "Guix System." Those are the source to packages which can be installed by Guix (whether it's running under Guix System or some other distribution). As I said -- I do not believe there is a single place where you can obtain all that source code in one go.
<PotentialUser-96>I do not want to use git to download the source code.
<ieure>PotentialUser-96, If you want to obtain the source to some set of packages, you can run `guix build -S package-a package-b ...', and it will print their locations.
<ieure>The various %base-packages constants in that system.scm I listed above are the default set of packages for a Guix System installation -- though obviously the specific packages installed varies from system to system.
<PotentialUser-96>ieure: I had read the Guix Manual, I just want to install some package without to use internet. Just download a binary and install it.
<ieure>PotentialUser-96, As far as I know, the only way to accomplish that is to use `guix archive --export' on some Internet-connected machine running Guix (this includes the Guix package on foreign distributions, it doesn't have to be Guix System) and sneakernet that to your airgapped box to `guix archive --import'.
<PotentialUser-96>something like this guix package install-binary.pkg
<ieure>I do not believe that is possible.
<ieure>The only notion of a prebuilt binary package in Guix is a substitute, and you cannot install them directly.
<PotentialUser-96>ieure: Do you know why we cannot install them directly?
<ieure>PotentialUser-96, Because Guix is fundamentally a from-source distribution which fetches things over the internet, and does not have any notion of directly-installable binary packages.
<PotentialUser-96>ieure: I really appreciate your valuable time to answer my questions. Thank you so much.
<ieure>PotentialUser-96, No problem, sorry the answers weren't what you were looking for.
<daviwil>fnat: thanks for pointing out the patch! I ran into this issue yesterday
<daviwil>I will give it a try later when I sit down at my computer
<daviwil>I sent an email to Giacomo about it yesterday, he responded back with some suggestions but I haven't had time to read them in detail yet
<meaty>how do I package a repo whose installation instructions are just "install dependencies, run ./cmake/install.sh as root"
<meaty>oh wait
<meaty>the install.sh is here https://git.dec05eba.com/sibs/tree/cmake/install.sh
<peanuts>"install.sh ? cmake - sibs - A simple build system for native languages. Supports c, c++ and zig. Inspired by cargo (rust)." https://git.dec05eba.com/sibs/tree/cmake/install.sh
<meaty>how can I turn this into the right build-phases expression
<meaty>obvs bin_dir needs to be configured, other than that does someone more knowledgeable recognize what is being done here
<AwesomeAdam54321>meaty: The install.sh looks like it's just a convenience wrapper script for invoking the CMake build system
<AwesomeAdam54321>Do you plan on reimplementing install.sh as the `build` phase or just fixing the script?
<civodul>any opensmtpd person here?
<civodul>the last update (in November) broke the test: https://ci.guix.gnu.org/build/2355499/details
<peanuts>"Build 2355499" https://ci.guix.gnu.org/build/2355499/details
<civodul>ACTION looks at the red dots at https://ci.guix.gnu.org/eval/latest/dashboard?spec=tests
<fnat>Thanks daviwil (as a matter of fact, I got to know about the OCI service thanks to your newsletter in the first place! :)).
<civodul>hey there!
<civodul>ci.guix is starting to have quite a lot of substitutes, at least for x86_64-linux
<civodul>for ‘core-updates’ i mean
<civodul>now’s the time to test & fix!
<civodul>(at last :-))
<efraim>We have to figure out what to do with mesa for aarch64, since it needs libclc now
<efraim>Easy option is to just add it, but that causes lots of compiler builds
<efraim> https://bpa.st/FTTQ
<peanuts>"View paste FTTQ" https://bpa.st/FTTQ
<efraim>I wasn't able to build clang using llvm-for-mesa, but packaging versions using llvm-15 was possible
<efraim>basically libclc-15 for mesa, which I gave spirv-llvm-translator-15, which I gave an earlier version of spirv-headers and python-lit
<daviwil>fnat: That's awesome!
<jpoiret>efraim: by "causes a lot of compiler builds" do you mean it's a big rebuild for all archs?
<efraim>jpoiret: spirv-llvm-translator and python-lit depend on llvm-18 and llvm-17, which in turn depend on gcc-13 and gcc-12. all so that libclc can have spirv-llvm-translator
<efraim>also I'm pretty sure I found that mesa needs libclc to be the same version as the llvm it uses
<jpoiret>is that due to a mesa change?
<efraim>only on aarch64, in order to build the asahi driver
<Aarush>Hello. After clicking the download link for the latest guix, I get :"{"error":"Could not find the requested build product."}"
<efraim>in theory there are other bits of mesa which would benefit from having libclc as an input, and there's also mesa-opencl
<andreas-e>Aarush: This is a known and admittedly annoying problem. You can instead use Guix 0.4 for installation, and then do a "guix pull". The end result will be the same. We still have substitutes for an old Guix, I just went this route a few days ago.
<Aarush>Hello. The download link for the latest Gnu Guix iso is not working; It is displaying "{"error":"Could not find the requested build product."}".
<Aarush>Please help.
<Aarush>exit
<andreas-e>Aarush: Please see my previous answer to your question - just use Guix 1.4.0.
<avalenn>is guix.info related to some people here ?
<andreas-e>avalenn: guix.info is owned by Guix Foundation. Why?
<Aarush>is there a way to install the latest Gnome 46 in Gnu Guix instead of Gnome 44?
<andreas-e>Many of the xxx.guix.info are just the same DNS entries as the corresponding xxx.guix.gnu.org
<andreas-e>foundation.guix.info is a separate website not on anything guix.gnu.org, as well as a few other websites.
<avalenn>TLS certificates are not up-to-date, big warning on browsers
<andreas-e>Ah, annoying. Which site exactly? They should be updated automatically, but maybe there is a bug in this service.
<avalenn>for issues.guix.info
<avalenn>not looked at others
<andreas-e>Okay, thanks for the info! You can use issues.guix.gnu.org instead.
<efraim>civodul: sjd-p9 (ppc64le system) doesn't seem to have built any packages since you reconfigured berlin
<andreas-e>efraim, civodul: I can ssh into it, and see the following warning in the logs: "low on disk space, doing nothing"
<andreas-e>Only 5GB free in /gnu, I will run a soft "guix gc -F 10G".
<andreas-e>Do we not have a cron job for this?
<efraim>is that 10.0.0.7?
<andreas-e>No, 10.0.0.13.
<efraim>ah, that was my next guess
<andreas-e>Otherwise, the build farm looks really good, lots of hydra-guix working!
<efraim>I see it started working
<efraim>10.0.0.7 is the one I can't get into from berlin
<efraim>I actually have a script I run from berlin to ssh into all the machines and make sure there's some free space
<andreas-e>I will do some more aggressive gc now.
<efraim>wait, 10.0.0.7 is guixp9, I have direct access to that machine
<efraim>looks like libfaketime FTBFS on core-updates on armhf also
<andreas-e>Do we not have a cronjob on the hydra-guix-xxx machines? Those run the GNU system, while sjd-p9 does not.
<andreas-e>14000 packages depend on libfaketime :(
<efraim>I bet whatever fixes it on i686 will fix it on armhf also
<civodul>andreas-e: oh great that you’re looking into sjd-p9!
<civodul>i see that it’s building again, neat
<civodul>i can log in but i’m not a sudoer it seems
<civodul>ci.guix is building lotta stuff for haskell-team and gnome-team
<andreas-e>Is that an old haskell-team branch? Since it is not even scheduled for a merge. gnome-team should be next.
<ngz>Aaah, I see TeX Live packages being built, too
<ngz>Nice.
<ngz>(but it's on C-U…)
<civodul>hmm “file name component is not a directory "/var/run/dbus"”
<civodul>does that ring a bell?
<civodul>/etc/guix/machines.scm had disappeared again on build machines with childhurds
<civodul>turns out this was fixed in https://issues.guix.gnu.org/69401 but never redeployed
<civodul>ACTION runs “guix deploy berlin-nodes.scm”…
<peanuts>"/etc/guix/machines.scm symlink can be garbage collected" https://issues.guix.gnu.org/69401
<polyedre>Hey @efraim, I saw on your dotfiles that you were able to use dbxfs in your home configuration. I tried it too but I struggle because my current user does not have the permission to use `mount`. Do you remember what you did to let your user mount a remote folder use dbxfs?
<Franciman>my user is in the netdev group, but i can't activate or modify connections in nmcli without running sudo
<Franciman>is this expected?
<polyedre>I personally use sudo with nmtui, but I would like to be able to use my user
<meaty>is there a way to browse the documentation of all packages in the store
<meaty>or browse the documentation from the "perspective" of a certain package
<meaty>e.g. I want to browse the cmake and readline docs without messing with my profile
<yelninei>meaty: Does guix shell work? If i use "guix shell texinfo readline" i then can browse info pages for readline
<meaty>you're right, good thinking
<meaty>i forgot to try including man-db/info in the shell command :P
<cancername>Hi! I've previously been using dnss to proxy plain DNS to DoH, but on Guix, searching for "dns over https" and "doh" doesn't seem to give any results. What's the currently recommended method to do that on Guix?
<zyd>When installing Guix on a foreign distro, it removes the dir file (well, overrides by placing a symlink) in /usr/local/share/info, meaning if you had info manuals in there you won't see them until you rebuild the dir file manually. I want to try to fix this, am I looking at the right place? https://0x0.st/XqRB.png
<zyd>Highly suspect the procedure `delete-info-dir-file'
<JetpackJackson>Hmm, I've just noticed that on one machine, my ~/.config/guix/current symlink is broken, but the other machine's link is fine. What could've possibly caused this? (These are foreign distros)
<Chubbymomo>Hello, I am trying to utilize the oci-container-service-type to manage containers in Guix and running into issues. Below is the relevant portion of my config.scm:
<Chubbymomo>(service oci-container-service-type
<Chubbymomo>(list
<Chubbymomo>(oci-container-configuration
<Chubbymomo>(image "pihole/pihole:latest")
<Chubbymomo>(provision "pihole")
<Chubbymomo>(network "host")
<JetpackJackson>Chubbymomo: use paste.debian.net to send files
<Chubbymomo>Thank you, sorry for plaguing the chat with that one...
<JetpackJackson>Its ok it only sent a few lines
<JetpackJackson>It happened to me too when I first joined lol
<Chubbymomo>Lol
<Chubbymomo>Okay, now for the question:
<Chubbymomo>I am trying to utilize the oci-container-service-type to manage containers in Guix and running into issues. Below is the relevant portion of my config.scm and a log:
<Chubbymomo> http://paste.debian.net/1319317/
<Chubbymomo>I also tried the example config given in the devel Guix manual, however that yielded the same results. Any help would be greatly appreciated.
<peanuts>"debian Pastezone" http://paste.debian.net/1319317
<fnat>Hi Chubbymomo, I think that's a known issue, see https://lists.gnu.org/archive/html/guix-patches/2024-05/msg01756.html .
<peanuts>"[bug#71254] [PATCH] services: oci-container: fix provided image is strin" https://lists.gnu.org/archive/html/guix-patches/2024-05/msg01756.html
<fnat>The patch still needs to be reviewed by a committer and merged.
<Chubbymomo>fnat, thank you! I guess my search engine techniques and some six hours of time didn't manage to find that...
<fnat>I tested it and it seems to be working fine, at least in the context of fixing the 'struct-vtable' issue.
<JetpackJackson>ah i fixed my broken symlink, had to run guix pull as well as sudo -i guix pull lol
<Chubbymomo>Great, if it wouldn't bother your too much, how would I merge the patch? I have some idea but it's been a bit since I've used a patchfile.
<fnat>Chubbymomo: I think it took me a while to find it too.
<fnat>Chubbymomo: one way to go about it is to clone the Guix repository, apply the change (you can do it manually by editing the relevant file), then build Guix, finally you use this new version of Guix. We can go through some of these steps together if you like.
<Chubbymomo>I think I can manage it from here, I'll message you if I need help. Thank you!
<fnat>Np, yw!
<civodul>apteryx: hey! in the mandb hook on ‘core-updates’, i see things like: “In procedure open-file: Too many open files: "/gnu/store/2rn2mlfzns9jrfcmwwj2wk8m2iy38yxj-util-linux-with-udev-2.37.4/share/man/man1/lastb.1.zst"”
<civodul>does that ring a bell?
<civodul>in other news, “make check-system TESTS="basic openssh"” passes on core-updates
<cancername>"moreutils" and "parallel" both provide a binary named "parallel". can I somehow select which one I'd like to have in my path?
<cancername>(other than installing moreutils first and parallel second)
<wigust>Hi. When you ssh into a Guix system, does your terminal display the remote hostname of a Guix system in the title bar?
<raghavgururajan>Hello Guix!
<raghavgururajan>In `.guix-authorizations` file of channels, are we using fingerprint of keygrip of keys?
<raghavgururajan>s/of/or
<eikcaz>One thing that has confused me about the contributing section of the guix manual: which steps need to be rerun after a git pull?  Do I need to bootstrap and configure each time, or should just a 'make' do?
<raghavgururajan>Currently, my channel has my primary key mentioned in `.guix-authorizations`, which I've been using for signing. Now, I'm gonna create new subkey and use that for signing. Do I have to change the fingerprint/keygrip in `.guix-authorizations`?
<eikcaz>Alright, this time make and configure failed, so I'll take that to mean I need to do all steps for each pull
<raghavgururajan>I presumed I didn't have to change anything in `.guix-authorizations` and only update publickey in keyring, since the reference in `.guix-authorizations` is primary it'd also include the subkeys.
<PotentialUser49>hello, I just discovered the npm-binary importer. Are packages generated from this importer being kept separate from the other node packages such that it's easy to determine what is truly being built from source?