IRC channel logs

2024-06-03.log

back to list of logs

<JetpackJackson>i like the names lol, what do the workers do exactly?
<JetpackJackson>package builds?
<civodul>yes, package builds
<JetpackJackson>oh nice
<Googulator>ouch... https://issues.guix.gnu.org/56584
<peanuts>"vala build uses bundled bootstrap binaries" https://issues.guix.gnu.org/56584
<Googulator>seems like Haskell and OCaml aren't the only languages used in Guix without being bootstrapped - and this one even gets built as part of an installer build
<meaty>how can I package a repo that has a src directory deeper than the root dir
<meaty>like the structure is /projectroot/projectname/src
<meaty>all you'd do when building manually is a single 'cd' command first but here it is a mystery
<apteryx>ieure: same! :-)
<apteryx>rekado: oh wow, the burger menu button on cuirass is fixed!
<apteryx>I think this is thanks to your recent work -- thank you
<elevenkb`>Hi there people, so I'm using librewolf and I want Guix to manage the passff extension for it. How might I do that?
<meaty>I suspect the answer is in (origin) somewhere, perhaps a snippet? But the documentation can be so obtuse...
<meaty>Is there a variable/function for "this is the new package root"
<apteryx>meaty: #:phases #~(modify-phases %standard-phases (add-after 'unpack 'chdir (lambda _ (chdir "projectname/src"))
<meaty>works! thx! :)
<meaty>now to work on the next error...
<meaty>this has all been exposure therapy for my phobia of learning build systems
<apteryx>makx: welcome!
<cancername>hi! I'd like to use a Linux kernel from a custom repo, but I'm a bit confused by the source definition. how can I calculate the hash to define the source for make-linux-libre?
<Googulator>Is guile-fibers known to randomly lock up while running its testsuite (on tests that normally take no measurable time)?
<Googulator>specifically guile-fibers-1.1.1
<Googulator>I had to cancel and rerun its build several times until it didn't lock up in both i686-linux and x86_64-linux modes
<Googulator>just trying to figure out if this is a problem with my bootstrap environment or Guix itself
<PotentialUser-67>hello everyone, someone could help me to give instructions to get guix package binaries e.g repository?
<bdju>all my sound broke after killing a misbehaving program. is there a herd service I should restart or something? I already tried pulseaudio -k with no luck
<bdju>nothing is able to connect to pulse even though it appears to be running in htop
<bdju>I wonder if this actually broke a long time ago and I just had an old service still running...
<bdju>current plan is to run updates and possibly reboot after. but I have 275 days uptime so I fear I will run into issues. like the time I couldn't decrypt my LUKS drive. or the time someone broke swaylock. if that doesn't fix my sound, I dunno what I'll do. maybe roll back a bunch of generations
<efraim>Googulator: some of the tests for guile-fibers take so long that I've disabled some of the tests on some architectures. I don't recall it locking up though, just taking hours
<indigo-oce>Is there a way to see the config.scm used for my current system configuration? I'm failing to build one and I'm not sure how it looked when it worked.
<efraim>indigo-oce: try /run/current-system/configuration.scm
<indigo-oce>Thanks!
<civodul>Hello Guix!
<civodul>ci.guix is working hard, but there are still 492k queued builds
<civodul>that’s ~6 days assuming it completes one build per second
<civodul>but there’s “only” 106k x86_64 builds
<Googulator>Is there any way to force the installer (when booted from an ISO) to effectively run with --no-substitutes?
<efraim>I suppose you could stop the daemon service and restart it manually with --no-substitutes
<Googulator>how do I pass --no-substitutes using shepherd?
<efraim>I mean run 'sudo guix-daemon ... --no-substitutes' from a different tty
<Googulator>efraim: doesn't work, as the installer just starts its own guix-daemon with substitutes enabled :(
<Googulator>I guess I would need to update the configuration of the shepherd service itself, but I can't find any documentation on where to look for the service configuration
<efraim>Looks like you'd need to change the guix-service in %installation-services in (gnu system install), the easiest would be to change (authorize-key? #t) to (authorize-key? #f)
<Googulator>Where is that?
<Googulator>As in the file system
<efraim>oh, there's also a use-substitutes? keyword
<efraim>I mean for when building an install image
<Googulator>you mean, it can only be done at image creation time?
<efraim>looking at the installation image config it looks like the guix-daemon should be started at boot, so you should be able to stop it and run it from a different tty
<Googulator>I tried that - the installer restarts the service anyway
<Googulator>if I manually stop it
<Googulator>as soon as I approve the configuration, I end up with 2 guix daemons running, one with substitutes enabled, the other disabled
<Googulator>the one with substitutes enabled "wins", and it begins downloading binary packages :(
<Isaz>Ever since I split my config into modules, I get vague errors such as "no code for module (modules base)"... It is always due to a bug in the module causing it not to load, rather than the module being missing. Is there a reason why it might be reporting incorrect errors?
<bdju>sound issue appears to be pulseaudio becoming a zombie. so guess a reboot will be necessary after all
<bdju>my sudo shutdown failed, had to hold in the button. saw this screen full of gibberish. https://litter.catbox.moe/pshd2e.jpg
<Isaz>:(
<bdju>has anyone ever tried to package duckstation? is there a reason it's not packaged? since there are worse ps1 emulators packaged already
<bdju>and I hope the yt-dlp package gets updated soon
<Altadil>bdju: I guess the reason is just emulators often being difficult to package (and maybe not many Guix users interested). But if you can do it, we’ll be at least two happy about it. :)
<Googulator>Posting here as well: https://gist.github.com/Googulator/338cce370b2e2a65f23e4f6a5b5c3881 describes a successful bootstrap of Guix on top of a live-bootstrap bare metal environment, culminating in a working, bootable Guix installer ISO, with the sole bootstrap binaries being Guix's bootstrap-guile & helpers, the stage0 bootstrap seeds, and
<Googulator>builder-hex0's 192 byte MBR.
<peanuts>"guix-bootstrap-build.sh ? GitHub" https://gist.github.com/Googulator/338cce370b2e2a65f23e4f6a5b5c3881
<Googulator>Most importantly - no kernel!
<Googulator>(a kernel does get built, but it's all from source, no precompiled one)
<Googulator>The ISO creation has a weird issue where db.sqlite ends up in /usr/var/guix/db instead of /var/guix/db, probably because Guix is installed into /usr in the bootstrap environment - this can be worked around by symlinking it to the intended location before running installation.
<efraim>would using DESTDIR help?
<Googulator>where would I specify DESTDIR?
<efraim>DESTDIR=/usr PREFIX=/ sudo make install, or something like that
<Googulator>for installing Guix itself?
<Googulator>The problem is that this is a merged-usr system, so /var and /usr/var are actually the same directory
<efraim>I thought I used PREFIX and DESTDIR with stow when I built guix and dependencies by hand for powerpc-linux but it looks like I didn't
<efraim>looks like I ended up with 'sudo make install prefix=/usr/local/stow/guile-zlib-0.1.0'
<efraim>but if /var and /usr/var are the same then I guess it shouldn't matter
<Googulator> /usr/var gets searched first, so Guix replicates that path for the DB file inside the ISO - everything else ends up in /var/guix, except for the DB
<Googulator>Anyway, the ISO is usable, and can be used to build a proper one with the DB in the right place, so I consider this successful already.
<jpoiret>Googulator: have you configured guix with --sysconfdir=/etc?
<jpoiret>and --localstatedir=/var>
<jpoiret>s/>//
<civodul>picnoir, efraim: there’s this rust-nix failure: https://ci.guix.gnu.org/build/4789911/log
<peanuts>"Build log of build #4789911" https://ci.guix.gnu.org/build/4789911/log
<civodul>i’m not sure what to do about it since nsncd actually builds fine
<civodul>same with rust-dns-lookup: https://ci.guix.gnu.org/build/4789914/log
<peanuts>"Build log of build #4789914" https://ci.guix.gnu.org/build/4789914/log
<picnoir>ack for the rust-nix issue. I can't have a look at it rn, but I'll do this EU evening.
<picnoir>Not 100% sure about what's happening. From the distance, looks like a rust-libc compatiblity issue.
<ngz>It reminds me there was a recent proposal about Rust package. I wonder if there's really a good reason for Guix to try building every intermediate Rust package, considering how Cargo handles inputs. We might be wasting CPU cycles and human energy.
<wolfdog>having a small problem with setting up xfce with lightdm (since i cant seem to make screen locking work under gdm), I've added the xfce and lightdm services and removed gdm from the desktop services, but after a reboot lightdm fails to start and i just get a blank TTY
<wolfdog>any ideas of what could be happening?
<wolfdog>running lightdm like `lightdm --test-mode -d` outputs this https://paste.sr.ht/~coyotes/675eabb960d247df7f3884237a91a7862397aa49
<peanuts>"lightdm.log ? paste.sr.ht" https://paste.sr.ht/~coyotes/675eabb960d247df7f3884237a91a7862397aa49
<wolfdog>i just gave up and configured XFCE to use xlock :P
<civodul>there’s https://ci.guix.gnu.org/jobset/rust-branch
<civodul>is this jobset still releavant, efraim?
<peanuts>"rust-branch" https://ci.guix.gnu.org/jobset/rust-branch
<civodul>i see ci.guix building stuff from May 24th :-)
<JetpackJackson_2>hi guys, its me, JetpackJackson (on the other laptop). re: texlive doc files, i tried manually specifying the outputs but it didnt work: https://paste.debian.net/1319000/
<peanuts>"debian Pastezone" https://paste.debian.net/1319000
<JetpackJackson_2>not sure why its not working since the package definition shows two outputs: doc for docs, and out for everything else
<ngz>JetpackJackson_2: what didn't work?
<JetpackJackson_2>it downloaded the docs and the package, instead of just the package
<JetpackJackson_2>some of the texlive docs are big so i dont want to download them
<JetpackJackson_2>oh how'd i join twice
<JetpackJackson_2>oops
<ngz>Ah yes. I don't understand the problem either.
<ngz>Something eludes me in the output handling.
<JetpackJackson_2>darn that sucks
<JetpackJackson_2>this is strange, if i specify "texlive-foo:doc", it installs the doc and the package as well...
<ngz>Hmm, is it specific to texlive packages?
<JetpackJackson_2>not sure, lemme test
<JetpackJackson_2>im trying to think of a package i dont have installed that would have a small -doc package lol
<ngz>JetpackJackson_2: liblouis maybe
<ngz>4 outputs, no fancy input.
<JetpackJackson_2>alright thanks
<JetpackJackson_2>it downloaded all outputs even when i specified liblouis:doc
<JetpackJackson_2>so not just texlive
<JetpackJackson_2>is it my install specifically?
<ngz>No, I don't think so.
<ngz>It i be r
<ngz>oops
<ngz>It might be related to grafts. I read something about it not so long ago. But clearly, this is above my pay grade.
<JetpackJackson_2>thats fair, ill look into grafts then
<JetpackJackson_2>thank you for your help
<ngz>I'd love to fix this too.
<JetpackJackson_2>im going to try with the --no-grafts option
<JetpackJackson_2>i think that mightve worked?
<JetpackJackson_2>lemme test with another package to be safe
<JetpackJackson_2>ok i think --no-grafts made it work
<JetpackJackson_2>im going to check texlive again
<ngz>OK
<JetpackJackson_2>bingo
<JetpackJackson_2>that works
<JetpackJackson_2>thank you so much
<ngz>Well, unfortunately, the underlying issue is not fixed =/
<JetpackJackson_2>true
<ngz>See for example <https://issues.guix.gnu.org/69653>
<peanuts>"grafts require all outputs (e.g. large debug symbols) to be downloaded to operate" https://issues.guix.gnu.org/69653
<JetpackJackson_2>ah gotcha
<JetpackJackson_2>i suppose for now i can just use --no-grafts with texlive stuff but use grafts for everything else
<ngz>I suppose so, too.
<JetpackJackson_2>alright i gtg for now, thanks again
<apteryx>I can't seem to mount cdrom with gio or nautilus
<apteryx>I've seen it work once by rebooting with the cdrom in the drive, which sounds a lot like https://bugs.archlinux.org/task/54644
<apteryx>so I've updated libblockdev to latest, along udisks, but still face the same issue
<apteryx>I'm not thinking the gvfs service is lacking some extension modules
<Abhishek>Hi, I wanted to discuss about the user data privacy problem, i.e. the user data that sits on third party servers which have no transparency around the services they provide and what they do with the data. I'm working on a solution for this where the mail goal is to eliminate the third party services.
<meaty>is there a fast way to locate the store dir of an installed package
<meaty>I have beein using 'find /gnu/store ...' but it sucks
<meaty>and guix locate does not work a lot of the time
<Abhishek>Thanks :)
<meaty>sassy
<ieure>Solving the problem of user data on third-party servers by [checks notes] writing messages about it and sending them to third-party servers.
<ngz>meaty: guix build the-package?
<meaty>does that not rebuild the package and waste store space?
<ngz>If it is installed, it will not be rebuilt.
<meaty>aha
<meaty>ok, it has become curiouser
<meaty>my 'texdoc' command doesn't run, kpse reports a missing "texdoclib"
<meaty>guix searches yield no mention, however
<ngz>meaty: what happens if you run, e.g., `guix shell texlive-bin texlive-texdoc texlive-onedown:doc -- texdoc onedown'
<apteryx>civodul: did I tell you that 'guix locate' is already useful? :-)
<apteryx>meaty: 'guix locate' has data limited to what you have in your profile/store. eventually it'll be able to fetch databases produced by the build farm; that's the plan
<meaty>ngz: seems to work that time
<meaty>maybe it just needs a reboot? or am i doing something wrong...
<meaty>aha, i had not been paying attention to the "consider setting the necessary environment variables" hint
<JetpackJackson>anyone know anything about the ruby build system? trying to get neocities to work but the build fails for one of the deps: https://paste.debian.net/1319045/
<peanuts>"debian Pastezone" https://paste.debian.net/1319045
<wolfdog>you'll want to disable the check phase (https://guix.gnu.org/manual/en/html_node/Build-Phases.html)
<wolfdog>since the package does not seem to have tests
<peanuts>"Build Phases (GNU Guix Reference Manual)" https://guix.gnu.org/manual/en/html_node/Build-Phases.html
<wolfdog>is issues.guix.gnu.org down? it's giving me 502 errors
<eikcaz>I asked on the Purism forums, but maybe this is better. Has anyone gotten Guix to run on a Librem Mini v2?
<eikcaz>I had a lot of luck with the V1, so I'm surprised the V2 is gaving me so much trouble
<eikcaz>wolfdog: it's not loading for me either
<wolfdog>I
<wolfdog>oops, pressed enter
<wolfdog>I keep struggling getting XFCE to lock my screen successfully. Telling it to use xlock or slock leads to weird behavior when the lid is closed (screen is locked, but display isn't blanked), using xscreensaver works but only shows "Don't log in as root" instead of blanking the screen
<wolfdog>and xfce4-screensaver does not work, saying "Failed to get session bus: Cannot spawn a message bus when AT_SECURE is set"
<wolfdog>does anyone use XFCE in Guix System and have any pointers?