IRC channel logs

2024-05-11.log

back to list of logs

<lykso>RavenJoad: Thanks!
<lykso>The problem is that I can't ungexp mnt-reform-debian-packages, as it then complains about that variable being unbound
<Tadhgmister>where do I look for logs for user space shepherd processes?
<bigbookofbug>is there a way to modify the .guix-home directory through home configuration? i am attmepting to input an org.Freedesktop.Notifications file into the /share/dbus-1/services directory so i can get stumpwm-notify up and running, and have tried everything from searching for packages to declaring it as an extra-special-file, but since it's a read-only dir nothing seems to work
<bigbookofbug>Tadhgmister: /home/user/.local/state/log
<Tadhgmister>bigbookofbug I am literally working on the same thing right now, it doesn't look like it is properly implemented for home dbus service
<bigbookofbug>oooooh oof
<bigbookofbug>stumpwm too ?
<bigbookofbug>i wonder if looking at the dbus services file for root might shed any light on how it could be translated to the home env
<Tadhgmister>it might just need to pass `--config-file` to an xml that lists `.guix-home/profile/share/dbus-1` as a directory having services
<Tadhgmister>for what ever reason the root one doesn't use the --config-file option instead it populates /etc/dbus-1/
<RavenJoad>Tadhgmister: If you created the service & shepherd-service, shepherd-service lets you specify the log-file for the program.
<RavenJoad>I am not sure where the default one goes to though. Perhaps /run/user/$UID? or $HOME/.local/var/log?
<Tadhgmister>`~/.local/state/log/shepherd.log` had the detail I needed for that moment as bigbookofbug mentioned I will probably include a log file but I got very side tracked looking at passing a config file to the home dbus service
<RavenJoad>bigbookofbug: Perhaps you could install a special file? The only other way would be to teach Guix how to accept arbitrary file-like objects through a configuration.
<bigbookofbug>RavenJoad: as in through extra-special-files ? i think i tried that, but i may have done it through home-files-service-type. i'll attempt that
<bigbookofbug>services like dunst seems to be able to point to .guix-home/share/dbus/services as part of their build process, so maybe making a small package for it could be a method as well
<Tadhgmister>bigbookofbug I got it working like I suspected it would here https://github.com/tadhgmister/dotfiles/commit/f8d14c2869b281de317742a8b9a9cfce4659d457#diff-c1d1d9a1bb028378d2bee25de1dbcd1377fbfdf64d6e66cd1999871bc499d949
<peanuts>"added dbus temporary fix ? tadhgmister/dotfiles@f8d14c2 ? GitHub" https://github.com/tadhgmister/dotfiles/commit/f8d14c2869b281de317742a8b9a9cfce4659d457#diff-c1d1d9a1bb028378d2bee25de1dbcd1377fbfdf64d6e66cd1999871bc499d949
<Tadhgmister>dunst does fail because it doesn't seem to have the right environment variables so this isn't necessarily a fill fix but adding a config file to the home dbus that points to the folders we could reasonably expect services to be would probably be a good idea
<Tadhgmister>wait... it is saying it already requested a config file from a store file, there is almost certainly a proper way to do that that I am unaware of
<bigbookofbug>special file still generates the "read-only directory" error on reconfigure
<bigbookofbug>Tadhgmister: i might try a modified version of this to see if i can get the notifications file to generate
<Tadhgmister>I was literally in the process of making a `dunst` service to write the config file in guile when I realized the thing about dbus letting things get auto-started
<Tadhgmister>and when you mentioned the auto-start I figured I should try
<lykso>Is there any way to define a package with multiple source inputs?
<Tadhgmister>lykso I also wondered this but then I learned that the source is treated as an input called "source" and that utilities like "guix refresh" doesn't really make sense with 2 sources, so any case I thought of it made more sense to have one of the sources just an input
<lykso>So, how did you do that?
<lykso>I've got a package defined for the files I want, but I'm not sure how to refer to those files from the other package's definition now. I can get the source package's output directory with "derivation->output-path", but then wouldn't I have to "install" those files to use them?
<Tadhgmister>can you give me more context, what is the package and what are the 2 sources
<Tadhgmister>I think you can just stick the origin record in the inputs list but if you are talking about installing both instead of just grabbing files from one during build phases I'm not sure I understand your usecase
<Tadhgmister>like `(inputs `(("toolssource" ,(origin ....)) ("jdk" ,icedtea "jdk") ...)` is how I remember doing it, then in the build process doing `(assoc-ref #$inputs "toolssource")`  but I might be misremembering which parts of my bodges actually worked
<lykso>Tadhgmister: Thanks, those are some new keywords I can start digging with.
<Tadhgmister>if that doesn't work defining a package with copy-build-system and the desired origin would be the "proper" way
<lykso>Specifically I have a git repository with patches I want to apply to an origin I'm passing to "customize-linux"
<Tadhgmister>ok wait, if your "second source" is for patches why are you not using the patches field of the origin record?
<Tadhgmister>like it is multiple patch files in one repo that need to all be applied? that is maybe a little complicated, but if you can specify each patch with it's own origin record you can just pass that to the patches field of the source origin record
<lykso>There are other things besides patches in the git repository, and there are different sets of patches for different kernel branches as well, so I need to be able to specify a subdirectory to recursively include from the patch origin or package.
<lykso>I have a function that can take a path as a string and give me a list of paths to patches
<lykso>But I can't figure out how to go from the origin or package with the patches to a path which can be passed to that function
<lykso>I've also got a couple other use cases where I'll need to do something similar, but referring to those files in, e.g., a build phase
<lykso>I've tried gexps and the store monad, but haven't managed to get anything to even compile with those
<lykso>I'm using the store explicitly now, and that at least compiles, but I don't see a way to refer to the source files in a derivation, which makes it seem like I'll have to copy the files from the source and into an output directory... which seems like unnecessary duplication.
<lykso>It'd be nice if i could just grab a file or archive or repository, chuck it into the store, and get a path to it.
<Tadhgmister>in theory gexps would be the thing that can do that, if you had a variable XX that was set to an origin reference for the patches a snippet that does `#$XX` should give you the path to the store of that code as a string when it evaluates
<Tadhgmister>so like `#~(begin (invoke "patch" "-i" (string-append #$XX "/a.patch"))` might be worth trying as the snippet option
<Tadhgmister>or something along those lines, I can't remember the scheme way to call patch
<xerty>Hi, it seems now when setting GTK_IM_MODULE=wayland, apps like nheko and icecat would fail to pull the file picker and result in immediate abort, has anyone got similar results? (
<xerty>that is also true for a file save option, which also pulls a file picker( and I'm using GNOME 44
<KE0VVT>Cannot see commands in htop: /gnu/store[cutoff].
<xerty>Sorry, it seems it was fixed already
<lykso>Here's what I'm trying to get to work: https://paste.debian.net/1316597/
<peanuts>"debian Pastezone" https://paste.debian.net/1316597
<lykso>Gives me "Wrong type (expecting string): #<gexp (string-append #{$#mnt-reform-debian-packages}# "/linux/patches6.1") /home/user/mnt-reform-nonguix/mnt-reform/imx8mq.scm:73:6 ffff7a29e840>"
<lykso>Is there some way to eval a gexp?
<Tadhgmister>almost certainly, but I was thinking you'd be passing it to the snippet field of the origin of the other package to apply the patches which expects a gexp
<lykso>Tadghmister: Okay, I understand now. This seems like a very promising route. Thanks!
<lykso>Got something that looks promising, but it's complaining about "invoke" being an unbound variable
<lykso>Figured it out. Was missing (use-modules (guix build utils))
<lykso>Looks like I can't invoke patch from a snippet for some reason
<lissobone>Okay, so, I want to use Udisks on my GNU system. I added a "(service udisks-service-type)" line to my system configuration file. But when I attempt to reconfigure the system, it throws a curious error that building of dbus-system-services.drv failed. In the logs it also says "ERROR: In procedure symlink: File exists".
<lissobone>Has anyone encountered anything like that before?
<lissobone>I am pretty sure it is not normal behavior.
<lissobone>Huh... I considered running 'guix pull' followed by 'guix package -u' to get up-to-date packages, blah blah blah, and it fixed itself. Like, cool.
<lissobone>Nah, it didn't. In addition to that, it now says "find-files: /gnu/store/86i7liph73f7y2ak4fakzj82qi3rvc74-gdm-44.1/share/dbus-1/: No such file or directory".
<lissobone>I do not know what to do with this information.
<ngz>Hello Guix
<Kristofer>Hi everyone! I have managed to get myself into some mess with my Guix install, probablt through Guix Home. After a "guix home reconfigure" I can't now use my Guix command in "~/.config/guix/current/bin/guix". This is the backtrace I get:
<Kristofer>Backtrace:
<Kristofer>          11 (primitive-load "/home/dev/.config/guix/current/bin/guix")
<Kristofer>In guix/ui.scm:
<Kristofer>   2312:7 10 (run-guix . _)
<Kristofer>  2275:10 9 (run-guix-command _ . _)
<Kristofer>In ice-9/boot-9.scm:
<jpoiret>Kristofer: you should use paste.debian.net to paste backtraces
<Kristofer>jpoiret: Check! Here is a pasbin: https://paste.debian.net/1316604
<peanuts>"debian Pastezone" https://paste.debian.net/1316604
<jpoiret>Kristofer: do you have guile installed as a package in your guix home profile?
<Kristofer>jpoiret: Yes I have "guile-next" in my guix home profile (I have been thinking that it could be the reason behind it).
<Kristofer>But I don't know how to "reverse" it now, because I can't use my guix command
<jpoiret>if you start a new shell, then delete the guile-related variables like `GUILE_LOAD_PATH` and `GUILE_LOAD_COMPILED_PATH`, maybe you should be able to use the guix command?
<Kristofer>I tried unset:ing both of those but I doesn't help unfortunatly. I get the same error when trying guix pull after
<graywolf>Hi :) Would some commiter have time to look at https://issues.guix.gnu.org/70112 ? It was tested both by me and by other user and seems to work.
<peanuts>"[PATCH 00/11] Update container tooling (podman, buildah)" https://issues.guix.gnu.org/70112
<graywolf>There already is new version of both buildah and podman, and it would be great to be able to send those as separate patches instead of redoing this series (again)...
<tjout>I want to run smartd to monitor all disks on my system. Following the documentation I created a simple-service. However when trying to reconfigure Guix screams at me about some invalid field specifier. What am I missing?
<tjout>(simple-service
<tjout>                    'smartd-service
<tjout>                    shepherd-root-service-type
<tjout>                    (list
<tjout>                        (shepherd-service
<tjout>                            (documentation "Monitor disks for failure.")
<tjout>                            (provision '(smartd))
<whynt>What would the process of congealing a system I've got installed to a machine onto a flash drive to be live entail?
<bienjensu>whynt: Have a look at `guix system image`. You'll likely want `--image-type iso9660` with which you can use `--label` to label the volume, then use the label to specify it in a file-systems declaration.
<bienjensu>there's more information in the manual
<bienjensu>Has anyone made an APE (actually portable executable) build of the guix binary?
<lissobone>Not me!
<lissobone>I observe weird stuff. Whenever I enable the 'linux' service module in the system configuration and reconfigure the system (...the next logical step), it reports: "Unrecognized keyword: #:linux".
<lissobone>And it is only the service module line, in no other place does linux cause any problems.
<JetpackJackson>Hi, i'm new to Guix and IRC, and I'm trying to write a scheme to package the arduino-cli but i'm running into some issues. is there a way for me to send my arduino.scm file?
<wakyct>you can paste it JetpackJackson like at https://paste.debian.net/
<parnikkapore>^
<peanuts>"Debian Pastezone" https://paste.debian.net
<wakyct>btw there has been some discussion on this that might help
<JetpackJackson> https://paste.debian.net/1316629/ heres my file
<peanuts>"debian Pastezone" https://paste.debian.net/1316629
<wakyct> https://logs.guix.gnu.org/guix/search?query=arduino-cli
<peanuts>"Search guix IRC channel logs" https://logs.guix.gnu.org/guix/search?query=arduino-cli
<JetpackJackson>im also searching the logs for "arduino"
<JetpackJackson>ah thanks
<wakyct>what issues are you seeing?
<JetpackJackson>i cant get it to build/install
<wakyct>can you paste the output?
<JetpackJackson>yeah working on it
<JetpackJackson> https://paste.debian.net/1316631/
<peanuts>"debian Pastezone" https://paste.debian.net/1316631
<wakyct>not sure if this has been discussed on the mailing list or bug list yet, might be good to get a more permanent record
<wakyct>this is also on my todo list
<JetpackJackson>arduino stuff you mean?
<wakyct>yeah
<wakyct>to get it working, I switched to Guix a few weeks ago
<JetpackJackson>ah gotcha
<JetpackJackson>im tinkering with guix as an alternative to nix for development enviroments
<JetpackJackson>ok the logs say theres a way to use it with emacs somehow
<JetpackJackson>i dont use emacs tho lol
<JetpackJackson>i first tried to get guix to install the precompiled binary but it didnt work but im trying to get it to compile and thats what im having issues with in my scm file
<wakyct>so that's a source tar ball in the package definition?
<wakyct>where did you get the arduino.cc link from?
<wakyct>I thought the releases were on github
<wakyct>regarding emacs I think that's just referring to an emacs mode, not an alternative way to get it to work
<lykso>This is driving me a little nuts, so I'm hoping someone can help me figure this out. I'm getting "no code for module (gnu packages base)
<wakyct>I just noticed something odd, a week or so ago I installed gvfs system wide and then my FM Thunar was able to do gvfs things (it was enabled in Thunar preferences), But now Thunar can't see gvfs anymore
<wakyct>gvfs is still installed in the store, has anyone seen something like this before?
<lykso>" when I try to #:use-module, but (gnu packages linux) loads just fine. Even passing a checked out guix repository via -L doesn't resolve the error.
<lissobone>Even if something is present in the store, that doesn't mean it is running. Make sure your current system configuration includes the gvfs service thingy!
<lissobone>For info: the provenance meta-data about the system is managed by the service called "provenance". It creates several files under '/run/current-system', such as 'configuration.scm' and some others. Check your '/run/current-system/configuration.scm'! (It's not an order, I am not commanding you, just a friendly advice).
<wakyct>thanks lissobone, I'm looking for the service now though not finding anything so far
<wakyct>the weird thing was it did work when I reconfigured the first time I added gvfs
<JetpackJackson>wrt earlier i got the arduino.cc link from the page on how to install the cli https://arduino.github.io/arduino-cli/0.35/installation/#download
<peanuts>"Installation - Arduino CLI" https://arduino.github.io/arduino-cli/0.35/installation/#download
<wakyct>so maybe the service didn't restart, but I don't see it in the herd list
<JetpackJackson>so strange to me that i have to look at the logs to view the messages i missed lol
<JetpackJackson>im used to other chat programs ig
<lissobone>That might indicate that your system is currently using a configuration that is devoid of GVFS! When booting, did you select any "old" systems in the GRUB menu?
<wakyct>no, but I'll investigate, thanks lissobone
<wakyct>JetpackJackson, people usually use IRC bouncers to save messages
<lissobone>Well, uh... Not "might", it DOES show that...
<JetpackJackson>ah ok ill look into that then
<wakyct>some web IRC gateways do that for you as well
<wakyct>or non-web, etc
<lissobone>You know, I am still kind of a guix noob as of now, so I don't really know what does it mean when a service is absent from the 'herd status' list... But I will read the info docs right now!
<JetpackJackson>im using hexchat rn but im gonna try out pidgin and then find a bouncer
<lissobone>Hey, I am using ERC with GNU Emacs! (definitely not boasting)
<JetpackJackson>man emacs has everything huh
<lissobone>Yeah, it's like a little dark world... Or a light world, depending on your theme
<JetpackJackson>i installed it just to see what it was all about and theres a little therapist chatbot-type thing? and a calendar?
<JetpackJackson>crazy
<lissobone>Yes, you are right. Technology of the 80's.
<JetpackJackson>Client: HexChat 2.16.2 • OS: ArchLinux • CPU: Intel(R) Pentium(R) CPU B960 @ 2.20GHz (2.19GHz) • Memory: Physical: 15.1 GiB Total (12.4 GiB Free) Swap: 1000.0 MiB Total (1000.0 MiB Free) • Storage: 141.3 GB / 478.6 GB (337.2 GB Free) • VGA: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller @ Intel Corporation 2nd Generation Core Processor Family DRAM Controller • U
<JetpackJackson>ptime: 5h 38m 47s
<JetpackJackson>oops
<JetpackJackson>sorry
<JetpackJackson>i shouldve not clicked that
<lissobone>You have done a huge mistake by letting us know your preferences.
<lissobone>You should have not clicked that.
<JetpackJackson>i cant delete it either :(
<JetpackJackson>drat
<freakingpenguin>lissobone: Not all guix services are shepherd services, so that's why some services don't show up in herd status. Shepherd service = daemon, guix service = almost anything which may include daemons.
<lissobone>Well, thanks for info, though it got even more complicated.
<freakingpenguin>Well daemon or one-shot program I guess.
<lissobone>sudo herd status
<lissobone>Oops! Sorry!
<wakyct>yeah, I don't see a gvfs service, it must be something else
<wakyct>(guix shepherd service)
<lissobone>You might consider sandwiching it in in the services list.
<wakyct>don't see anything in dmesg...any ideas on where else to look for gvfs errors?
<lissobone>Perhaps... I have an idea.
<lissobone>Maybe somewhere in /var/log/?
<lissobone>I must do something urgent.
<Guest84>I have a self-defined guile module that I want to use in an mcron job running under guix home's shepherd. How do I make mcron aware of my module(s)? Will it use GUILE_LOAD_PATH if defined in home-environment-variables-service-type?
<wakyct>Guest84 I think there is an example in the manual under scheduled jobs that shows using a Guile module
<wakyct>I think you can set env variables as well?
<Guest84>wakyct: Perfect, let me have a look, thanks!
<wakyct>I don't know about inheriting env variables though
<Jetpack_Jackson>ok im back from trying to get znc working. it did not happen and ive somehow messed up my username in the process
<freakingpenguin>Guest84: One solution would be to put your module in a channel, add that channel to your configuration, pull, and ungexp as necessary. The other suggestion is probably much simpler so I'd try that first.
<Guest84>freakingpenguin: Eventually I will set up a channel for my own modules (soon, I hope), so I'll keep that in mind when I do.
<wakyct>Jetpack_Jackson, you probably can /nick <your name> to get your nick back
<wakyct>long term you'll want to register your nickname on Libera, I think they use NickServ
<Jetpack_Jackson>the command doesnt seem to be doing anything
<Jetpack_Jackson>oh i just found "/msg nickserv ghost nickname"
<wakyct>I could have it wrong, I always forget 90% of IRC commands
<Jetpack_Jackson>will that work here
<Jetpack_Jackson>its saying "JetpackJackson is not a registered nickname"
<wakyct>maybe Libera has stricter rules on claiming niks
<wakyct>you can try registering then
<Jetpack_Jackson>ah ok
<wakyct>maybe /msg NickServ register <nick> <pass>?
<Jetpack_Jackson>im looking at the thing and it says i need to switch to the nick i want first before i register
<Jetpack_Jackson>which is this without the underscore lol
<wakyct>if you look up Libera docs it's there, I was looking at it recently when I started using this client
<wakyct>for posterity's sake, I solved the gvfs issue by restarting Thunar (as usual ;) )
<wakyct>weirdly a system restart didn't solve it, so maybe Thunar starts before all the gvfs machinery is online
<Jetpack_Jackson>i still cant get the old nick back
<JetpackJackson>ah
<JetpackJackson>finally
<JetpackJackson>ok
<wakyct>wb, what did you have to do?
<JetpackJackson>time to register
<JetpackJackson>idk i just tried /nick JetpackJackson again
<JetpackJackson>and it worked
<JetpackJackson>what is a user cloak
<JetpackJackson>i almost panicked cause i saw the private/hidden messages from NickServ and thought it was sending messages everyone could see lmao
<freakingpenguin>That's a relatable feeling from a while back.
<JetpackJackson>glad to know its not just me lol
<freakingpenguin>I use stumpwm which lets me click on other windows without losing focus. If I'm not careful I can forgot IRC is focused and start spamming chat.
<JetpackJackson>oh neat
<JetpackJackson>ok im gonna try searching the logs for arduino-related stuff again
<Guest84>Is there a way to run the mpd-service-type from Guix Home whilst using the user's existing PA/Pipewire session?
<wakyct>is it not working Guest84 or are you wondering?
<Guest84>Sorry, I believe someone just replied to me but the notification crashed the web client. Could that person repeat themself please?
<wakyct>classic :). I was wondering if you had tried something that wasn't working or are you wondering if it's possible
<Guest84>wakyct: I'm in the process of trying, but I haven't actually finished testing. I ask (probably too eagerly) because of issues I've read about with it
<Guest84>So I guess I was wondering if anybody had had success reusing the system service with guix home
<Guest84>the issue would be that it starts its own PulseAudio service, but I want it to use my user's audio server (in my case pipewire)
<Guest84>As for trying it myself, I'm stuck with a mysterious error trying to reconfigure my home: "guix home: error: no target of type 'system' for service 'boot'" (probably something to do with trying to run a system service from guix home, but I don't really know)
<Guest84>That happens when adding this service definition: (service mpd-service-type (mpd-configuration (music-directory "~/files/music") (db-file "~/.cache/mpd/db")))
<wakyct>try this way perhaps https://www.reddit.com/r/GUIX/comments/qnioet/mpd_in_guix_system/
<wakyct>it sets up a shepherd service in home
<wakyct>I've not tried it myself though
<wakyct>mpd runs as its own user normally, so maybe this is the conflict
<lissobone>Sorry for leaving you alone in the darkness... I was just checking my gvfs daemon. It really doesn't show up in the output of 'herd status', but it sort of is there. At least now I can access the photographs from my camera via USB!
<lissobone>Nerd status, ha-ha... How funny.
<lissobone>Oh god... Oh no... While checking the photos, I saw a photogrpah of my face... I won't be able to sleep.
<lissobone>It scared me. I feel hopeless.
<lissobone>I remember that photo, but for some reason it feels quite different now... Things have gotten very, very interesting.
<lissobone>Okay, I already forgot who had problems with GVFS not doing its job, but whoever you were, report! How is it going?
<Guest84>wakyct: Thanks, I had read and thought to use it as a last resort because I'd rather reuse services if possible. But it looks like the way!
<Guest84>I had read that post*
<wakyct>I think I saw somewhere how you could start mpd as a system service but as your user?
<wakyct>but the person trying that had other issues, maybe fixable in jack though
<wakyct>lissobone, that was me, it's fixed. Restarted my FM. Restarting the system didn't fix it though, so some kind of dependeny issue on startup
<Guest84>wakyct: Yeah I recall reading something along those lines in an early post on Guix Home... But I haven't found said post. Memory doesn't always serve.
<wakyct>has anyone played around with audio stem separation on Guix? I'm running a job with demucs on Windows right now and I'd like to do that with Guix on that machine, but demucs looks like kind of a hairball to package
<miaomiao>I am not sure if I should ask this here or not, but I'm having trouble figuring something out. I have installed a program called fractal, a matrix client, through flatpak. If i launch this via `flatpak run org.gnome.Fractal` it appears to work fine. The problem seems to be with the Gnome 'show apps' menu, which has it listed, but refuses to launch it when selected. I can paste the exec= command of any .desktop file I can find for fractal o
<miaomiao>n my systerm into a terminal window and it works as expected. But Gnome refuses to launch whatever .desktop file is in that applications menu. I have no idea what the issue is. Has anyone seen something like this before?
<miaomiao>I found this reddit thread describing almost exactly my issue (though it's not in guix): https://www.reddit.com/r/gnome/comments/pvx8j4/gnome_apps_installed_through_flatpak_wont_launch/
<miaomiao>...with no solution, lol
<miaomiao>(I believe fractal is a gnome program)
<miaomiao>I will also see if there are gnome or flatpak channels here I can ask in, too.
<freakingpenguin>Anyone try installing guix on a rk3399 SoC lately?
<freakingpenguin>Or rather on a board with that soc
<podiki>miaomiao: likely you need to add the flatpak paths to one of the XDG env variables; flatpak should tell you when you run from a shell
<podiki>probably gnome (or any other launcher) won't find the .desktop files of flatpak programs as they are in some flatpak directory
<miaomiao>podiki, they are there. i can see the application in the menu just fine. but it doesn't do anything when clicked
<miaomiao>such a strange issue
<podiki>could be the .desktop file is out of date
<podiki>you can see what Exec= is in the .desktop file; i thought we stopped capturing paths that would go out of date though
<miaomiao>podiki: yeah, i found 3 separate .desktop files on the system, and all of the exec= commands in each of them work when pasted into a terminal window, which is the confusing part to me
<podiki>hrm
<miaomiao>it has to be using one of those, and if they all work in the command line but not thru the gui...i'm stumped
<podiki>have you tried another launcher? maybe it is gnome specific the issue
<podiki>(i don't use gnome but have launched flatpak stuff from rofi/dmenu successfully in the past)
<miaomiao>i can try with rofi or something probably, yes
<miaomiao>let's see...
<Kolev>I wish dmenu did .desktop files.
<miaomiao>truly i wouldn't be surprised if it's a flatpak thing, too. i am not the biggest fan
<podiki>yeah, it can be a bit clunky sometimes
<miaomiao>this might be the excuse i need to finally learn how to package something myself :P
<miaomiao>it appeasr to work through rofi drun mode. it must be a gnome+gnome program installed through flatpak thing. how bizarre
<podiki>fractal is written in rust? if so....good luck, might be a ton of packages (though i hear the importers is good)
<podiki>well, maybe that means not guix related? or something we need to configure/adjust for us?
<podiki>flatpak for us is only in --user mode, if that is anything related
<miaomiao>i don't *think* that would matter for this if it can be run outside of gnome shell's menu
<miaomiao>i still am not sure what causes this but i am convinced its not a guix thing, at least :)
<sneek>Welcome back podiki!
<miaomiao>in any event thank you for walking through it with me, podiki. i have been so lost in the weeds i'm not sure i would have thought to just use another launcher, lol. i am one step further along troubleshooting than i was before
<podiki>welcome! i remember having issues first using flatpak with how to launch things and understanding flatpak
<podiki>not that i understand much now since luckily i don't need to use it very often
<Guest70>I am trying to package `kanata` the keyboard custimization rust program. I've gotten quite far through the dependencies. However, when building it seems to also want to include dependencies that are gated behind `[target.'cfg(target_os = "macos")'.dependencies]'
<Guest70>is the guix import or cargo build system failing to see that this is not building for a mac platform?