IRC channel logs

2024-04-28.log

back to list of logs

<Kolev>efraim: How do I get this module to work? https://codeberg.org/csh/chromebook-guix/issues/1#issuecomment-1792156
<freakingpenguin>Kolev: For those errors I find running guix repl <file> usually spits out something more precise.
<wakyct>Kolev, is your load path including your module source directory?
<Kolev>wakyct: Fixed GUILE_LOAD_PATH. It looks like it's trying to build.
<wakyct>nice
<Kolev>How long should "building /gnu/store/d4sgwln8w6fqk97fyvrkzm248v9a6hmc-guix-packages-base.drv..." take?
<ajarara>substitute* breaks binary files (looking at eu-readelf -h output the entry point address shifts). See https://paste.debian.net/1315388/ as the example I have.
<peanuts>"debian Pastezone" https://paste.debian.net/1315388
<ajarara>as in, it breaks even if there are no actual substitutions
<ajarara>unsure what entry point address actually means, and yes I want to build this (FOSS) binary from source but figuring out how to get node to work is not a weekend problem
<ajarara>by 'break' I mean I get 'Exec format error' where before a subsitute run I get a different, more obvious error
<KE0VVT>Is there a reason why tmux plugin manager will not run?
<bienjensu>Having a slight problem with `guix gc`. I ran it for the first time in about a year (I know) and it was collecting around 250gb of trash. I used the duration flag. While removing /gnu/trash, after having apparently successfully collected, the process exited for some reason. Now running `guix gc` just reports "finding garbage collector roots..." and seems to hang? Planning to let it run overnight.
<bienjensu>The guix daemon is running pretty hot, and there's occasional spikes of btrfs-endio-meta kworkers.
<KE0VVT>Hi, Kolev here. Still no code for module. Is sudo messing with variables?
<bienjensu>Oh I think I hit a known sore spot with btrfs https://issues.guix.gnu.org/51787#25-lineno104
<peanuts>"GC takes more than 9 hours on berlin" https://issues.guix.gnu.org/51787#25-lineno104
<bienjensu>moral of the story is to gc often
<coyote>KE0VVT: did you try `guix system -L (path of module) reconfigure`?
<coyote>maybe that'll tell us if sudo is messing with the environment or not, although i dont think that's the case
<coyote>sometimes when a module has an error Guix (in my experience, at least) will simply bail out saying "no code for module"
<KE0VVT>coyote: Aha! I was doing `GUIX_LOAD_PATH=$dir sudo guix time-machine`...
<coyote>in that case it might help opening the REPL and trying to load it manually
<coyote>KE0VVT: I'm not saying that's the cause of your error, just trying to check
<coyote>also, that variable should be GUILE_LOAD_PATH.
<coyote>I think
<KE0VVT>coyote: So you're saying, try loading the module in a REPL?
<coyote>Yeah, that could tell you what's happening that Guix is not loading the module
<coyote>`guix repl -L ...` and then do `(use-modules (...))`
<KE0VVT>coyote: https://0x0.st/XHxV.txt
<coyote>you have to wrap it in parentheses: `(use-modules (chromebook alsa-lib))`
<KE0VVT>coyote: scheme@(guix-user)> (use-modules (chromebook alsa-lib))
<KE0VVT>scheme@(guix-user)>
<coyote>hm, so there's nothing wrong with your module. ok
<coyote>I'm assuming you haven
<coyote>pressed enter accidentally.
<coyote>I'm assuming you haven't tried reconfiguring with the -L flag yet?
<coyote>seems like there's no reason it shouldn't work with the directory in your load path
<KE0VVT>coyote: I used -L $HOME/Projects/chromebook-guix
<KE0VVT> https://bpa.st/2QEQ alsa-lib.scm
<peanuts>"View paste 2QEQ" https://bpa.st/2QEQ
<coyote>hm
<coyote>yeah, im not really sure what's going on then, sorry :-(
<KE0VVT>coyote: Thanks.
<KE0VVT>What is modprobe? How do I change its settings?
<KE0VVT>These instructions say I need to change an environment variable to point to some files, and change modprobe settings. https://raw.githubusercontent.com/chrultrabook/docs/a281259c3016d754540500e4eeea40874098b8eb/src/docs/installing/distros.md
<coyote>modprobe is for loading kernel modules, you can configure it with a service definition in your system configuration https://guix.gnu.org/manual/en/html_node/Linux-Services.html#Kernel-Module-Loader-Service
<peanuts>"Linux Services (GNU Guix Reference Manual)" https://guix.gnu.org/manual/en/html_node/Linux-Services.html#Kernel-Module-Loader-Service
<KE0VVT>coyote: I haven't even done it the normal way.
<coyote>well, each kernel module has an identifier where you can load it with the command `modprobe` while the system's running, or at boot with modprobe configuration files. probably the Arch Linux wiki page on it may help https://wiki.archlinux.org/title/Kernel_module :-)
<peanuts>"Kernel module - ArchWiki" https://wiki.archlinux.org/title/Kernel_module
<KE0VVT>coyote: The files are supposed to be somewhere on the file system, but we all know what happened to the file system when Guix was designed.
<KE0VVT>So I have to understand both Python and Scheme to get audio working...
<coyote>would be much easier if the script linked in the page had a dry run option, heh X(
<coyote>seems the most important function is here https://github.com/WeirdTreeThing/chromebook-linux-audio/blob/de640dc3c80f53ff16b7f303f0046e22c2cde1c8/setup-audio#L85C1-L109C16, matching the board to what settings/etc. it installs
<peanuts>"chromebook-linux-audio/setup-audio at de640dc3c80f53ff16b7f303f0046e22c2cde1c8 ? WeirdTreeThing/chromebook-linux-audio ? GitHub" https://github.com/WeirdTreeThing/chromebook-linux-audio/blob/de640dc3c80f53ff16b7f303f0046e22c2cde1c8/setup-audio#L85C1-L109C16
<KE0VVT>coyote: I see. My head hurts.
<KE0VVT>coyote: Now I don't know which files I need for my computer.
<wakyct>KE0VVT, if you want to hear audio, maybe just get a usb audio dongle. Then this is not such a blocker and you can work on it as you like.
<KE0VVT>wakyct: I have my real computer that has audio, if I really need it.
<wakyct>even better, you can just network your audio with pipewire ;)
<KE0VVT>wakyct: I'm not opposed to PipeWire. I just don't know what I'm doing and got into something way over my head.
<wakyct>well kudos to you for wanting to re/use hardware
<ajarara>yep, hunch was right, writing the updated position in place was what I needed to do https://paste.debian.net/1315396/
<peanuts>"debian Pastezone" https://paste.debian.net/1315396
<trig_function>How do I obtain the wayland-scanner? I want to build a library statically but I get the following error: Failed to find wayland-scanner.
<trig_function>What package is required for this to work?
<trig_function>ok this was a stupid question. got it, sorry
<Altadil>Hi, I can’t reconfigure my system anymore. I get the following error: https://paste.debian.net/1315404/
<Altadil>Was there recently a change in the expected syntax for the os declaration ?
<peanuts>"debian Pastezone" https://paste.debian.net/1315404
<jonsger>ACTION got icedove@115 working. Sadly only the icedove-minimal package...
<nathan_>the patch to fix the system reconfigure errors is here: https://lists.gnu.org/archive/html/guix-patches/2024-04/msg01679.html
<peanuts>"[bug#70598] [PATCH] system: fix duplicate nss-certs check" https://lists.gnu.org/archive/html/guix-patches/2024-04/msg01679.html
<bdju> https://0x0.st/XHg6.txt krita build failure. might've already mentioned it some days ago but I just tried to update again and it still isn't fixed. I'll skip it for now.
<bdju>qtbase failure too if I skip krita
<apteryx>bdju: which architecture?
<apteryx>bdju: 'guix weather qtbase' reports https://bordeaux.guix.gnu.org has a substitute for it
<peanuts>"bordeaux.guix.gnu.org Build farm" https://bordeaux.guix.gnu.org
<apteryx>nathan_: thanks for the patch! I'll apply it shortly
<apteryx>it's funny, I think I had a bad dream about that bug I introduced ;-)
<apteryx>LGTM, I'll push it in a minute
<apteryx>nutcase: look at (info '(guix-cookbook) Dynamic DNS mcron job') for an example
<apteryx>you need the guile-gnutls extension, which is required by the (web client) module
<apteryx>ieure: I applied your librewolf update; thank you!
<cancername>Hi! I'm trying to create a service to run a program, after making a shepherd-service as described here <https://guix.gnu.org/manual/devel/en/html_node/Shepherd-Services.html>, how may I add it to my system config? I tried to add it to (operating-system (services)), but that fails, expecting a struct.
<dariqq>cancername: you'd need to extend the shepherd-root-service-type with your service. The simplest way I think is using a simple-service : https://guix.gnu.org/manual/devel/en/html_node/Service-Reference.html#index-simple_002dservice
<peanuts>"Service Reference (GNU Guix Reference Manual)" https://guix.gnu.org/manual/devel/en/html_node/Service-Reference.html#index-simple_002dservice
<cancername>dariqq: I'm trying to do that, but adding either (simple-service (simple-service 'name shepherd-root-service-type (shepherd-service ...))) or (service (simple-service (simple-service 'name shepherd-root-service-type (shepherd-service ...)))) fails with "wrong type argument".
<dariqq>i think it should be a list. i.e (simple-service 'name shepherd-root-service-type (list your-service))
<cancername>thanks, that worked! tangentially related, but I've been meaning to ask: what's the difference between (list ...) and '(...)?
<dariqq>awesome :)
<nathan_>thanks
<Kolev>Efraim: Oh, sorry. Have fun!
<efraim>Kolev: no worries!
<apteryx>Altadil: if you 'guix pull', it should be resolved
<dariqq>cancername: https://www.gnu.org/software/guile/manual/html_node/Expression-Syntax.html maybe this helps
<peanuts>"Expression Syntax (Guile Reference Manual)" https://www.gnu.org/software/guile/manual/html_node/Expression-Syntax.html
<cancername>thanks! will read.
<imadnyc>Hey, I'm trying a simple derivation where I'm building https://git.sr.ht/~rafael/gembro/commit/master, a simple go package. When I "guix-build -f gembro.scm", though, I get the error "%exception #<&invoke-error program: "go" arguments: ("install" "-v" "-x" "-ldflags=-s -w" "") exit-status: 1 term-signal: #f stop-signal: #f>". Can anyone help me troubleshoot? I don't know what this really means
<peanuts>"~rafael/gembro: Remember scroll position - sourcehut git" https://git.sr.ht/~rafael/gembro/commit/master
<imadnyc> https://paste.debian.net/1315424/
<peanuts>"debian Pastezone" https://paste.debian.net/1315424
<Altadil>apteryx: Thanks, it indeed worked. :)
<nathan_>imadnyc: you have to scroll up in the build log to see why the go command failed. i dont know go, but the go-build-system documentation at least says that you need to provide #:import-path in the `arguments' of the package.
<imadnyc>Yea, I saw that, but I assumed that it would take some sort of default? I'm not familiar with Go either, but I was able to write this nix derivation here https://github.com/NixOS/nixpkgs/pull/301308 and assume Guix would be generally the same -- not sure what the paths are
<peanuts>"gembro: init at unstable-2022-01-25 by imadnyc ? Pull Request #301308 ? NixOS/nixpkgs ? GitHub" https://github.com/NixOS/nixpkgs/pull/301308
<nutcase>apteryx: Thank you, I already solved my issue. The problem was an empty $SSL_CERT_DIR env var
<freakingpenguin>Any chance someone with commit access could look at https://issues.guix.gnu.org/70085? Just a minor annoyance when I SSH into my server.
<peanuts>"[PATCH] home: services: add newline to XDG_RUNTIME_DIR warning" https://issues.guix.gnu.org/70085
<afm-victoria>ieure: yesterday I shared a pastebin with a Clojure class not found error. On a foreign distro, it goes away when I use your version of clojure-tools from bin-guix
<afm-victoria>On a native guix system, I had to import the class from the main namespace in my program, which made it avaiable in the system. Upgrading to your version of clojure-tools was not sufficient. My guess is that on the foreign distro the class was loaded when I reverted to the Fedora-installed version of Clojure tools and was thereafter available.
<afm-victoria>Lots of funky issues with the "new" tooling, I think.
<afm-victoria>Not you but the Clojure team tools
<afm-victoria>But I learned a ton